SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

Author Topic: Problem with recognition CLX-3185 FN under Xubuntu 16.04  (Read 617 times)


  • Testing the water
  • **
  • Posts: 2
    • View Profile
  • Linux Distribution: Ubuntu 12.04
  • Printer: SCX-4216F
Problem with recognition CLX-3185 FN under Xubuntu 16.04
« on: November 08, 2016, 13:08:51 »

For a couple of days I have been trying to get Scan to PC and/or Scan to PC GUI to work with SCX-3185FN. I have tried under Xubuntu 16.04 (64-bit), and - since it did not work - alternatively under Ubuntu 14.04 (i386).

Basically the scanner gets recognised (e. g. under Xsane, also under scanimage - L and netdiscovery), but - according to log - after the service recognises the device, it ends with some error, and on scanner I always get "not available".

I tried experimenting with several different versions of drivers (3.x, 4.x, 1.x...), but it did not resolve the issue. I also tried changing config files, as described under Scanning Questions (such as setting tcp address in .conf files). I also completely disabled the firewall.

I have a couple of question:
1. Under which Ubuntu (Xubuntu) version is Scan to PC working, preferably with my scanner model?
2. Does the Samsung driver has its support of Scan to PC?
3. Is it enough to select Scan to PC (and/or GUI version) from Synaptic with its (default) dependencies, or do I need to install some extra packages?
4. What else could I try?

If you want, I will attach my logs as well.

Best regards,


  • Administrator
  • *****
  • Posts: 493
    • View Profile
  • Linux Distribution: Debian Testing
  • Printer: none
Re: Problem with recognition CLX-3185 FN under Xubuntu 16.04
« Reply #1 on: November 12, 2016, 07:45:20 »
1. The last report I have of a working install is Ubuntu 14.04.  I have no idea if that means it isn't working later or not.  As far as models, whatever has been posted to this forum is what I know.
2. Scan to PC is independent of the driver, and should theoretically work with any version.  However, the driver-4.xx versions are probably the only ones that received significant testing.
3. As of the last time packages were updated (3 years ago), there was no need to install additional dependencies.
4. I don't know.  The developers have not contributed anything in 3 years, likely because they are no longer using it themselves.  I have never had a system with which to test this.  The project is effectively abandoned unless someone wants this functionality badly enough to work on the code and update it.  It is possible that a change associated with changing to systemd are why the service no longer works as expected, and it might be an easy fix for someone with time and enough knowledge.


Repository Information Legal Contact Alternative Drivers