SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

Author Topic: broken packages suld-configurator-2-qt4  (Read 29 times)

Yana

  • Testing the water
  • **
  • Posts: 1
    • View Profile
  • Linux Distribution: Debian Jessie
  • Printer: Samsung 4321
broken packages suld-configurator-2-qt4
« on: October 27, 2017, 07:17:21 AM »
Hello, I'm trying to install SCX 4321 to scan documents:
mcedit /etc/apt/sources.list

deb http://www.bchemnet.com/suldr/ debian extra

Close and save.

apt-get update
 
apt-get install suldr-keyring
apt-get update
apt-get install suld-driver-3.00.37
all is well
root@dhcppc0:/home/liana# apt install suld-configurator-2-qt4
Reading Package Lists ... Done
Building a Dependency Tree
Reading status information ... Done
Some packages can not be installed. Perhaps you are asking for the impossible,
or use an unstable version of the distribution, where you requested
packages are not yet created or have been removed from Incoming.
The following information may help you:

Packages with unsatisfied dependencies:
libvlccore8 : It breaks: vlc (< 2.2.4-7~) но 2.2.0~rc2-2+deb8u1 will be installed
               It breaks: vlc-nox (< 2.2.4-7~) но 2.2.0~rc2-2+deb8u1 will be installed
E: Error, pkgProblemResolver :: Resolve generated corrupted packages. This can be caused by delayed (held) packets.

sources.list
# deb cdrom:[Debian GNU/Linux 8.1.0 _Jessie_ - Official i386 kde-CD Binary-1 20150606-13:00]/ jessie main
 
# deb cdrom:[Debian GNU/Linux 8.1.0 _Jessie_ - Official i386 kde-CD Binary-1 20150606-13:00]/ jessie main

deb http://ftp.ua.debian.org/debian/ jessie main
deb-src http://ftp.ua.debian.org/debian/ jessie main

deb http://security.debian.org/ jessie/updates main
deb-src http://security.debian.org/ jessie/updates main

# jessie-updates, previously known as 'volatile'
deb http://ftp.ua.debian.org/debian/ jessie-updates main
deb-src http://ftp.ua.debian.org/debian/ jessie-updates main
deb ftp://ftp.debian.org/debian stable main contrib non-free
deb http://www.bchemnet.com/suldr/ debian extra
help me figure it out, if it's possible
p.s. at debian 7  everything worked

bchemnet

  • Administrator
  • *****
  • Posts: 480
    • View Profile
  • Linux Distribution: Debian Testing
  • Printer: none
Re: broken packages suld-configurator-2-qt4
« Reply #1 on: October 28, 2017, 07:50:39 AM »
You appear to have set up both the "stable" (currently Stretch) and "Jessie" repositories.  There may be some conflict there with the vlc libraries as a result.  Try disabling the "stable" repository, refreshing your lists, and installing the configurator package again.

Alternatively, installing the qt3 version should probably work, because the dependencies will mostly draw from the suldr repository rather than debian.

 

Repository Information Legal Contact Alternative Drivers