SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

Author Topic: [SOLVED] CPU Usage & Scanning Speed  (Read 1578 times)

cmer

  • Testing the water
  • **
  • Posts: 4
    • View Profile
  • Linux Distribution: Ubuntu 14.04.2 LTS
  • Printer: M2885FW
[SOLVED] CPU Usage & Scanning Speed
« on: December 22, 2014, 02:16:18 AM »
Hi everyone,

I have the sSS (0.4.5 from repo) running on a headless Ubuntu (14.04 Trusty) Server. It works well in general, when looking closer I have 2 issues:

1) When running, the ScannerServer generates a constant CPU load of about 5-10% (on an ASUS C60M1-I Mainboard /w dual core AMD C60 1GHz). Even if this mainboard is not exactly a screamer, this looks a bit much to me, considering that the scanner server does not do much until a scan job is triggered. Right? Does someone of you have an idea what might cause this?

2) I noticed, that while scanning from the ADF works, the next page is only pulled into the feeder after the last page was written to disk. This again takes quite a bit of time, which might be caused because the image transfer from the scanner to the server seems quite slow. This seems not to be a limitation by the scanner - scanning to an iPad is 5 times faster. (Scanning the same 5 pages (300dpi multipage pdf) took 155 sec to the linux server compared to 31 sec to the iPad). Might this have to do with how the image data is piped through? Would it be possible to eliminate 'wait states' in the program run?

Best
cmer
« Last Edit: April 12, 2015, 09:02:00 AM by cmer »

cmer

  • Testing the water
  • **
  • Posts: 4
    • View Profile
  • Linux Distribution: Ubuntu 14.04.2 LTS
  • Printer: M2885FW
Re: [dev] CPU Usage & Scanning Speed
« Reply #1 on: April 12, 2015, 07:37:24 AM »
Update:
I as well encountered a problem recently where the scanner wouldn't scan from the feeder. It would always scan from the scanner bed, no matter wether documents were in the feeder.

I today I wanted to track down the issue, and before trying anything else I just updated the (original Samsung) ULD to 1.00.35 - and now all of a sudden it all works again! Strange, but also the scan speed of multi-page images improved automagically to <5sec per page for 300dpi multi-page pdfs, grayscale (which I consider an absolutely adequate working speed).

- edit: Scan speed for 300dpi multi-page PDF in color is about 9-10sec per page (which more than 3 times faster than before) -

Now the only thing remaining is the slightly high cpu load when idling (and some error handling that produces some not-so-nice but obviously harmless log-entries).

Best
cmer
« Last Edit: April 12, 2015, 07:46:52 AM by cmer »

 

Repository Information Legal Contact Alternative Drivers