Samsung Unified Linux Driver Repository Forum

SULDR => Scanner Server (Scan to PC) => Topic started by: hustler77 on January 15, 2014, 11:53:45

Title: python-imaging vs python-imaging-sane in debian jessie
Post by: hustler77 on January 15, 2014, 11:53:45
Hi,

when I run an "aptitude full-upgrade", it wants to install python-imaging and uninstall python-imaging-sane.
As suld-scantopc depends on it, it would get uninstalled.

Die folgenden NEUEN Pakete werden zusätzlich installiert:
  python-pil{a}
Die folgenden Pakete werden aktualisiert:
  python-imaging
1 Pakete aktualisiert, 1 zusätzlich installiert, 0 werden entfernt und 0 nicht aktualisiert.
303 kB an Archiven müssen heruntergeladen werden. Nach dem Entpacken werden 337 kB frei werden.
Die folgenden Pakete haben verletzte Abhängigkeiten:
 python-imaging-sane : Hängt ab von: python-imaging (= 1.1.7-4) aber 2.2.1-3 soll installiert werden.
Die folgenden Aktionen werden diese Abhängigkeiten auflösen:

     Entfernen der folgenden Pakete:
1)     python-imaging-sane         
2)     suld-scantopc               
3)     suld-scantopc-gui

I guess the dependencies needs to be changed in the suld-scantopc  packages.

greets
Title: Re: python-imaging vs python-imaging-sane in debian jessie
Post by: totally-king on January 16, 2014, 20:32:26
Hi hustler77,
on my new ubuntu saucy machine the python-imaging-sane package also depends on a specific version of the python-imaging package, which is 1.1.7+2.0.0-1ubuntu1. So for python-imaging-sane to work you need a python-imaging which provides that version (in your case 1.1.7-4). Since suld-scantopc cannot work without the python sane library, the dependency is correct und must remain there. The error seems to be in your debian repository/ies, because with your current situation you cannot install python-imaging-sane at all. A workaround for you might be (if you really need the latest python-imaging) to remove the python-imaging-sane package as suggested, install the python sane library via PyPI (https://pypi.python.org/pypi/pysane/2.0.1) (the Python Package Index) and create & install a dummy .deb package that provides python-imaging-sane as needed by suld-scantopc. Another way could be to hold the current version of python-imaging until this repository bug is resolved. (You should consider reporting (http://www.debian.org/Bugs/Reporting) a bug.)
Code: [Select]
sudo aptitude hold python-imagingCheers, ~TK
Title: Re: python-imaging vs python-imaging-sane in debian jessie
Post by: hustler77 on January 17, 2014, 15:20:30
It looks like Virtuelles Paket: python-imaging-sane is now a virtual package in debian jessie:
http://packages.debian.org/de/jessie/python-imaging-sane
Title: Re: python-imaging vs python-imaging-sane in debian jessie
Post by: hustler77 on March 19, 2014, 12:52:38
found that in debian release notes

python-imaging (1.1.7+2.0.0-1.1) unstable; urgency=low

  * Non-maintainer upload
  * Rename python3-imaging* packages to python3-pil*
  * Rename python-imaging to python-pil and python-imaging-compat to
    python-imaging (use python-imaging until given package imports Image
    directly, i.e. needs .pth file)
  * Rename python-imaging-tk to python-pil.imagetk, provide the old name
  * Rename python-imaging-sane to python-sane, provide the old name
  * Rename other python-imaging-* packages to python-pil-* and Provide the old
    names
Title: Re: python-imaging vs python-imaging-sane in debian jessie
Post by: sakuvee on April 07, 2014, 14:24:56
I got this fixed as follows:

> apt-get download suld-scantopc
> dpkg --force-depends -i suld-scantopc_0.4.5-3_all.deb

Then I renamed the dependency in /var/lib/dpkg/status of "Package: suld-scantopc" so that the row:

Depends: python (>= 2.7), python (<< 3.0), python-imaging-sane (>= 1.1.7), ...

Became:

Depends: python (>= 2.7), python (<< 3.0), python-sane (>= 1.1.7), ...
Title: Re: python-imaging vs python-imaging-sane in debian jessie
Post by: bchemnet on May 04, 2014, 13:50:03
As a temporary fix, I will add both names as resolving this dependency to the latest release of this package.  Hopefully it won't cause additional problems for those using the newer library.