Samsung Unified Linux Driver Repository Forum

SULDR => Scanning => Topic started by: jonno on October 01, 2014, 13:07:02

Title: ADF trouble with SCX-4729
Post by: jonno on October 01, 2014, 13:07:02
I am running a SCX-4729 MFP over USB on Linux Mint 16 Petra. Printing works fine.

Scanning on the flatbed works fine, as does scanning a single sheet through the ADF.

When I first fire up the scanner, sane-find-scanner and scanimage -L both recognize the scanner.

However, as soon as I attempt so scan 2 or more pages through the ADF (e.g. through Simple Scan), as soon as the second page gets fed, the scanner loses connectivity and the scanner will drop off the scanimage -L list (although it is still recognized by sane-find-scanner). In XSane, if I try to scan 2 pages on the ADF, the first page will appear on the viewer, then an error message will appear onscreen:

Failed to start scanner: Error during device I/O.

If I then turn the Scanner off, then turn it back on, the scanner reappears on scanimage -L.

Very strange. I had the scanner hooked up through WiFi which worked fine, including the ADF - but scanning was too slow so I moved to USB.

I tried different versions of SULD driver, to no avail.
I have installed suld-scanner-usblp-fix.
I tried to fix it by adding the printer to /etc/sane.d/xerox_mfp-smfp.conf, did not work.

Any suggestions? Have others had this ADF issue? (a cursory forum and Google search came up empty).

I should note I also have an HP Scanjet 8290 which works fine, even with ADF feed.

Edit: Appears to be related to the USB autosuspend feature. Entering this command:

sudo modprobe usbcore autosuspend=-1

results in the scanner no longer dropping off the scanimage -L list and I no longer have to turn it back off then on again when scanning 2 pages through the ADF. However, it still only scans the first page to the screen. Same error message appears in XSane.

Getting closer...