Samsung Unified Linux Driver Repository Forum

SULDR => Scanning => Topic started by: lister171254 on September 10, 2015, 02:47:22

Title: Networked M2070 prinitng but not found by scanner
Post by: lister171254 on September 10, 2015, 02:47:22
The networked printer works fine, but the scanner doesn't find the device.

Trying to follow the scanner troubleshooting breaks the printer as it suggest to ensure suld-network-* package is up to date. But installing this package removes the suld2-driver-* package, which means I cannot print.

Thanks
Title: Re: Networked M2070 prinitng but not found by scanner
Post by: lister171254 on September 10, 2015, 03:17:43
I've added the ip address to xerox_mfp.conf as per various suggestions.

This gets me further but am now getting the attached 'Failed to open device' error
Title: Re: Networked M2070 prinitng but not found by scanner
Post by: lister171254 on September 10, 2015, 03:30:02
Netdiscovery shows the following

/usr/lib/cups/backend/smfpnetdiscovery
network socket://192.168.1.50 "Samsung M2070 Series" "Samsung M2070 Series on 192.168.1.50" "MFG:Samsung;CMD:SPL,URF,FAX,FWV,PIC,EXT,SPDS;MDL:M2070 Series;CLS:PRINTER;CID:SA_SPLV3_BW;MODE:FAX3,SCN,SPL3,R000105;"
network ipp://192.168.1.50 "Samsung M2070 Series" "Samsung M2070 Series on 192.168.1.50" "MFG:Samsung;CMD:SPL,URF,FAX,FWV,PIC,EXT,SPDS;MDL:M2070 Series;CLS:PRINTER;CID:SA_SPLV3_BW;MODE:FAX3,SCN,SPL3,R000105;"
Title: Re: Networked M2070 prinitng but not found by scanner
Post by: lister171254 on September 10, 2015, 03:33:01
Sorry, should have put this first.

Running 15.04 Ubuntu
I have a Samsung M2070 which is networked
The driver I installed is driver2-1.00.35
Title: Re: Networked M2070 prinitng but not found by scanner
Post by: bchemnet on September 10, 2015, 21:59:59
Try one of the older driver2 versions, such as 1.00.29.  I've seen a few reports that 1.00.35 may not work correctly with some printers.
Title: Re: Networked M2070 prinitng but not found by scanner
Post by: lister171254 on September 10, 2015, 22:58:02
Uninstalled 2-1.00.35 and installed 2-1.00.29

Results the same.

simple-scan -d
[+0.00s] DEBUG: simple-scan.vala:594: Starting Simple Scan 3.16.1.1, PID=13701
[+0.00s] DEBUG: Connecting to session manager
[+0.03s] DEBUG: ui.vala:1880: Loading state from /home/llist/.cache/simple-scan/state
[+0.03s] DEBUG: ui.vala:1848: Restoring window to 600x400 pixels
[+0.03s] DEBUG: autosave-manager.vala:64: Loading autosave information
[+0.03s] DEBUG: autosave-manager.vala:259: Waiting to autosave...
[+0.03s] CRITICAL: gtk_event_controller_reset: assertion 'GTK_IS_EVENT_CONTROLLER (controller)' failed
[+0.06s] DEBUG: scanner.vala:1446: sane_init () -> SANE_STATUS_GOOD
[+0.06s] DEBUG: scanner.vala:1452: SANE version 1.0.24
[+0.06s] DEBUG: scanner.vala:1513: Requesting redetection of scan devices
[+0.06s] DEBUG: scanner.vala:802: Processing request
[+0.13s] DEBUG: autosave-manager.vala:281: Autosaving book information
[+0.18s] DEBUG: ui.vala:1971: Saving state to /home/llist/.cache/simple-scan/state
[+5.54s] DEBUG: scanner.vala:338: sane_get_devices () -> SANE_STATUS_GOOD
[+5.54s] DEBUG: scanner.vala:350: Device: name="smfp:net;192.168.1.50" vendor="Samsung" model="M2070 Series on 192.168.1.50" type="Scanner"
[+12.01s] DEBUG: simple-scan.vala:310: Requesting scan at 150 dpi from device 'smfp:net;192.168.1.50'
[+12.01s] DEBUG: scanner.vala:1559: Scanner.scan ("smfp:net;192.168.1.50", dpi=150, scan_mode=ScanMode.GRAY, depth=2, type=ScanType.SINGLE, paper_width=0, paper_height=0, brightness=0, contrast=0)
[+12.01s] DEBUG: scanner.vala:802: Processing request
[+12.01s] DEBUG: scanner.vala:863: sane_open ("smfp:net;192.168.1.50") -> SANE_STATUS_DEVICE_BUSY
[+12.01s] WARNING: scanner.vala:867: Unable to get open device: Device busy
[+12.11s] DEBUG: ui.vala:1971: Saving state to /home/llist/.cache/simple-scan/state
[+19.18s] DEBUG: autosave-manager.vala:195: Deleting autosave records
[+19.18s] DEBUG: scanner.vala:1586: Stopping scan thread
[+19.18s] DEBUG: scanner.vala:802: Processing request
[+19.18s] DEBUG: scanner.vala:1597: sane_exit ()


Thanks

Title: Re: Networked M2070 prinitng but not found by scanner
Post by: lister171254 on September 12, 2015, 02:56:58
After a few more install/uninstalls I'm back at the stage that the scanner is not found.

The printer always works (including older drivers).

Is there some info I can look up as to what other (config) files are needed for the scanner or what the sequence of events is when it tries to find a scanner and the reasons for not finding it?

Thanks
Title: Re: Networked M2070 prinitng but not found by scanner
Post by: bchemnet on September 12, 2015, 09:25:19
Quote from: lister171254 on September 12, 2015, 02:56:58
Is there some info I can look up as to what other (config) files are needed for the scanner or what the sequence of events is when it tries to find a scanner and the reasons for not finding it?

You would need to look at information specific to SANE to find out anything more than is available here.  This is pretty much the only Samsung-specific resource.

Unfortunately, I don't have any additional suggestions.  I suspect it is not directly related to the Samsung driver, though, so perhaps you would have more luck by interacting with the SANE support (possibly via Ubuntu's system).
Title: Re: Networked M2070 prinitng but not found by scanner
Post by: lister171254 on September 12, 2015, 19:57:43

Have borrowed a friends PC with windows and have the same scanner problem in Windows 10.

Have contact Samsung and also raised an issue regarding their (latest) Linux drivers, which do not list my printer.

Thanks for your help.
Title: Re: Networked M2070 prinitng but not found by scanner
Post by: ixti on December 10, 2015, 20:56:08
Latest ULD solved the problem for me: http://downloadcenter.samsung.com/content/DR/201512/20151210091120064/uld_v1.00.37_00.99.tar.gz

Samsung M2070W
Debian GNU/Linux stretch/sid

❯ dpkg-query -l "libsane*" | grep "^ii"
ii  libsane:amd64         1.0.26~git20151121-1 amd64        API library for scanners
ii  libsane-common        1.0.26~git20151121-1 all          API library for scanners -- documentation and support files
ii  libsane-extras:amd64  1.0.22.3             amd64        API library for scanners -- extra backends
ii  libsane-extras-common 1.0.22.3             amd64        API library for scanners -- documentation and support files

Title: Re: Networked M2070 prinitng but not found by scanner
Post by: lister171254 on December 12, 2015, 17:11:27
Downloaded the latest uld as suggeted but result is the same:

1) The printer M2070 cannot be found when I try to add my printer (M2070)
2) xsane doesn't find a scanner

llist@LeosLinux:/tmp/uld$ dpkg-query -l "libsane*" | grep "^ii"
ii  libsane:amd64         1.0.25+git20150528-1ubuntu2 amd64        API library for scanners
ii  libsane-common        1.0.25+git20150528-1ubuntu2 all          API library for scanners -- documentation and support files
ii  libsane-dbg:amd64     1.0.25+git20150528-1ubuntu2 amd64        API development library for scanners [debug symbols]
ii  libsane-extras:amd64  1.0.22.3ubuntu1             amd64        API library for scanners -- extra backends
ii  libsane-extras-common 1.0.22.3ubuntu1             amd64        API library for scanners -- documentation and support files
ii  libsane-hpaio         3.15.7-0ubuntu4             amd64        HP SANE backend for multi-function peripherals
Title: Re: Networked M2070 prinitng but not found by scanner
Post by: ixti on December 12, 2015, 18:10:03
Try connecting it to different USB ports. By some reason after installing the driver I have linked before it happens to me (figured out recently) that scanner starts failing again. Then I switch it to different USB port -and all works.
Title: Re: Networked M2070 prinitng but not found by scanner
Post by: lister171254 on December 13, 2015, 17:03:30
I'm doing this over the network.
Title: Re: Networked M2070 prinitng but not found by scanner
Post by: ixti on December 13, 2015, 17:42:39
Hmm. I was not testing scan via network.