Samsung Unified Linux Driver Repository Forum

SULDR => Printing => Topic started by: in_die75 on August 15, 2019, 11:17:26

Title: problem of printing in wifi: weird symbols
Post by: in_die75 on August 15, 2019, 11:17:26
Hi,

I've just installed my Samsung Xpress c647 printer in WIFI and my problem is that the result doesn't correspond to the original document.
It prints a lot of pages with weird symbols, it seems like it's an encoding problem (but why does it print a lot of pages instead of one ?).
Can you help me please !?

Regards,
Christelle

Title: Re: problem of printing in wifi: weird symbols
Post by: bchemnet on August 18, 2019, 06:44:33
Do you mean the c467 (not c647)?  As far as I know Samsung, never produced a printer with a model number of c647 (or c6 anything).

My three suggestions are to (in no particular order):
1. If you installed via the repository, try using the Samsung installer.  Or if you installed using the Samsung installer, switch to using the repository.
2. Try a different driver version within the supported range.
3. Try printing by USB, even if only temporarily, to determine if it is a problem specific to the wireless connection.
Title: Re: problem of printing in wifi: weird symbols
Post by: in_die75 on August 19, 2019, 00:42:28
I'm sorry I was wrong for the number, it's 467...

I've already installed the uld driver and I think it's the Samsung version.
The printing works only with the USB connection, whereas the scanner doesn't work even when connected by USB.
Title: Re: problem of printing in wifi: weird symbols
Post by: dorfsmay on August 31, 2019, 13:03:04
I have the same issue, well almost, with a M3065FW:

- first time I print is fine
- then it prints the postscript source (pages and page of what looks like random characters, but you can tell it's postscript)

It starts working fine again, for a single print, after I either reboot or unplug/replug the printer (honestly not sure which of the two).

I installed suld-driver2-1.00.39 through the repository on Ubuntu 18.04.

I never that problem with Ubuntu 14.04 with, I'm not sure which previous version of the driver.
Title: Re: problem of printing in wifi: weird symbols
Post by: bchemnet on August 31, 2019, 16:59:22
Unfortunately, all I can offer as a solution is to try a different version of the driver.  Or to contact HP to see if they have any interest in developing an updated driver, but I doubt it both because they have no financial incentive and because CUPS is making changes that will eventually make obselete all drivers in Linux (and printers that do not support the new CUPS approach).
Title: Re: problem of printing in wifi: weird symbols
Post by: dorfsmay on August 31, 2019, 19:03:00
I tried different versions of the driver, going way back... and it didn't help.

So I re-installed the latest driver, that driver is needed for scanning, then went and customized CUPS. Copy pasting my posting on askubuntu:

https://askubuntu.com/questions/1169909/samsung-wifi-printer-printing-garbage-after-upgrading-to-18-04/1169910

    open a browser
    navigate to localhost:631
    click on "Printers" in top bar
    click on name of the printer (Samsung...)
    Click on the "Administration" drop down menu, and select "Modify Printer"
    You'll be prompted for your user id and password, enter your Linux login credentials
    select the first printer in "Discovered Network Printers", "Continue"
    "Continue" again
    select "Samsung XXXXX driverless cups-filters", "Modify Printer"