Samsung Unified Linux Driver Repository Forum

SULDR => Printing => Topic started by: aaron on June 07, 2020, 03:33:51

Title: Force Samsung CLP-510N to print in monochrome only (disable color mode)
Post by: aaron on June 07, 2020, 03:33:51
Hi,

I would like to force all print jobs sent to my Samsung CLP-510N to monochrome, even when the client explicitly requests color mode.

The background is that we don't want to replace the colored cartridges anymore and use the printer as a monochrome printer only. Therefore, the colored cartridges are always empty, and a user who doesn't know this will get an unexpected result.

I have already set color mode to "Grayscale" in the default options, however, iOS devices don't seem to adhere to this default and try to color print anyway.

Any idea how I can achieve this?

The printer is connected via Ethernet to an Ubuntu 20.04 server running CUPS 2.3.1. It is shared, so macOS and iOS devices can print via Bonjour/AirPrint. I have installed suld-driver-4.00.39.

Thanks,
Aaron
Title: Re: Force Samsung CLP-510N to print in monochrome only (disable color mode)
Post by: bchemnet on June 07, 2020, 06:55:01
I do not believe this is possible with that printer.  Some printers have an option to force grayscale at the printer level (i.e., by changing a setting on the printer itself) but the CLP-510 does not.  So grayscale would have to set on each device that sends a job, because I am unaware of any software way to modify the job request that an individual user sends when that job comes from a separate device.

You could set up the printer as a grayscale generic postscript printer rather than as the CLP-510 model (i.e., not using the Samsung driver at all).  That would universally prevent color from being an option, but might impact print quality.
Title: Re: Force Samsung CLP-510N to print in monochrome only (disable color mode)
Post by: aaron on June 07, 2020, 07:21:09
Hi, thanks for getting back!

In the meantime, I've found out that even when I set the color mode to grayscale on the client, it is still printing blue text (which I believe happens because it tries to print black with the colored cartridges, but some are empty).

Only when I print the printer's configuration ("Print Printer Configuration Page" via the printer's web interface), it will print in black. Any idea why that is?

I'll try the hint regarding PostScript and see if the quality is still good enough.
Title: Re: Force Samsung CLP-510N to print in monochrome only (disable color mode)
Post by: bchemnet on June 07, 2020, 07:36:29
Some Samsung (and other manufacturer) printers routinely print "black" by using color ink, if the job is color but converted to grayscale.  Other than the postscript option, I do not think there is anything you can do to change that behavior.  The only justification for printing black this way is to drive up sales of color ink.
Title: Re: Force Samsung CLP-510N to print in monochrome only (disable color mode)
Post by: aaron on July 12, 2020, 14:38:16
Interesting, I didn't know that!

I've also tried to manually convert documents to grayscale before printing (and then choosing color mode in the driver to—ironically—prevent it from using the colored cartridges for black color). What it does then is that black will actually be printed in black, but all the shades of grey will be mixed using the colored cartridges. So as you said, there's probably no way around that besides using another driver. I had a look at Splix, but I weren't able to make that work. Also, I've read that quality is superior when using the official Samsung driver.

So in the end, we've bought new color cartridges now and will make sure to never use the grayscale option in the driver ever again. In hindsight, this explains why the colored cartridges never lasted long, even though we thought we were saving so much ink by always choosing the grayscale option in the driver. Wow, quite a bummer! Thanks a lot for clearing that up!