Samsung Unified Linux Driver Repository Forum

SULDR => Using the Repository => Topic started by: mkrueger on January 21, 2022, 19:15:52

Title: suld-configurator-2-qt4 and Debian 11 (QT5)
Post by: mkrueger on January 21, 2022, 19:15:52
I use antiX 21 as a 32 bit version (based on Debian 11 bullseye). Unfortunately, Debian 11 no longer supports QT4. For the installation of my Samsing CLX 3185 the program suld-configurator-2-qt4 is required.

Are there plans to create a corresponding update to QT5? Are there alternative options?
Title: Re: suld-configurator-2-qt4 and Debian 11 (QT5)
Post by: bchemnet on January 23, 2022, 08:07:43
There is no development on any part of this project.  The Qt interface development was actually discontinued 9 years ago, well before Samsung sold their printer business to HP in 2016.  HP has not shown any interest in developing the driver (the last true update was nearly 6 years ago), let alone reviving that interface.  And there is no practical way to get Qt4 working in the latest Debian-based distributions due to some severe security issues that were discovered after Qt4 development ended.

However, you should be able to use system-config-printer to set up the printer.
Title: Re: suld-configurator-2-qt4 and Debian 11 (QT5)
Post by: mkrueger on January 23, 2022, 08:13:50
This is sad because the network scanner was also addressed and managed by the driver. But ok, thanks for the answer.