Samsung Unified Linux Driver Repository Forum

SULDR => Scanning => Topic started by: michael on October 03, 2012, 08:00:35

Title: samsungmfp-scanner-sane-fix unmet dependencies
Post by: michael on October 03, 2012, 08:00:35
I get the following error when I try and install the samsungmfp-scanner-sane-fix package in an attempt to get a SCX4216F printer working on Ubuntu 12.04

The following packages have unmet dependencies:
 samsungmfp-scanner-sane-fix : Depends: libsane (<= 1.0.22-3) but 1.0.22-7ubuntu1 is to be installed
                               Depends: samsungmfp-common (= 4.00.35-2) but 4.00.39-1 is to be installed
E: Unable to correct problems, you have held broken packages.

It seams strange that you have a dependency on a version of samsungmfp-common that you don't supply.
Title: Re: samsungmfp-scanner-sane-fix unmet dependencies
Post by: bchemnet on October 04, 2012, 06:04:54
If you are using the 4.00.39 versions of the packages, samsungmfp-scanner-sane-fix is unnecessary (it is now part of samsungmfp-scanner), so this is exactly correct.  If you are still at 4.00.35, lock the version of samsungmfp-common and it will install correctly.