SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - schluppschlupp

Pages: [1]
1
Printing / Re: Howto enable SULD drivers on rasberrypi
« on: August 23, 2021, 10:52:39 »
Hmm... tough ride here... I had to solve some GPG errors first, but now I get this:

root@pi4-pios-nas:~# apt-get update
Hit:1 http://deb.debian.org/debian buster InRelease
Hit:2 http://repository.spotify.com stable InRelease                                                                                                                                                         
Ign:3 http://deb.debian.org/debian-security buster-security InRelease                                                                                                                                         
Hit:4 http://archive.raspberrypi.org/debian buster InRelease                                                                                                                                                 
Hit:5 https://dtcooper.github.io/raspotify raspotify InRelease                                                         
Get:6 http://deb.debian.org/debian buster-updates InRelease [51.9 kB]                                                 
Hit:7 http://raspbian.raspberrypi.org/raspbian buster InRelease                                               
Err:8 http://deb.debian.org/debian-security buster-security Release       
  404  Not Found [IP: 151.101.14.132 80]
Hit:9 https://www.bchemnet.com/suldr debian InRelease
Get:10 http://deb.debian.org/debian buster-updates/main amd64 Packages [15.2 kB]
Get:11 http://deb.debian.org/debian buster-updates/main Translation-en [13.9 kB]
Reading package lists... Done       
E: The repository 'http://deb.debian.org/debian-security buster-security Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
N: Skipping acquire of configured file 'non-free/binary-armhf/Packages' as repository 'http://repository.spotify.com stable InRelease' doesn't support architecture 'armhf'
N: Skipping acquire of configured file 'main/binary-amd64/Packages' as repository 'https://dtcooper.github.io/raspotify raspotify InRelease' doesn't support architecture 'amd64'
N: Skipping acquire of configured file 'main/binary-amd64/Packages' as repository 'http://raspbian.raspberrypi.org/raspbian buster InRelease' doesn't support architecture 'amd64'
N: Skipping acquire of configured file 'contrib/binary-amd64/Packages' as repository 'http://raspbian.raspberrypi.org/raspbian buster InRelease' doesn't support architecture 'amd64'
N: Skipping acquire of configured file 'non-free/binary-amd64/Packages' as repository 'http://raspbian.raspberrypi.org/raspbian buster InRelease' doesn't support architecture 'amd64'
N: Skipping acquire of configured file 'rpi/binary-amd64/Packages' as repository 'http://raspbian.raspberrypi.org/raspbian buster InRelease' doesn't support architecture 'amd64'

Tried to install anyway, and got the same error as above :( Any help is very much appreciated!

2
Printing / Re: Howto enable SULD drivers on rasberrypi
« on: August 23, 2021, 10:09:13 »

Many thanks for the quick response! Please find below the requested data:

root@pi4-pios-nas:~# cat /etc/apt/sources.list
deb http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi

root@pi4-pios-nas:~# ls -l /etc/apt/sources.list.d/
total 20
-rw-r--r-- 1 root root 187 Jan 11  2021 raspi.list
-rw-r--r-- 1 root root  56 Aug 11 09:50 raspotify.list
-rw-r--r-- 1 root root  50 Aug 11 09:46 spotify.list
-rw-r--r-- 1 root root  62 Aug 23 15:58 suldr.list

root@pi4-pios-nas:~# cat /etc/apt/sources.list.d/*
deb http://archive.raspberrypi.org/debian/ buster main
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://archive.raspberrypi.org/debian/ buster main
deb https://dtcooper.github.io/raspotify raspotify main
deb http://repository.spotify.com stable non-free
deb [arch=amd64] https://www.bchemnet.com/suldr/ debian extra

Cheers, Jürgen

3
Printing / Re: Howto enable SULD drivers on rasberrypi
« on: August 23, 2021, 09:17:50 »
Sounds very interesting to me! I want to get a Samsung ML-1670 running on a Raspberry Pi 4 compute module with PiOS (Linux-5.10.52-v7l+).

Unfortunely apt has difficulties solving the dependencies:

# export LANG=en_US.UTF-8 ; export LC_ALL=en_US.UTF-8 ; apt-get install suld-driver-3.00.65
bash: Warnung: setlocale: LC_ALL: Kann die Locale nicht ändern (en_US.UTF-8).
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 suld-driver-3.00.65:amd64 : Depends: libstdc++5:amd64 but it is not installable
                             Depends: libusb-0.1-4:amd64 but it is not installable
                             Depends: libxml2:amd64 but it is not installable
                             Depends: suld-network-install:amd64
                             Depends: libcupsimage2:amd64 but it is not installable
E: Unable to correct problems, you have held broken packages.

Can somebody give me a hand with this issue?

Many thanks in advance,
Jürgen.

Pages: [1]
Repository Information Legal Contact Alternative Drivers