SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - markosjal

Pages: [1]
1
Printing / Re: Howto enable SULD drivers on rasberrypi
« on: August 27, 2021, 14:06:58 »
I think this is a serious case of "Pi in the Sky" as it does not work, even with the "updated instructions". (English in quotes)

root@raspberrypi:/etc/apt/sources.list.d# apt install suld-driver2-1.00.39:amd64
Leyendo lista de paquetes... Hecho (reading...)
Creando árbol de dependencias        (Creating dependency tree...)
Leyendo la información de estado... Hecho (reading state...)
No se pudieron instalar algunos paquetes. Esto puede significar que (could not instrall some packages, this could mean that)
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».  (you asked for an impossible situation or you are using ...)
La siguiente información puede ayudar a resolver la situación: (the following may be helpful...)

Los siguientes paquetes tienen dependencias incumplidas: (...incomplete dependencies...)
 suld-driver2-1.00.39:amd64 : Depende: libxml2:amd64 pero no va a instalarse
                              Depende: libstdc++6:amd64 pero no va a instalarse
                              Depende: libusb-0.1-4:amd64 pero no va a instalarse
                              Depende: libcupsimage2:amd64 pero no va a instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos. (unable to correct problems)

Using Raspbian debian stretch


I have  created /etc/apt/sources.list.d/debian-arm64.list

which  contains:
deb [arch=amd64] http://deb.debian.org/debian stretch main
deb [arch=amd64] http://deb.debian.org/debian-security/ stretch-security main
deb [arch=amd64] http://deb.debian.org/debian stretch-updates main

on apt-get update I see..

Err:13 http://deb.debian.org/debian-security stretch-security/main amd64 Packages
  404  Not Found [IP: 2a04:4e42:64::644 80]

W: El repositorio «http://deb.debian.org/debian-security stretch-security Release» no tiene un fichero de Publicación.
N: Los datos de un repositorio como este no se pueden autenticar y por tanto su uso es potencialmente peligroso.
N: Vea la página de manual apt-secure(8) para los detalles sobre la creación de repositorios y la configuración de usuarios.
W: Error de GPG: http://deb.debian.org/debian stretch-updates InRelease: Las firmas siguientes no se pudieron verificar porque su clave pública no está disponible: NO_PUBKEY 04EE7237B7D453EC NO_PUBKEY 648ACFD622F3D138
W: El repositorio «http://deb.debian.org/debian stretch-updates InRelease» no está firmado.
N: Los datos de un repositorio como este no se pueden autenticar y por tanto su uso es potencialmente peligroso.
N: Vea la página de manual apt-secure(8) para los detalles sobre la creación de repositorios y la configuración de usuarios.
W: Error de GPG: http://deb.debian.org/debian stretch Release: Las firmas siguientes no se pudieron verificar porque su clave pública no está disponible: NO_PUBKEY 04EE7237B7D453EC NO_PUBKEY 648ACFD622F3D138 NO_PUBKEY 0E98404D386FA1D9 NO_PUBKEY EF0F382A1A7B6500
W: El repositorio «http://deb.debian.org/debian stretch Release» no está firmado.
N: Los datos de un repositorio como este no se pueden autenticar y por tanto su uso es potencialmente peligroso.
N: Vea la página de manual apt-secure(8) para los detalles sobre la creación de repositorios y la configuración de usuarios.
E: Fallo al obtener http://deb.debian.org/debian-security/dists/stretch-security/main/binary-amd64/Packages  404  Not Found [IP: 2a04:4e42:64::644 80]
E: No se han podido descargar algunos archivos de índice, se han omitido, o se han utilizado unos antiguos en su lugar.



now to try and undo the damage.....


2
if you are sharing in ubuntu from windows you only need to send postscript to the ubunrtu machine. Forget the clp365 driver on windows

3
Printing / ML-1675 and "Missing Driver" error
« on: August 10, 2014, 11:52:19 »
I just did a clean install of Linux Mint 17 (Ubuntu 14.04 based)

I tried adding the suld-driver-2-1.00.21

When I installed the printer I get the message
Missing driver
Printer 'Samsung-ML-1670' requires the '/usr/lib/cups/filter/rastertosplc' program but it is not currently installed.  Please install it before using this printer.

I searched synaptic Package manager and do not find this

4
Printing / Re: CUPS error when exporting printers to Samba
« on: July 22, 2013, 13:42:00 »
Since you ask what is what I actually did and what I expect.....

I have a working CUPS / Samba print server that works on  my xerox color laser and PDF printer with no issues. What I do is click "export printers to samba" in the CUPS web GUI after adding the Samsung and am told that one printer can not be exported with the samsung highlighted .  the error log shows what I pasted earlier. I thought that was clear and I elaborated here a bit.


what I expect is no error and the printer successfully exported to CUPS

I have found that I can use commend line tools to export it successfully however this then makes it more burdensome when a printer is changed.

5
Printing / CUPS error when exporting printers to Samba
« on: July 21, 2013, 14:25:02 »
I recently reformatted an old machine with Linux Mint 15 and ran into many problems. This particular problem now has reared its ugly head in the Mint 14 installation as well and I am 90% sure it relates to this driver repo directly.

Let me explain that I created an image of Mint 14 with my Samba and CUPs configured just as I had wanted and was tested on an HP Deskjet printer as well as the PDF virtual printer . Both of which had worked while only clicking "Export Printers to Samba" in the Administration tab of CUPS . This particular install of CUPS was a forced upgrade to 1.61 whereas the Mint 15 with the same error was 1.62 (default version) .

The error produced is below and clearly related to the Samsung driver mess. I believe the "W" messages to be "warnings" that are not fatal while the "E" messages which all relate to Samsung drivers, seem to be fatal "errors".  The files referenced in the E messages seem to be where indicated in /usr/share/cups/model/suld/cms/, but I have no way of knowing what is wrong with them

before moving on, I want to make an additional comment that printing was painfully slow on Mint 15 after testing a few different versions of the drivers here . This apparently is not the case on Mint 14 using the latest driver version.
_________________________________________________________________________________
W [21/Jul/2013:12:52:41 -0500] CreateProfile failed: org.freedesktop.ColorManager.AlreadyExists:profile id 'PDF-Gray..' already exists
W [21/Jul/2013:12:52:41 -0500] CreateProfile failed: org.freedesktop.ColorManager.AlreadyExists:profile id 'PDF-RGB..' already exists
W [21/Jul/2013:12:52:41 -0500] CreateDevice failed: org.freedesktop.ColorManager.AlreadyExists:device id 'cups-PDF' already exists
W [21/Jul/2013:13:09:14 -0500] AddProfile failed: org.freedesktop.DBus.Error.UnknownMethod:No such interface `org.freedesktop.ColorManager' on object at path /org/freedesktop/ColorManager/devices/cups_PDF
W [21/Jul/2013:13:09:14 -0500] AddProfile failed: org.freedesktop.DBus.Error.UnknownMethod:No such interface `org.freedesktop.ColorManager' on object at path /org/freedesktop/ColorManager/devices/cups_PDF
E [21/Jul/2013:13:11:30 -0500] [cups-driverd] Bad driver information file "/usr/share/cups/drv/cupsfilters.drv"!
E [21/Jul/2013:13:27:44 -0500] [cups-driverd] Bad driver information file "/usr/share/cups/drv/cupsfilters.drv"!
E [21/Jul/2013:13:44:01 -0500] [cups-driverd] Bad driver information file "/usr/share/cups/model/suld/cms/M262xsc.cts"!
E [21/Jul/2013:13:44:01 -0500] [cups-driverd] Bad driver information file "/usr/share/cups/model/suld/cms/M337xsc.cts"!
E [21/Jul/2013:13:44:01 -0500] [cups-driverd] Bad driver information file "/usr/share/cups/model/suld/cms/CLX-3160sc.cts"!
E [21/Jul/2013:13:44:01 -0500] [cups-driverd] Bad driver information file "/usr/share/cups/model/suld/cms/SCX-3400sc.cts"!
E [21/Jul/2013:13:44:01 -0500] [cups-driverd] Bad driver information file "/usr/share/cups/model/suld/cms/CLP-660sc.cts"!
E [21/Jul/2013:13:44:01 -0500] [cups-driverd] Bad driver information file "/usr/share/cups/model/suld/cms/CLX-216xsc.cts"!
E [21/Jul/2013:13:44:01 -0500] [cups-driverd] Bad driver information file "/usr/share/cups/model/suld/cms/CLP-610sc.cts"!
E [21/Jul/2013:13:44:01 -0500] [cups-driverd] Bad driver information file "/usr/share/cups/model/suld/cms/M332xsc.cts"!
E [21/Jul/2013:13:44:01 -0500] [cups-driverd] Bad driver information file "/usr/share/cups/model/suld/cms/CLX-3170sc.cts"!
E [21/Jul/2013:13:44:01 -0500] [cups-driverd] Bad driver information file "/usr/share/cups/model/suld/cms/CLX-3180sc.cts"!
E [21/Jul/2013:13:44:01 -0500] [cups-driverd] Bad driver information file "/usr/share/cups/model/suld/cms/SCX-472xsc.cts"!
E [21/Jul/2013:13:44:01 -0500] [cups-driverd] Bad driver information file "/usr/share/cups/model/suld/cms/CLP-360sc.cts"!
E [21/Jul/2013:13:44:01 -0500] [cups-driverd] Bad driver information file "/usr/share/cups/model/suld/cms/ML-2540sc.cts"!
E [21/Jul/2013:13:44:01 -0500] [cups-driverd] Bad driver information file "/usr/share/cups/model/suld/cms/SCX-4650sc.cts"!
E [21/Jul/2013:13:44:01 -0500] [cups-driverd] Bad driver information file "/usr/share/cups/model/suld/cms/SCX-470xsc.cts"!
E [21/Jul/2013:13:44:01 -0500] [cups-driverd] Bad driver information file "/usr/share/cups/model/suld/cms/M267xsc.cts"!
E [21/Jul/2013:13:44:01 -0500] [cups-driverd] Bad driver information file "/usr/share/cups/model/suld/cms/CLP-600sc.cts"!
E [21/Jul/2013:13:44:01 -0500] [cups-driverd] Bad driver information file "/usr/share/cups/model/suld/cms/SF-760sc.cts"!
E [21/Jul/2013:13:44:01 -0500] [cups-driverd] Bad driver information file "/usr/share/cups/model/suld/cms/CLP-300sc.cts"!
E [21/Jul/2013:13:44:01 -0500] [cups-driverd] Bad driver information file "/usr/share/cups/model/suld/cms/CLP-310sc.cts"!
E [21/Jul/2013:13:44:01 -0500] [cups-driverd] Bad driver information file "/usr/share/cups/model/suld/cms/ML-2160sc.cts"!
E [21/Jul/2013:13:44:01 -0500] [cups-driverd] Bad driver information file "/usr/share/cups/model/suld/cms/CLP-620sc.cts"!
E [21/Jul/2013:13:44:01 -0500] [cups-driverd] Bad driver information file "/usr/share/cups/model/suld/cms/CLP-320sc.cts"!
E [21/Jul/2013:13:44:01 -0500] [cups-driverd] Bad driver information file "/usr/share/cups/model/suld/cms/CLX-6220sc.cts"!
E [21/Jul/2013:13:44:01 -0500] [cups-driverd] Bad driver information file "/usr/share/cups/model/suld/cms/ML-2950sc.cts"!
E [21/Jul/2013:13:44:01 -0500] [cups-driverd] Bad driver information file "/usr/share/cups/drv/cupsfilters.drv"!
W [21/Jul/2013:13:44:20 -0500] AddProfile failed: org.freedesktop.DBus.Error.UnknownMethod:No such interface `org.freedesktop.ColorManager' on object at path /org/freedesktop/ColorManager/devices/cups_B_W_Laser_ByN_Laser
W [21/Jul/2013:13:44:20 -0500] AddProfile failed: org.freedesktop.DBus.Error.UnknownMethod:No such interface `org.freedesktop.ColorManager' on object at path /org/freedesktop/ColorManager/devices/cups_B_W_Laser_ByN_Laser
W [21/Jul/2013:13:44:32 -0500] CreateProfile failed: org.freedesktop.ColorManager.AlreadyExists:profile id 'B&W_Laser-ByN_Laser-Gray..' already exists
W [21/Jul/2013:13:44:32 -0500] CreateProfile failed: org.freedesktop.ColorManager.AlreadyExists:profile id 'B&W_Laser-ByN_Laser-RGB..' already exists
W [21/Jul/2013:13:44:32 -0500] CreateDevice failed: org.freedesktop.ColorManager.AlreadyExists:device id 'cups-B&W_Laser-ByN_Laser' already exists


Pages: [1]
Repository Information Legal Contact Alternative Drivers