SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

Menu

Show posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Show posts Menu

Messages - kgeiger

#1
I figured out what the problem was and how to get the scanner work on F25: The libusb package was missing. After installing the package, the scanner is detected and works perfectly.

Maybe it helps someone to debug similar problems - that's how I figured it out what was missing:
* Run scanimage in debug mode and redirect the output to a file:
  # SANE_DEBUG_DLL=128 scanimage -L > output.txt 2>&1

* In the output.txt, you see the problem where the "smfp" back end is loaded:
  [dll] load: searching backend `smfp' in `/usr/lib64/sane'
  [dll] load: trying to load `/usr/lib64/sane/libsane-smfp.so.1'
  [dll] load: dlopen()ing `/usr/lib64/sane/libsane-smfp.so.1'
  [dll] load: dlopen() failed (libusb-0.1.so.4: cannot open shared object file: No such file or directory)

* Look up which package provides the missing file:
  # dnf provides */libusb-0.1.so.4
  libusb-1:0.1.5-7.fc25.i686 : A library which allows userspace access to USB devices
  Quelle      : Fedora


Regards
#2
Hi,

I'm currently testing Fedora 25 Beta, but scanning with my M2875FD does not work, because the device is not found. I tried the 1.00.37.00.99 driver, that I used successfully before on Fedora 24. Additionally I tried 1.00.29 which worked on F23 and F24, but this one also fails on F25.

On F24:
# scanimage -L
device `smfp:net;192.168.1.10' is a Samsung M267x 287x Series on 192.168.1.10 Scanner

On F25 Beta:
# scanimage -L
No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

I used Wireshark to compare what's different on F24 and F25: On 24, snmp packages are sent to the device during the discovery, while this does not happen on F25.

If I run the "smfpnetdiscovery" command from the install directory:  It finds the device in the network. The output of the command is the same on F24 and F25:
# x86_64/smfpnetdiscovery
network socket://192.168.1.10 "Samsung M267x 287x Series" "Samsung M267x 287x Series on 192.168.1.10" "MFG:Samsung;CMD:PCL6,URF,FAX,FWV,PIC,SPDS,EXT;MDL:M267x 287x Series;CLS:PRINTER;CID:SA_PCL6_BW;MODE:FAX3,SCN,SPL3,R000105,SCP;"
network ipp://192.168.1.10 "Samsung M267x 287x Series" "Samsung M267x 287x Series on 192.168.1.10" "MFG:Samsung;CMD:PCL6,URF,FAX,FWV,PIC,SPDS,EXT;MDL:M267x 287x Series;CLS:PRINTER;CID:SA_PCL6_BW;MODE:FAX3,SCN,SPL3,R000105,SCP;"

There is no local firewall installed, nor between the computer and the M2875FD. Both devices are in the same subnet.

Please let me know if I can provide any further debug information.

Regards
Repository Information Legal Contact Alternative Drivers