Sticky
SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - NewBee1

Pages: [1]
1
Printing / Re: Samsung ML2545 with Manjaro XFCE 17.1.2
« on: September 29, 2018, 18:37:54 »
Thanks for the info.
I tried those downloads as well.
Every time I enter it, it gives me an error in terminal. Same thing happens with any of the tar.gz files for this printer that I have tried. They all come back invalid or corrupted, including the one direct from HP.

sudo yaourt -U /home/eric/Downloads/UnifiedLinuxDriver-4.00.35.tar.gz
[sudo] password for eric:
unable to read /home/eric/Downloads/UnifiedLinuxDriver-4.00.35.tar.gz.
loading packages...
error: missing package metadata in /home/eric/Downloads/UnifiedLinuxDriver-4.00.35.tar.gz
error: '/home/eric/Downloads/UnifiedLinuxDriver-4.00.35.tar.gz': invalid or corrupted package

I'm throwing in the towel on this. Tired of messing with something the Manjaro program should have had no problem with whatsoever.
Going to wipe the drive and try a different Linux version. Probably switch back to an Ubuntu based one. I know the printer works with those.


2
Printing / Samsung ML2545 with Manjaro XFCE 17.1.2
« on: September 29, 2018, 10:59:54 »
Fresh install of Manjaro on Toshiba Satellite laptop that is about ten years old.
intel corei5 processor
Samsung ML2545 printer via USB cable
Home computer, stand alone.
Won't print.

When choosing the Manjaro recommended printer and driver, it just kicks back error messages. One was regarding missing PPD file. Another was regarding a missing Rastertospl file. I did manage to get a sheet to print and all it said was "Internal error - Please use the proper driver. Huh? I used the driver the system suggested.

Downloaded and unpacked the driver file from HP. Found the PPD file and Rastertospl file, and copied those via sudo cp to their proper spots.
Tried printing again. Just get a generic error message on screen. "Sorry, unknown error."

So I downloaded the 4.00.35 and 1.00.36 files from your website.

Used terminal and it kicks this back to me for both files:

sudo pacman -U ~/Downloads/uld_V1.00.39_01.17.tar.gz
[sudo] password for eric:
loading packages...
error: missing package metadata in /home/eric/Downloads/uld_V1.00.39_01.17.tar.gz
error: '/home/eric/Downloads/uld_V1.00.39_01.17.tar.gz': invalid or corrupted package

I am no Linux expert by any stretch. Just basically tell me what I need to copy and paste into terminal to get this printer working. Clearly the system recognizes the printer since it kicked out the error sheet.

Going on day number 3 trying to get this printer to work. I'm lost at this point.

I have a text file that it kicked out as part of it's troubleshooting attempt. But it exceeds 2000 characters, so can't paste it here. Will try to attach.

Pages: [1]
Repository Information Legal Contact Alternative Drivers