SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

Menu

Show posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Show posts Menu

Messages - ellepdesk

#1
@Eim: My experiments with this driver are not on raspberry hardware, but on a Cubieboard2 (arm7) and a NanoPI Neo4 (arm64)

Do you get the (exact) same error for libc when using ubuntu for raspberry?
#2
@Eim:
Yes, that is the libc issue that happens on raspberry pi os.

I've had success with armbian as os
#3
Printing / Re: Howto enable SULD drivers on rasberrypi
September 29, 2021, 08:51:19
I think I found something, it seems raspbian uses a custom version of gcc-8-base, 8.3.0-6+rpi1, where the amd64 version is just 8.3.0-6.

From what I figure apt requires the foreign package versions to EXACTLY match the native version, otherwise installation will fail.

It seems my other boards run a baseline gcc-8-base from armbian.

If I find the time I will try to prepare a docker image, that is the only way out of this I can think of.
#4
Printing / Re: Howto enable SULD drivers on rasberrypi
September 29, 2021, 03:37:06
Hi, I found a raspberrypi running raspbian buster in my house, so I'm trying the procedure there.

Can you post the result of 'sudo apt update' to verify something?
#5
Printing / Re: Howto enable SULD drivers on rasberrypi
September 28, 2021, 08:17:28
Can you post the contents of /etc/apt/sources.list and /etc/apt/sources.list.d/* ?

I'd like to compare them to mine.

I have personally succeeded in installing the amd64 binaries on both a arm32 debian based box, as well as an arm64 Ubuntu based box.
#6
Well, it does work, but it is not for the faint of heart.
The main problem is that it requires setting up sources for amd64 corresponding to the distribution you are running. This will differ fron distro to distro, and there are quite a lot of variants around.

There is definitely something wrong with my debian config, I'll have a look later, I'll mark it as broken for now.
#7
I think that

deb [arch=amd64] http://deb.debian.org/debian buster main

or maybe

deb [arch=amd64] http://deb.debian.org/debian buster main contrib

should be enough to work

I also found that adding [arch=arm64] after 'deb' to the existing repos cleans up a lot of the 'doesn't support architecture' warnings
#8
Hmm,  I'll have a good look tomorrow, in the meantime can you try removing the second and third line and try again?
#9
Ok, so your distro is based on debian buster.

I think you need to add the following lines to a new file, '/etc/apt/sources.list.d/debian-arm64.list':

deb [arch=amd64] http://deb.debian.org/debian buster main
# deb [arch=amd64] http://deb.debian.org/debian-security/ buster-security main
# deb [arch=amd64] http://deb.debian.org/debian buster-updates main

This will add the main debian repositories for buster to you system, but only for amd64 packages.
run 'apt update' after adding the file and try installing suld again.


For my own system, which is based on ubuntu focal, I've added the file '/etc/atp/sources.list.d/ubuntu-amd64.list' with the content:
deb [arch=amd64] http://archive.ubuntu.com/ubuntu/ focal main
deb [arch=amd64] http://archive.ubuntu.com/ubuntu/ focal-updates main
deb [arch=amd64] http://archive.ubuntu.com/ubuntu/ focal-security main
#10
This is probably due to the fact that there is no repository configured for amd64 packages.

Can you post the content of '/etc/apt/sources.list' and all/any files in '/etc/apt/sources.list.d/'?

You will need to add a source for amd64 sources, matching the version of your os.
#11
Tnx, yes they work out-of-the-box for multi-architecture now.
#12
Thanks for updating the driver-common and ppd packages, I've updated the procedure.
I've also updated to 1.00.39.
#13
I've managed to get the suld drivers working on armhf/arm64 devices by using qemu-user emulation of amd64.
Sharing my work so others can benefit:

# enable transparent emulation of amd64 (on armhf/arm64)

apt install qemu-user-binfmt binfmt-support
dpkg --add-architecture amd64

# enable suldr repo for amd64
echo 'deb [arch=amd64] https://www.bchemnet.com/suldr/ debian extra' > /etc/apt/sources.list.d/suldr.list
wget 'http://www.bchemnet.com/suldr/pool/debian/extra/su/suldr-keyring_2_all.deb'
dpkg -i suldr-keyring_2_all.deb


# Make sure you have set up apt to install packages for amd64
# You may need to add [arch=arm64] or [arch=armhf] modifiers to lines in /etc/apt.sources.list
# and/or add the main ubuntu/debian repositories for arm64

# Update the package DB
apt update

# Install the driver indicated for your printer, in my case for a Samsung C410, suld-driver2-1.00.39. 

# This wil pull in a LOT of dependencies (about 200MB) of amd64 libs
apt install suld-driver2-1.00.39:amd64


Enjoy printing

IMPORTANT NOTICE:
This procedure is BROKEN for raspberry os/raspbian, due to a difference in the version of libc used!

UPDATE:
Thanks to bchemnet for updating the drivers before anyone else read this, the procedure has been shortened considerably.
I've removed the redundant steps to avoid confusion
#14
Hi,

I'm trying to bypass the restrictions on architecture by enabling qemu-user-static to run amd64 binaries on arm.
Installation of the suldr-driver2 packages fails because the driver depends on common, and common is installed only for the current architecture.

By patching the common and ppd .deb files to include 'Multi-Arch: foreign' these packages are seen as a fulfillment of the dependencies of suld-driver2:amd64 even when installed on a native arm system.

Using these patched debs an qemu-user-static I have successfully printed a test page from an arm system on a Samsung C410 printer. At the cost on a bunch of arm64v libs an a big overhead on executing, this could solve the long-standing issue of using the SULD drivers on a raspberry pi.

In sort: Please add 'Multi-Arch: foreign' to the control file for all 'Architecture: all' .deb files.
Repository Information Legal Contact Alternative Drivers