SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer


Show posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Show posts Menu

Messages - bchemnet

The new packages in the repository address this issue.  Please let me know if you update and it persists.
Using the Repository / Re: GPG error
May 01, 2013, 22:44:34
Quote from: painful_registration on May 01, 2013, 11:13:51
I ran into the same issue with linux mint debian edition, and a debian box running wheezy.

Following the instructions to wipe apt cache fixed the issue. Maybe add this tip to the FAQ or something.
I'm working on many updates now, and this is on the list of things to incorporate.

Quote from: painful_registration on May 01, 2013, 11:13:51
Also the registration process for this forum is really painful. I made a mistake in the email address and couldn't receive the confirmation email and was blocked from registering from the same computer, it also forced me to choose a less secure password than the one I wanted to use just for the sake of putting an uppercase letter and number in there.
So I restarted all over again from another machine and had to invent new username/email/password then the confirmation email would not arrive despite a couple resend.
This went on until I ran out of computers and had to resort to fiddle with cookies and found one email provider the registration would send email to.
I almost gave up around the 6th or 7th failed attempt at registering.
Actually, the registration system worked exactly as it should have.  Your pattern of activities, including use throw-away email addresses, were entirely consistent with a spambot.  And since I have very limited time to spend on this, I have zero tolerance for wasting that time dealing with spam.  If I had truly aggressive registration settings, you probably would have managed to get your IP address banned.

While I certainly use throw-away email addresses at times myself, the registration for the forum is supposed to be a truly valid one (for example, to receive notification of responses to your posts).  So there is a delay to try to avoid exactly what you did.  I'm a little surprised you managed to register at all with that approach.
I recommend waiting.  I'm close to releasing, but need to run some additional tests first.  Life permitting, the next 24-48 hours.

If you want to do some experimenting in the meantime, the older driver versions currently available should work except possibly for -legacy.  But the new packages I'm preparing are perhaps more likely to.
An update to the packages is coming that may address this issue.  I was hoping to get it out in parallel with the 13.04 release, but am running a few days behind.  I'm still trying to get everything out before the Debian Stable release this weekend.
Scanning / Re: Samsung 4216F scanner not working
April 28, 2013, 20:23:59
Two things you can possibly try.  First, just make sure it isn't an issue with Xen, do you have a machine running Linux natively that you can connect the printer to?

Second, I am very close to releasing updated packages that might help with this issue if isn't due to Xen.  My goal was today, but that isn't going to happen - more likely another 3-4 days.
No.  The Samsung Unified Linux Driver is only available for i386 and amd64 architectures.  Because the driver is not open source, I have no control over this limitation, nor will you be able to locate any source code.
Your sources.list should exactly like this:

deb debian extra

From the example you give, it likes like you may have a typo (sludr instead of suldr) and/or be missing part of the line.
I'm not sure what else to try, unless you happen to have another computer available to try with the printer to test for a different result in the event it is a subtle hardware issue.  This printer is normally well-supported by both the Samsung driver and SANE natively, but I do occasionally hear from other people who simply can't get a particular printer/computer combination to work.
Okay, try explicitly adding everything:
apt-get install samsungmfp-driver-4.00.35=4.00.35-2 samsungmfp-scanner=4.00.35-2 samsungmfp-configurator-qt3=4.00.35-2.2 samsungmfp-common=4.00.35-2 samsungmfp-configurator-data=4.00.35-2 samsungmfp-network=4.00.35-2

Sometimes apt is configured to be too insistent on the latest versions.
Try adding the explicit samsungmfp-common version:
apt-get install samsungmfp-driver-4.00.35=4.00.35-2 samsungmfp-scanner=4.00.35-2 samsungmfp-configurator-qt3=4.00.35-2.2 samsungmfp-common=4.00.35-2
You need to allow all incoming UDP packets on all ports (or at least > 1024) from the printer.  The netdiscovery tool uses UDP on a variable port.  The iptables rule is something like this:
iptables -A INPUT -p udp -s PRINTER -j ACCEPT

Where PRINTER is the network name or IP address of the printer.  (If the printer is on a static IP, that is more reliable because network names do not always resolve when the firewall first loads upon boot.  If it isn't static and the name isn't resolving correctly,  you can use a range of IP addresses, such as, to ensure that whatever dynamic IP address it has is in the allowed range.)

I have never used UFW or GUFW, and from the available documentation it is not obvious to me how one could set up this rule using that interface.  Because GUFW is 2 steps removed from the actual firewall (iptables -> ufw -> gufw), you may give up a lot of flexibility using it.
I don't use it, so can't say for certain.  But I suspect that the answer is "no" unless you either uninstall it or disable whatever script is starting it upon boot (but that may also render it useless).
apt-get install samsungmfp-driver-4.00.35=4.00.35-2 samsungmfp-scanner=4.00.35-2 samsungmfp-configurator-qt3=4.00.35-2.2

The ".2" for the version of the configurator was left out of my previous post.
Use this to get the older packages (you will probably need to remove all existing samsungmfp packages first to ensure dependencies work correctly):
apt-get install samsungmfp-driver-4.00.35=4.00.35-2 samsungmfp-scanner=4.00.35-2 samsungmfp-configurator-qt3=4.00.35-2
It looks to me like your hardware is being mis-identified.  Have you tried using different USB ports?

You might also want to try the 4.00.35-2 package versions, which have the older scanner binaries and might work if there is just some odd interaction on your system.
Quote from: mbriseno on April 02, 2013, 23:11:36
Hi there. First thanks for your useful help. I followed all your instructions and Ubuntu 12.04 recognizes the Samsung scanner. But, when I re started my computer and I logged into Ubuntu a Samsung window appeared (I attached it). After that I tested my new scanner using Xsane scanner program. It works great, but I found the following problem:

The popup is the smart panel, which I don't deal with, and not the driver itself.

Quote from: mbriseno on April 02, 2013, 23:11:36
All the images that I scanned had a section of the letter size. (I attached one).  I checked the Xsane scanner program, I found the following information: 12.80 cm x 14.70 cm. I couldn't modify this option on the Xsane scanner program configuration.

Do you have the preview window open (window -> show preview)?  That provides the interface generally used to change the size in xsane (whether or not you actually use the preview).

Quote from: mbriseno on April 02, 2013, 23:11:36
I decided to use the Samsung Smart panel, but it didn't work.

Any idea, how to fix this problem?

Thanks in advance.

The smart panel (I believe) is just for interfacing to specific printing features.  You need the Configurator to control the scanner.
That is what I meant.  When I have some time (probably not for a month or so), I'll see if I can come up with anything else.
Try these suggestions if you haven't already:

Post again if none of those helps.
Try this:

Otherwise installing the samsungmfp-scanner package from this repository will pull in the necessary bits.  You can still use the existing printer driver without any changes, whether you use the print driver from this repository or not does not affect the ability to use the scanning part (though the printer driver will have to install).
The only immediate possibility that comes to my mind is a group issue (e.g., not being in the lp group).  I agree it's a bit odd.
When I finally get to this, I'll include all the changes you've made into the repository.
You're welcome.  I went through a similar cycle of frustration with the driver and a Samsung printer several years ago.

If you want the PSU and smartpanel, you can get them directly from Samsung; the versioning of those is essentially independent of the driver, so the downloads provided for your printer should work.  (And if they aren't provided for your printer from Samsung's website, they probably wouldn't work anyway.)
Quote from: binarynut on March 25, 2013, 09:34:44
What packages are you referring to in Mint repository ?
That repository will work with Mint as-is.
This sounds like either a complex interaction between glibc, cups, and the driver that only appears with the particular combination of versions you have on your Fedora 17 system, or it is just another quirk of the Samsung installer that it simply does not work well on all systems.  For your Mint systems, I suggest trying the repository - many people have reported that installing with the packages is far more reliable, possibly because the dependency resolution is much better than the script used by the Samsung installer.  For your Fedora system, either update to Fedora 18 or use alien to convert the .deb packages you want to .rpm.

In a few months I may have time to look into building proper .rpm packages for Fedora users, but that's a large time investment I simply can't make right now.
What conflict are you getting, and are you using the Ubuntu package or the download from Google?  Although I don't use Google Earth, I just downloaded the 64-bit .deb from Google and it had no conflict on my system when preparing to install.
I'm not sure what to make of that, particularly for Mint.  There have been conflicts between particular libc versions and the driver before, but 2.15 is standard in Ubuntu 12.10 which numerous people have reported working (I'm still using 2.13).

Are you using the Samsung installer or the packages?  And if the latter, have you tried different versions of the driver?  If you are using the Samsung installer, trying the installer for a different printer may work around the issue (there are various versions on this website).
Printing / Re: SAMSUNG SCX 4521 F
March 18, 2013, 20:13:48
Quote from: nickaidin on March 18, 2013, 07:14:19
I wanted to ask furthermore if there is a way for me to have the scanning source of this maschine autoselected in libreoffice writer. Since everytime i log in to my ubuntu (64bit 12.10) i have to select source of importing scanning software.

I'm not aware of any way to do so and can see no indication that there is a setting to store that information in.  I don't generally use that interface, but a quick test on my system (Libreoffice 4.0.0 on this particular machine) indicates that the insert -> picture -> scan -> request only works after I have first selected the source.  Which is slightly odd, because "select source" works with the scanner regardless of the source actually selected.  (In my case, the interference is a USB camera and the scanner is a Canon flatbed, so this is an issue that has nothing to do with the multifunction aspect of a printer.)

Filing a wish request in their bug tracker might be the way to go.
You can try removing that printer and configuring a new one to get an appropriate driver match.

Failing that, uninstall the driver you downloaded and try again using the repository packages provided through this site; many people who have trouble with the "official" drivers find they work fine via a package setup (even though the binary files are identical).
Repository Information Legal Contact Alternative Drivers