SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

Recent Posts

Pages: [1] 2 3 4 5 6 ... 10
1
Printing / Re: CLP-510 on raspberry pi 3
« Last post by behnam263 on December 05, 2021, 13:47:50 »
Thank you for the answer, I watched the link and realized that also other people get the same error that i get
when they try to install the qemu-user emulation of amd64 package :

The following packages have unmet dependencies:
 suld-driver2-1.00.39:amd64 : Depends: libxml2:amd64 but it is not installable
                              Depends: libstdc++6:amd64 but it is not installable
                              Depends: libusb-0.1-4:amd64 but it is not installable
                              Depends: libcupsimage2:amd64 but it is not installable
E: Unable to correct problems, you have held broken packages.

So I am going for the second option to test.
2
Printing / Re: CLP-510 on raspberry pi 3
« Last post by bchemnet on December 05, 2021, 12:02:08 »
I think you have two options.  One is to follow this thread, but use one of the version 3.xx drivers that support that printer instead of the latest package:
https://www.bchemnet.com/suldr/forum/index.php?topic=386.0

The other option is to set the printer to be a "generic postscript" as the printer type.  I seem to recall that works okay with that model, although not quite as well as the dedicated driver.
3
Printing / CLP-510 on raspberry pi 3
« Last post by behnam263 on December 05, 2021, 05:11:38 »
Hello, I tried to install drivers for a Samsung CLP-510 printer, but because I'm using a Raspberry Pi 3 with an arm7 processor,
I can't install anything except unified driver 4.01, which is outside the printer's minimum and maximum support range.


Is there anything that can be done to fix it and make it function, or is there a solution?
4
Printing / Re: Howto enable SULD drivers on rasberrypi
« Last post by ellepdesk on November 26, 2021, 09:06:45 »
@Eim: My experiments with this driver are not on raspberry hardware, but on a Cubieboard2 (arm7) and a NanoPI Neo4 (arm64)

Do you get the (exact) same error for libc when using ubuntu for raspberry?
5
Printing / Re: Howto enable SULD drivers on rasberrypi
« Last post by Eim on November 26, 2021, 02:10:19 »
Thanks. No luck with ubuntu server 20.04 32-bits either.

@ellepdesk: What armbian version or image did you use?
I don't see Raspberry Pi 3B+ in the list of supported devices on their website: https://www.armbian.com/download/?device_support=Supported
6
Printing / Re: Howto enable SULD drivers on rasberrypi
« Last post by ellepdesk on November 25, 2021, 00:24:46 »
@Eim:
Yes, that is the libc issue that happens on raspberry pi os.

I've had success with armbian as os
7
Printing / Re: Howto enable SULD drivers on rasberrypi
« Last post by Eim on November 24, 2021, 14:32:35 »
IMPORTANT NOTICE:
This procedure is BROKEN for raspberry os/raspbian, due to a difference in the version of libc used!
@ellepdesk: what OS did work for you?

I'm running on Raspberry Pi OS 32 bit based on debian bullseye.

Followed the guide with amd64 and i386 and neither works for me. Here's the output of the amd64 attempt, I can post the i386 output as well.

root@raspberrypi:~# apt update
Hit:1 http://deb.debian.org/debian bullseye InRelease
Hit:2 http://archive.raspberrypi.org/debian bullseye InRelease                                     
Hit:3 http://raspbian.raspberrypi.org/raspbian bullseye InRelease                                 
Hit:4 https://www.bchemnet.com/suldr debian InRelease
Get:5 https://www.bchemnet.com/suldr debian/extra amd64 Packages [3,796 B]
Fetched 3,796 B in 2s (2,083 B/s)
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
All packages are up to date.
N: Skipping acquire of configured file 'main/binary-amd64/Packages' as repository 'http://raspbian.raspberrypi.org/raspbian bullseye InRelease' doesn't support architecture 'amd64'
N: Skipping acquire of configured file 'contrib/binary-amd64/Packages' as repository 'http://raspbian.raspberrypi.org/raspbian bullseye InRelease' doesn't support architecture 'amd64'
N: Skipping acquire of configured file 'non-free/binary-amd64/Packages' as repository 'http://raspbian.raspberrypi.org/raspbian bullseye InRelease' doesn't support architecture 'amd64'
N: Skipping acquire of configured file 'rpi/binary-amd64/Packages' as repository 'http://raspbian.raspberrypi.org/raspbian bullseye InRelease' doesn't support architecture 'amd64'

root@raspberrypi:~# apt install suld-driver2-1.00.39:amd64
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gnupg : Depends: dirmngr (< 2.2.27-2.1~)
         Depends: dirmngr (>= 2.2.27-2)
         Depends: gnupg-utils (< 2.2.27-2.1~)
         Depends: gnupg-utils (>= 2.2.27-2)
         Depends: gpg (< 2.2.27-2.1~)
         Depends: gpg (>= 2.2.27-2)
         Depends: gpg-agent (< 2.2.27-2.1~)
         Depends: gpg-agent (>= 2.2.27-2)
         Depends: gpg-wks-client (< 2.2.27-2.1~)
         Depends: gpg-wks-client (>= 2.2.27-2)
         Depends: gpg-wks-server (< 2.2.27-2.1~)
         Depends: gpg-wks-server (>= 2.2.27-2)
         Depends: gpgsm (< 2.2.27-2.1~)
         Depends: gpgsm (>= 2.2.27-2)
 libcrypt1 : Depends: libc6 (>= 2.25) but it is not installable
 perl-base : PreDepends: libc6 (>= 2.29) but it is not installable
 suld-driver2-1.00.39:amd64 : Depends: cups:amd64 or
                                       cupsys:amd64 but it is not installable
                              Recommends: sane-utils:amd64
E: Unable to correct problems, you have held broken packages.

@ellepdesk Is this the libc error you are reffering to?

Also I've added the debian bullseye package source:
root@raspberrypi:~# cat /etc/apt/sources.list.d/raspi.list
deb [arch=amd64] http://deb.debian.org/debian/ bullseye main
#deb [arch=i386] http://deb.debian.org/debian/ bullseye main
8
Scanner Server (Scan to PC) / Re: scan2pc.sh bash script
« Last post by bchemnet on October 15, 2021, 22:07:15 »
I have no way of testing or improving this, but will pin the thread so it is easily discoverable.
9
Scanning / Scx3400 scanner half paper
« Last post by cokiere on October 05, 2021, 00:28:25 »
Hello
I have a scx3400. Print and scanner get Driver immidiatly, but the scanner doesn't work properly: It scan 297x126mm only.
I tryed with a distro live whithout solved
Thanks for any suggestions
10
Scanner Server (Scan to PC) / Re: Scan to PC is dead
« Last post by mak2109 on October 02, 2021, 09:08:49 »
Dear bchemnet,

I can partly answer my questions after having a slightly deeper look into the py sources.

- The M_PDF functionality is implemented in the samsungScannerServer.py

As I could see, the relevant action handling regarding the dialog with multi page is taking place in class "TCPproxy" and class "_ModSaneIterator".

I fiddled a bit with the "1b a8" requests and the "a8" answers but could not bring the scanner to react in a usable manner. Therefore I added a little bit efford to complete the bash script implementation.

As you asked me to enter the script in a new tread, I opened the thread "scan2pc.sh bash script".
Pages: [1] 2 3 4 5 6 ... 10
Repository Information Legal Contact Alternative Drivers