SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

Recent Posts

Pages: [1] 2 3 4 5 6 ... 10
1
Printing / Re: problem of printing in wifi: weird symbols
« Last post by dorfsmay on August 31, 2019, 19:03:00 »
I tried different versions of the driver, going way back... and it didn't help.

So I re-installed the latest driver, that driver is needed for scanning, then went and customized CUPS. Copy pasting my posting on askubuntu:

https://askubuntu.com/questions/1169909/samsung-wifi-printer-printing-garbage-after-upgrading-to-18-04/1169910

    open a browser
    navigate to localhost:631
    click on "Printers" in top bar
    click on name of the printer (Samsung...)
    Click on the "Administration" drop down menu, and select "Modify Printer"
    You'll be prompted for your user id and password, enter your Linux login credentials
    select the first printer in "Discovered Network Printers", "Continue"
    "Continue" again
    select "Samsung XXXXX driverless cups-filters", "Modify Printer"
2
Scanner Server (Scan to PC) / Scan to PC is dead
« Last post by bchemnet on August 31, 2019, 17:29:23 »
For all practical purposes, the Scan to PC utility is dead and will rarely work.  Nobody is actively maintaining it.  You are free to try it, but if it does not work then you are on your own.  For the reasons outlined in the link below, there is no real motiviation to address the issues.

See this announcement: https://www.bchemnet.com/suldr/forum/index.php?topic=366.0
3
Announcements / Why the driver is working less often
« Last post by bchemnet on August 31, 2019, 17:17:55 »
HP has shown no interest in updating the Samsung printer driver, and has no financial incentive to do so (after all, there has not been a new Samsung-branded printer in nearly 3 years as of this moment).  As of this post, the latest driver release is nearly 3 years old, and is really based on code that is now 5 or more years old.  So the driver is going to gradually stop working on modern Linux systems as Linux and CUPS continue to evolve.

In addition, qt3 and qt4 are long obselete, so the Configurator packages (last updated 7 years ago) will often not install, or even if they do they still not work.  This will continue to get more frequent.  Even if you do manage to get everything installed, note that the relevant qt packages depend on an obselete and insecure openssl, and will not work with a modern library.  That is the main reason I am not attempting to repackage these programs in a way that will allow them to be installed even after distros drop the necessary dependencies.

Finally, CUPS has made design changes that, starting with version 2.3 (included in most mid-2019 Linux distros), are intended to make all drivers and PPD (printer instruction) files obselete.  As of 2.3, some releases of CUPS already do not work with the Samsung PPD files due to the use of non-standard keys in the Samsung PPD files.  Sometime in the next couple of years, it is likely that a current CUPS install will simply not work at all with these drivers on any system.  The new approach for CUPS is based entirely on the IPP protocol, which some (but by no means all) Samsung printers support, to varying extents.  See, for example:
https://www.cups.org/blog/2018-06-06-demystifying-cups-development.html
https://github.com/apple/cups/issues/5562

Somewhat related, scanning support that depends on the Samsung drivers continues to get less reliable each year due to various system changes in Linux, and there is no work around for this.

So nearly all Samsung-branded printers are going to stop working in Linux over the next few years if you keep an up-to-date system.  I will continue to host the files and resources here for a couple of more years, but after that there will not be much point and the best solution to a non-working Samsung printer will probably be to replace it.
4
Printing / Re: problem of printing in wifi: weird symbols
« Last post by bchemnet on August 31, 2019, 16:59:22 »
Unfortunately, all I can offer as a solution is to try a different version of the driver.  Or to contact HP to see if they have any interest in developing an updated driver, but I doubt it both because they have no financial incentive and because CUPS is making changes that will eventually make obselete all drivers in Linux (and printers that do not support the new CUPS approach).
5
Printing / Re: problem of printing in wifi: weird symbols
« Last post by dorfsmay on August 31, 2019, 13:03:04 »
I have the same issue, well almost, with a M3065FW:

- first time I print is fine
- then it prints the postscript source (pages and page of what looks like random characters, but you can tell it's postscript)

It starts working fine again, for a single print, after I either reboot or unplug/replug the printer (honestly not sure which of the two).

I installed suld-driver2-1.00.39 through the repository on Ubuntu 18.04.

I never that problem with Ubuntu 14.04 with, I'm not sure which previous version of the driver.
6
Printing / Re: problem of printing in wifi: weird symbols
« Last post by in_die75 on August 19, 2019, 00:42:28 »
I'm sorry I was wrong for the number, it's 467...

I've already installed the uld driver and I think it's the Samsung version.
The printing works only with the USB connection, whereas the scanner doesn't work even when connected by USB.
7
Printing / Re: problem of printing in wifi: weird symbols
« Last post by bchemnet on August 18, 2019, 06:44:33 »
Do you mean the c467 (not c647)?  As far as I know Samsung, never produced a printer with a model number of c647 (or c6 anything).

My three suggestions are to (in no particular order):
1. If you installed via the repository, try using the Samsung installer.  Or if you installed using the Samsung installer, switch to using the repository.
2. Try a different driver version within the supported range.
3. Try printing by USB, even if only temporarily, to determine if it is a problem specific to the wireless connection.
8
Printing / problem of printing in wifi: weird symbols
« Last post by in_die75 on August 15, 2019, 11:17:26 »
Hi,

I've just installed my Samsung Xpress c647 printer in WIFI and my problem is that the result doesn't correspond to the original document.
It prints a lot of pages with weird symbols, it seems like it's an encoding problem (but why does it print a lot of pages instead of one ?).
Can you help me please !?

Regards,
Christelle

9
Success Stories / Success with Samsung ML-1670 under Manjaro
« Last post by inksi on July 18, 2019, 15:07:09 »
Hi,

I inherited a Samsung ML-1670 which was lucky because the old hp has long been a source of trouble. But I could not get the little Samsung to work except under Windows - which I never really use

The printer did not appear in the cups list despite having added in most available extra driver packages (all the foomatic ones, the splix one, and maybe more)
The ML-1660 driver did not work
no generic 5e selections worked
no foomatic selections worked
I never found a linux driver on the Samsung site

The most I could get was a test page telling me 'Internal Error - Please use the proper driver'.

I tried no end of hints and workarounds then for some reason, perhaps a simpler search, the SULDR site popped up. I downloaded the 1.00.27 driver and unzipped the gzipped tar 'UnifiedLinuxDriver-1.00.27.tar.gz' in my Download directory. Then I did a cd to the uld directory created and issued the command
$ sudo ./install-printer.sh

This did the trick, I modified the printer under CUPS and saw the new driver there read;y for selection ....
So easy ...

BINGO

Very grateful because I needed a new printer but could not afford a new one. I hope we have solved this for posterity. I wish there was such a workable solution for the hp :)

many many thanks.
inksi

10
Printing / Re: ML-1670P Printer Gives Internal Error after upgrade Fedora 30
« Last post by bchemnet on June 11, 2019, 05:50:08 »
I solve this problem in ubuntu 19.04 installing printe-driver-splix and this openprinting ppd --> https://mega.nz/#!9kcz2Cbb!xwTwiaD-RJTtEDu19V1NFSxZiAcRLapId0HO82Rs3Vc
Thanks for sharing.  Note that a more stable link to the ppd is https://github.com/rshev/SpliXextras .  It is possible that sufficiently motivated individuals could use this as a model for adapting other PPD files for use with splix (printing only, not for scanning), as the content differences between this and the Samsung PPD are not large.
Pages: [1] 2 3 4 5 6 ... 10
Repository Information Legal Contact Alternative Drivers