Sticky
SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

Recent Posts

Pages: 1 [2] 3 4 5 6 7 ... 10
11
I solve this problem in ubuntu 19.04 installing printe-driver-splix and this openprinting ppd --> https://mega.nz/#!9kcz2Cbb!xwTwiaD-RJTtEDu19V1NFSxZiAcRLapId0HO82Rs3Vc
12
Printing / Re: ML-1670P Printer Gives Internal Error after upgrade Fedora 30
« Last post by Anil on May 12, 2019, 04:40:20 »
Thanks a million. I used the source from Fedora 29 - cups version 2.2.8-10 and could build it on Fedora 30 without any issues and the printer works.

As you suggested, I have posted a bug report but as you indicated, not much hope of it being addressed.

On the other hand, if Samsung/HP could release the source of the driver, it would be freedom!
13
This error seems to be appearing with several ML printers on distros that have updated to cups 2.2.11 or pulled recent patches into 2.2.10.  Although there are no CUPS errors reported, I believe this is due to some change in CUPS.  Please report it as a bug to Fedora and ask that it be escalated to CUPS.  But honestly I expect that the CUPS team will say "not our problem", as they seem determined to keep making changes that are breaking support for Samsung printers.

As a fix, my best suggestion is to revert back to CUPS 2.2.10.
14
Printing / ML-1670P Printer Gives Internal Error after upgrade Fedora 30
« Last post by Anil on May 10, 2019, 07:06:08 »
I am using the ver 1.0.39.  After upgrading to Fedora 30, the printer is printing the following message whenever a document contains any image, even if grayscale;

INTERNAL ERROR - uw_color == 4
SYSTEM : h6fw_5.49/x1_image
LINE : 341
VERSION : SPL 5.49 10-20-2010

Cups does not seem to show any error.
15
Printing / Re: CLP 320N not working anymore: SPL-C ERROR
« Last post by bchemnet on May 04, 2019, 18:08:55 »
This problem is related to the CUPS issue reported here:
https://github.com/apple/cups/issues/5562

The gist is that CUPS is making changes that are not compatible with the Samsung drivers.  CUPS 2.2.11 has recently been patched to restore working behavior for Samsung printers, but there is no guarantee that will remain true.  Debian inherited the problematic change in 2.2.10-4 and it may remain as of 2.2.10-6.  If you are using a Debian-based distribution and still have this problem, report it to the bug tracker and reference the CUPS issue above.

This is all related to a complete change in the way that CUPS handles printer drivers, as described here:
https://www.cups.org/blog/2018-06-06-demystifying-cups-development.html

The gist is that printers that do not use IPP, and/or that use custom drivers such as the Samsung driver, and at risk of no longer working after CUPS 2.3 is released (although they will likely continue working for some unknown amount of time after the initial release).  Some of the newer Samsung-branded printers support IPP, so will not necessarily be affected by the changes.  I do not know what the long-term implications are for continuing to provide this repository and the associated drivers.
16
Success Stories / Re: SL-M2875FD Ubuntu 16.04 printing and scanning over LAN
« Last post by TeddyLad on April 23, 2019, 05:56:05 »
What if the named printer option doesn't show up? What could be causing this?
17
Using the Repository / Re: repo broken
« Last post by oldunixguy on April 09, 2019, 23:22:08 »
Happened again recently.... the rm -rf /var/lib/apt/lists/* cure does cure it!
thanks
oldunixguy
18
Printing / Re: CLP 320N not working anymore: SPL-C ERROR
« Last post by bchemnet on March 29, 2019, 21:37:10 »
I suggest trying to revert your CUPS package to the previously installed verison (e.g., using snapshot.debian.org, although you may need multiple packages) to see if the printer works again.  If so, then it is a bug in CUPS and should be reported through the Debian bug reporter.
19
Printing / CLP 320N not working anymore: SPL-C ERROR
« Last post by cris on March 28, 2019, 07:54:35 »
Suddenly my CLP 320N (connected via LAN) started to print blank pages with the following error:

SPL-C ERROR - Please use the proper driver
    POSITION : 0x0 (0)
    SYSTEM : src_5.47/xl_image
    LINE : 629
    VERSION : SPL-C 5.47 01-15-2010

Up until now the SULD driver worked perfectly.

I've tried to remove/reinstall the SULD driver several times, trying different versions of the driver1 and driver2: nothing helped.

Printing works again (although with bad quality) if I select the Foomatic/foo2qpdl driver.

I'm not sure if this might have something to do with a CUPS upgrade:
I'm using Debian Testing and CUPS version is 2.2.10-4 .

Thank you in advance.
20
Announcements / Re: Repository update: v1.00.36
« Last post by bchemnet on March 01, 2019, 06:26:32 »
I have reworked the supported printers page to make recommended versions more clear.
Pages: 1 [2] 3 4 5 6 7 ... 10
Repository Information Legal Contact Alternative Drivers