SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

Recent posts

#41
Printing / Re: Howto enable SULD drivers ...
Last post by steffl - September 16, 2022, 13:24:51
For everyone running into the libc6 issue, or any other issue when installing Suldr on Rasperry Pi OS there is another potential way to get Samsung printers working using the so called Splix Samsung printer driver package.

This can be easily installed by just running installing it from the default debian sources like this:

sudo apt install printer-driver-splix
No fiddling needed. The drivers will then show up in CUPS when setting up your printer. If your exact model isn't listed you should try the closest one. In my case I am using the SCX-3200 driver, which works fine for my SCX-3400 printer.

Further infos:
- https://packages.debian.org/de/bullseye/printer-driver-splix
- http://splix.ap2c.org/
#42
Announcements / Major forum upgrade
Last post by bchemnet - May 21, 2022, 17:05:49
The forum has undergone a major upgrade.  If you run into technical issues that seem related, let me know.
#43
Success Stories / Re: Samsung ML-1665
Last post by bchemnet - March 02, 2022, 08:18:52
You are welcome.  I am glad it helped to keep old hardware working.
#44
Success Stories / Samsung ML-1665
Last post by julian67 - March 01, 2022, 12:51:29
Just posting to say thank you for making these drivers available in a way which suits the way Debian works, and for presenting everything clearly.  My Samsung ML-1665, purchased today, ancient and used, for not a lot of £,  is now working nicely as a networked printer attached via USB to a similarly ancient HP Proliant Microserver running Debian Bullseye headless.  Thank you! 
#45
Using the Repository / Re: suld-configurator-2-qt4 an...
Last post by mkrueger - January 23, 2022, 08:13:50
This is sad because the network scanner was also addressed and managed by the driver. But ok, thanks for the answer.
#46
Using the Repository / Re: suld-configurator-2-qt4 an...
Last post by bchemnet - January 23, 2022, 08:07:43
There is no development on any part of this project.  The Qt interface development was actually discontinued 9 years ago, well before Samsung sold their printer business to HP in 2016.  HP has not shown any interest in developing the driver (the last true update was nearly 6 years ago), let alone reviving that interface.  And there is no practical way to get Qt4 working in the latest Debian-based distributions due to some severe security issues that were discovered after Qt4 development ended.

However, you should be able to use system-config-printer to set up the printer.
#47
Using the Repository / suld-configurator-2-qt4 and De...
Last post by mkrueger - January 21, 2022, 19:15:52
I use antiX 21 as a 32 bit version (based on Debian 11 bullseye). Unfortunately, Debian 11 no longer supports QT4. For the installation of my Samsing CLX 3185 the program suld-configurator-2-qt4 is required.

Are there plans to create a corresponding update to QT5? Are there alternative options?
#48
Printing / Re: CLP-510 on raspberry pi 3
Last post by behnam263 - December 05, 2021, 13:47:50
Thank you for the answer, I watched the link and realized that also other people get the same error that i get
when they try to install the qemu-user emulation of amd64 package :

The following packages have unmet dependencies:
suld-driver2-1.00.39:amd64 : Depends: libxml2:amd64 but it is not installable
                              Depends: libstdc++6:amd64 but it is not installable
                              Depends: libusb-0.1-4:amd64 but it is not installable
                              Depends: libcupsimage2:amd64 but it is not installable
E: Unable to correct problems, you have held broken packages.

So I am going for the second option to test.
#49
Printing / Re: CLP-510 on raspberry pi 3
Last post by bchemnet - December 05, 2021, 12:02:08
I think you have two options.  One is to follow this thread, but use one of the version 3.xx drivers that support that printer instead of the latest package:
https://www.bchemnet.com/suldr/forum/index.php?topic=386.0

The other option is to set the printer to be a "generic postscript" as the printer type.  I seem to recall that works okay with that model, although not quite as well as the dedicated driver.
#50
Printing / CLP-510 on raspberry pi 3
Last post by behnam263 - December 05, 2021, 05:11:38
Hello, I tried to install drivers for a Samsung CLP-510 printer, but because I'm using a Raspberry Pi 3 with an arm7 processor,
I can't install anything except unified driver 4.01, which is outside the printer's minimum and maximum support range.


Is there anything that can be done to fix it and make it function, or is there a solution?
Repository Information Legal Contact Alternative Drivers