SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

Recent Posts

Pages: 1 ... 4 5 6 7 8 [9] 10
Scanner Server (Scan to PC) / Scan to PC C480FW
« Last post by evolutionwate on January 09, 2019, 15:35:23 »

I have the software setup and it sees my C480FW printer:

INFO:stdout:# Initiating version 0.4.5
INFO:stdout:At program termination joining log listener process with:
INFO:stdout:    <function exitListener at 0x7f01dae6a320>
INFO:stdout:Used '/etc/samsungScannerServer.conf' as configuration file.
INFO:stdout:Below is what was configured with it.
INFO:stdout:CONFIG: SCANNER_SANE_NAME = 'smfp:SAMSUNG C48x Series on'
INFO:stdout:CONFIG: SERVER_NAME='ScanServer'
INFO:stdout:CONFIG: OUTPUT_PREFIX='${homedir}/Scans/SCAN_${date}__${uid}'
INFO:stdout:CONFIG: def contrastFilter(im):
INFO:stdout:CONFIG:     return ImageOps.autocontrast(im,10)
INFO:stdout:CONFIG:  { 'name' : 'S_PDF-300' , 'color' : 'COLOR_TRUE' , 'resolution' : 'DPI_300' , 'format' : 'FORMAT_S_PDF' , 'size' : 'SIZE_A4' , 'output' : OUTPUT_PREFIX ,   'filters' : [ ] } ,
INFO:stdout:CONFIG:  { 'name' : 'JPEG-300'    , 'color' : 'COLOR_GRAY' , 'resolution' : 'DPI_300' , 'format' : 'FORMAT_JPEG'   , 'size' : 'SIZE_A4' , 'output' : OUTPUT_PREFIX ,   'filters' : [ ] } ,
INFO:stdout:CONFIG: ]
INFO:stdout:CONFIG: MODES2SANE={'COLOR_MONO':'Black and White - Line Art', 'COLOR_GRAY':'Grayscale - 256 Levels','COLOR_TRUE':'Color - 16 Million Colors'}
INFO:stdout:CONFIG: SIZE2SANE={'SIZE_A4':'A4', 'SIZE_A5':'A5', 'SIZE_B5_JIS':'B5 (JIS)', 'SIZE_EXECUTIVE':'Executive', 'SIZE_LETTER':'Letter', 'SIZE_LEGAL':'Legal', 'SIZE_FOLIO':'Folio'}
INFO:stdout:CONFIG: LOG_NAME="/var/log/samsungScannerServer.log"
INFO:stdout:The following was automatically configured.
INFO:stdout:AUTOCONFIG: OWNER = 'root'
INFO:stdout:AUTOCONFIG: HOME_DIR = '/root'
INFO:stdout:Newly registered server 'ScanServer' with UniqueID 'baedb6dcf11ec51f' has got
INFO:stdout:    InstanceID '13'.
INFO:stdout:At program termination unregistering server with:
INFO:stdout:    <function unregisterServer at 0x7f01dae350c8>
INFO:stdout:Init SANE ...
INFO:stdout:Connecting to scanner ...

INFO:stdout:Connected to scanner.
INFO:stdout:Waiting for scan job ...

INFO:stdout:    Got it!
INFO:stdout:Waiting for user selection ...
INFO:stdout:Reconnected, waiting for user selection ..

When I go to the printer and select print to PC, then select my server name, select the scan properties, it says "not available" on the printer screen and beeps.  Nothing is updated on the server side and the python script just sits at "waiting for scan job"

Thanks for any help, not sure what i can do to debug any further
Scanning / Re: SCX 3400 on ubuntu 18.04.1
« Last post by Wey on December 21, 2018, 02:45:04 »
Hi all, firstly, sorry about my english. I will try to explain how finally can operate my scanner SCX-3400

Maybe, some step was unnecessary, who knows...

All starts in

Add repository:
    :~$ sudo vi /etc/apt/sources.list
    #Samsung Unified Driver Repo
    deb debian extra
    # deb-src debian extra

Try to search samsung drivers...bad luck
    :~$ aptitude search samsung
         "" nothing ""

Search, download and install appropiate driver
    *run as root (also add $user to lp group)

Patch sane config files

Made some links
    sudo ln -sfr /usr/lib/sane/libsane-smfp* /usr/lib/x86_64-linux-gnu/sane

Here, still not working... :-/

Install Suld-scanner-usblp-fix

BINGO!! simple-scan, xsane,...can scan now!!

Un saludo y gracias!!!!
Success Stories / Re: M2070W on Ubuntu: success!
« Last post by andyviv on December 20, 2018, 14:30:13 »
Hi there, I have a new Samsung Xpress m2070w printer and I have been struggling to install it in Ubuntu 18.01 on my desktop. Can anyone please aid with some instructions through the terminal route. Would really appreciate any assistance. The printer shows up in settings but am unable to select the correct drivers.
General Discussion / Re: A little contribution
« Last post by bchemnet on December 16, 2018, 21:00:50 »
Thanks for the input.  I have taken some of your suggestions.  The two main ones I did not take were the suggestion for sans-serif and to narrow the text display.  Personally I find serif much easier to read, I know all about the arguments for why sans is supposed to be easier on a screen but my experience differs.  And I admit to being a real dinosaur about the text padding issue, because I prefer to control text width by managing window size, and artificially narrowing the display complicates my window mangement.

Neither of those is a good argument for user interface design, because I am not the target the audience for this website.  Consider it a silent protest to the design decisions others are making that I dislike.  Of course, I still do not use a "smart" phone and detest all touch interfaces, so my ideas of interface design are far out of sync with current norms.

I am glad that you have found the site useful.
General Discussion / A little contribution
« Last post by diver on December 14, 2018, 12:24:03 »
First and foremost: thanks a lot bchemnet for taking care of properly packaging these nasty drivers and make them available on this repository. It save us a lot of trouble!

Now, while browsing the general FAQ, I found that some people ask about the look of the site and you say that as it is gets the job done (I agree) and you don't have extra time to invest on that. Since I am an experienced web developer, I know everything that it is possible to do regarding the look and feel of a site and, as you, I dislike "flashy" sites with excessive effects where visual design puts appearance before function. Still, I noticed a couple of little changes that could be done to the style precisely to improve the main function of documentation: to be easy to read. I experimented a while, trying to follow the minimalist design you created and to be very conservative on my changes. In addition, I introduced only two minor cosmetic changes that actually make the design simpler (plain table borders and taking blues out of the color palette).

My goal was also to not require any extra effort on your side, so what I propose is to just update the content of with the following:
Code: [Select]
body {
  color: #000000; background-color: #f5f5f5; font-size: large; line-height: 1.25;
  font-family: Liberation Sans, Arial, Helvetica Neue, Helvetica, sans-serif;
  max-width: 75em; margin: 0 auto; padding: 8px;

h1 {color: #303030; text-align: center; font-size: xx-large; font-weight: bolder}
h2 {color: #303030; text-align: center; font-size: x-large; font-weight: bolder}
h3 {color: #303030; text-align: left; font-size: large; font-weight: bold}

a:link {color: #ff1111; text-decoration: none; font-weight: bold}
a:visited {color: #cc0033}
a:hover {color: #ff1111; text-decoration: underline}
a:active {color: #ff33ff}

li {padding-bottom: 0.6em}

table {background-color: #fafafa; border-collapse: collapse}
th, td {border: 1px solid #999999; padding: 0.2em}
th.std, td.std {text-align: center; vertical-align: middle}

Feel free to try it, adjust it to your liking or ask me to correct anything you would prefer to be different. Hope it helps.

Kind regards
Scanning / Re: SCX 4500 on ubuntu 18.04.01 on USB
« Last post by pat on November 28, 2018, 06:19:26 »
It's not the same scanner (SCX 4500 <> SCX 4705).
In my case I also had to install "suld-scanner-usblp-fix". You can try to change usb socket, if possible directly on the motherboard. Check this page

Scanning / Re: SCX 4500 on ubuntu 18.04.01 on USB
« Last post by yanndan on November 28, 2018, 03:20:16 »
Hi pat,

Thanks for your answer but I still cannot scan with linux. I also tried with linux mint and I have the same issue. There is something that bother me: it worked yesterday but it does not work today. I did not change anything in the configuration.

Thanks for everything.
Using the Repository / Re: repo broken
« Last post by parrotlarch on November 27, 2018, 07:12:52 »
Thank you so much! Repo works, and the driver installed!
After applying your tips from point 1 and 2 aptitude told me, that the package apt-transport-https is not installed (and it should be). After installing the package and updating repos everything works fine.

The thing is that only  driver from your repo let me use scanner, I tried official samsung drivers and every tip from the internet. You saved me from using Windows just because of the printer. Once again thanks for your help, and for your hard work!
Using the Repository / Re: repo broken
« Last post by bchemnet on November 27, 2018, 06:02:15 »
W: Failed to fetch  Bad header line

When this error occurs with an otherwise apparently working repository or one that had been working, it pretty much always means some sort of network traffic error occurred.  The error should automatically clear quickly, but apt sometimes get stuck in some odd state.  Usually clearing the cache takes care of it, but obviously not this time.  Some other things you can try to force apt to find the repository again:
1. Change the "http" to "https" in the repository source line.  In some cases, it might be necessary to update the repository files, and then revert back to "http" to get it to work.
2. Comment out/deactivate (or delete) the bchemnet repository line, update apt, add the line back and update again.
3. If neither of the above works, it could be a persistent DNS or path resolution problem.  (However, I doubt this because if it was you would probably not be able to reach this forum.)  If know how, you can try changing the DNS servers being used by your computer/network, updating apt, and then changing the DNS servers back.
4. Wait 24 hours, clear the cache again, and repeat 1 or 2.
Using the Repository / Re: repo broken
« Last post by parrotlarch on November 27, 2018, 02:18:20 »
Tried it again,and cleared the cache, but no luck.
Great thanks, for such a quick reply!!
Pages: 1 ... 4 5 6 7 8 [9] 10
Repository Information Legal Contact Alternative Drivers