SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

Author Topic: configurator not working  (Read 8746 times)

augusto

  • Splashing around
  • ***
  • Posts: 6
    • View Profile
  • Linux Distribution: xubuntu 12.04
  • Printer: scx-4100
configurator not working
« on: June 14, 2012, 07:15:33 »
xubuntu 12.04 usb scx4100

samsungmfp-configurator-qt4 / driver driver 4.00.35

Hello, I was able to get scanner to work with usblp-fix

when i start configurator, choose scanner, and then select properties, the windows opens but immediately closes; looks like some dependencies were missing.

thanks

Paolo

bchemnet

  • Administrator
  • *****
  • Posts: 547
    • View Profile
  • Linux Distribution: Debian Testing
  • Printer: none
Re: configurator not working
« Reply #1 on: June 15, 2012, 09:32:28 »
when i start configurator, choose scanner, and then select properties, the windows opens but immediately closes; looks like some dependencies were missing.

First, try running as superuser, assuming you have been running as regular user, and see if the same behavior occurs.  If it works as superuser, then it's a permission problem somewhere.

If so, please run "/opt/Samsung/mfp/bin/Configurator" in a terminal, try to open the window, and then close Configurator.  Post any output from the terminal.  If there isn't any output that looks like it occurred when the window closed, then try "strace /opt/Samsung/mfp/bin/Configurator 2> strace.txt" in a terminal, try to open the window, close Configurator, and then attach the strace.txt file to a post here.

augusto

  • Splashing around
  • ***
  • Posts: 6
    • View Profile
  • Linux Distribution: xubuntu 12.04
  • Printer: scx-4100
Re: configurator not working
« Reply #2 on: June 15, 2012, 10:49:08 »
doesn't work as root too

sudo /opt/Samsung/mfp/bin/Configurator
[sudo] password for augusto:
Il pacchetto "cupsys-common" non č disponibile.
Usare "dpkg --info" (= "dpkg-deb --info") per esaminare gli archivi e
"dpkg --contents" (= "dpkg-deb --contents") per elencarne il contenuto.
ScannerPlugin - font = 10


cupsys-common doens't exist in ubuntu 12.04, as far as i can understand

by the way, the super user configurator command which comes with repositories (su-to-root -X -c /opt/Samsung/mfp/bin/Configurator) doesn't work - gksudo would probably work here

bchemnet

  • Administrator
  • *****
  • Posts: 547
    • View Profile
  • Linux Distribution: Debian Testing
  • Printer: none
Re: configurator not working
« Reply #3 on: June 15, 2012, 18:19:00 »
cupsys-common doens't exist in ubuntu 12.04, as far as i can understand
Has not existed for a long time, it was renamed "cups" several years ago.  That is a meaningless error.

Please run the strace command and post the output (you may have to install strace), and hopefully I can find something in that to indicate what the problem is.

by the way, the super user configurator command which comes with repositories (su-to-root -X -c /opt/Samsung/mfp/bin/Configurator) doesn't work - gksudo would probably work here
Ubuntu must have stopped including the "menu" package by default at some point.  I'll update the dependencies to explicitly include it next time I update the packages.  I use su-to-root because it is a minimal way to handle it, whereas gksu isn't always installed (and KDE users will be irritated if I make them install a bunch of GTK stuff just for that, the same way Gnome users would be irritated to install half of KDE to use the KDE equivalent).  su-to-root sorts all that out and users whatever is already installed.  In the short term, and if you need to, you can make it work by installing menu.

augusto

  • Splashing around
  • ***
  • Posts: 6
    • View Profile
  • Linux Distribution: xubuntu 12.04
  • Printer: scx-4100
Re: configurator not working
« Reply #4 on: June 15, 2012, 18:50:47 »
here you find

bchemnet

  • Administrator
  • *****
  • Posts: 547
    • View Profile
  • Linux Distribution: Debian Testing
  • Printer: none
Re: configurator not working
« Reply #5 on: June 17, 2012, 07:38:56 »
Unfortunately nothing obvious is wrong.  The Configurator appears to be behaving as if it decides it can't support the scanner, but I can't determine why.

Have you tried an alternate scanning interface like xsane?

You can also try the following:
1. Install samsungmfp-scanner-sane-fix-multiarch
2. Test Configurator (and alternate interface if possible)
3. Only if it is not working at this point, edit "/etc/sane.d/dll.d/smfp-scanner" (as root/sudo) and put a "#" in front of the "smfp"
4. Test Configurator (and alternate interface if possible)
5. If it still does not work, edit the smfp-scanner file and remove the "#"

augusto

  • Splashing around
  • ***
  • Posts: 6
    • View Profile
  • Linux Distribution: xubuntu 12.04
  • Printer: scx-4100
Re: configurator not working
« Reply #6 on: June 17, 2012, 14:09:13 »
I'll check when I'll be back home

thx


augusto

  • Splashing around
  • ***
  • Posts: 6
    • View Profile
  • Linux Distribution: xubuntu 12.04
  • Printer: scx-4100
Re: configurator not working
« Reply #7 on: January 01, 2013, 03:17:08 »
sorry, can't install samsungmfp-scanner-sane-fix-multiarch :

samsungmfp-scanner-sane-fix-multiarch:
 Dipende: samsungmfp-scanner, ma non sta per essere installato
  Dipende: samsungmfp-common v.(=4.00.35-2), ma verrā installata v.4.00.39-1

impossible to proceed


configurator doesn't work

augusto

  • Splashing around
  • ***
  • Posts: 6
    • View Profile
  • Linux Distribution: xubuntu 12.04
  • Printer: scx-4100
Re: configurator not working
« Reply #8 on: January 01, 2013, 06:26:25 »
I have to note that configurator that samsungmfp-configurator-qt3 works properly, while samsungmfp-configurator-qt4 doesn't work;

the only problem is I can't find where scanned file are saved

bchemnet

  • Administrator
  • *****
  • Posts: 547
    • View Profile
  • Linux Distribution: Debian Testing
  • Printer: none
Re: configurator not working
« Reply #9 on: January 01, 2013, 06:56:34 »
samsungmfp-sane-fix-multiarch is part of the main scanner package with 4.00.39, so no longer needs to be installed as a separate package (unless using the older driver files).

There is an unidentified problem with some recent qt4 library that conflicts with the qt4 configurator.  I haven't been able to pin it down, because it only seems to affect a few people and I can't reproduce it.  But many other qt4 programs have had similar issues with recent qt4 libraries, so I'm pretty sure it is a qt4 issue and not the configurator.  For now, just use the qt3 version and you can try the qt4 version later to see if it works.

I'm not sure about the file save location issue.  Maybe you should just use another scanner interface such as simplescan or xsane?

 

Repository Information Legal Contact Alternative Drivers