SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

Author Topic: [SOLVED] Ubuntu 13.04 Segmentation Fault on smfpscan  (Read 5989 times)


  • Testing the water
  • **
  • Posts: 4
    • View Profile
  • Linux Distribution: Ubuntu (13.04 Today)
  • Printer: Samsung SCX-472x Series
[SOLVED] Ubuntu 13.04 Segmentation Fault on smfpscan
« on: May 18, 2013, 14:06:40 »
I have the Samsung Print / Scan device:

  SCX-472x Series

Although it is not listed in the supported devices, scanning worked OK since I have installed the drivers. All features of xSane worked super! (multipage scan, resolution, ... everything). All I did was that I installed the three Packages


on my UBUNTU Machine.
I think when I started to use the device i was working with Ubuntu 12.10 (64 bit) recently I did an Upgrade to 13.04.

The Printer/Scanner is attached to the Network.

For Scanning I use (x)sane. Sometimes I had Problems, that the the Scanner was not found in the Network. Today it was not found again. But I printed a week ago already with 13.04. I cannot say exactly what I tried to get it working at the beginning (you know this, you start trying to do this and that and finally you know there is a problem but don't remember what you did up to now), but I think that I upgraded to the current version of the Samsung drivers.
Unfortunately I cannot say what driver was installed when everything was still working (unreliably, but working).

But I am sure that I have problems with "suld-driver-4.00.39"

First I found out that xsane and scanimage quit with Segmentation fault.
Later I found that smfpscan also quit with Segmentation fault. I am quite shure that smfpscan causes the problems for xsane. If I deinstall the Samsung packages, my I can run "scanimage -L" no problem, but with the Drivers installed BANG!.

I have also tried to reinstall the old Packages, as you sugested in another post, but to no avail, always the same.

Here is the analis:

Package: suld-driver-4.00.39
This is the Package that was installed by the Transitional Packages listed above. About in /opt/Samsung/mfp/bin/Configurator gives:
  common:  4.01.35
  Printer: 4.00.39
  Scanner: 4.00.31

  CheckPrinter: OK
  Print Testpage: OK
  Click Scanner: Crash
  output of /tmp/Configurator.app_naish_log:
    Failed to open configuration file </opt/Samsung/mfp/bin/../share/OEM.ini>
    Configuration file </opt/Samsung/mfp/bin/../share/OEM.ini> was not opened properly
    WARNING: gnome-keyring:: couldn't connect to: /run/user/naish/keyring-r0hQmd/pkcs11: Datei oder Verzeichnis nicht gefunden
    ScannerPlugin - font = 11
    Segmentation fault (core dumped)

  All output before Segmentation fault was before I clicked on the scanner icon.

  /opt/Samsung/mfp/bin/smfpscan: Crash (output of logfile):
    Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
    Segmentation fault (core dumped)

  /opt/Samsung/mfp/bin/netdiscovery: Printer Found
    # DEBUG: Network printers discovery utility
    ip:     slp: 0,0,0,0 snmp: 1,1,0 vendor: Samsung dsc: "SCX-472x Series"

  scanimage -L: crash as described above.

I also tried what was recommended on that Page ("ln -s netdiscovery32 netdiscovery" ...):

Bad Luck.

Then I tried the Package suld-driver-4.01.17:
    verry similar result

for more Detail I have attached the output of:
  strace /opt/Samsung/mfp/bin/smfpscan -N "SCX-472x Series on"

... This is the result of a Saturday Afternoon.

Can You imagine what the reason for this problem is?
I Hope someone can help, thanks in advance.


PD.: is there some place where I can see the parameters used for the commands in /opt/Samsung/mfp/bin/ ?
I found something like:
  netdiscovery --all --scanner
  smfpscan -N smfp:"SAMSUNG CLX-3180 on"

Is there some documentation where I can read about all that parameters?
Is there some -v Option for the Version or something similar?
« Last Edit: May 21, 2013, 08:29:26 by naish »


  • Administrator
  • *****
  • Posts: 569
    • View Profile
  • Linux Distribution: Debian Testing
  • Printer: none
Re: Ubuntu 13.04 Segmentation Fault on smfpscan
« Reply #1 on: May 18, 2013, 17:33:51 »
Quick response (I can look at this in more detail later if this doesn't fix it): try different suld-configurator packages.  That's where smfpscan comes from, so changing the driver version (probably) won't have any effect.

As to your question about where you can find out about options: there isn't any such list I'm aware of, and for the most part your examples cover the important bits.


  • Testing the water
  • **
  • Posts: 4
    • View Profile
  • Linux Distribution: Ubuntu (13.04 Today)
  • Printer: Samsung SCX-472x Series
Re: [SOLVED] Ubuntu 13.04 Segmentation Fault on smfpscan
« Reply #2 on: May 21, 2013, 08:28:58 »
> try different suld-configurator package.
Yes, thats it. First I had

now I have:

Oh my god If I would have called
    dpkg -S  /opt/Samsung/mfp/bin/smfpscan

once I would have known that I was playing around with the wrong packages.

So thank you for this hint. Now you can update your Supported devices table. Under
Ubuntu 13.04 (amd46) my SCX-472x Series connected via Network using Internet Printing Protocol works like a charm Scanning and Printing all done to full satisfaction (now ;-)). Using (X)sane.

This is closed.


Repository Information Legal Contact Alternative Drivers