SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

Author Topic: SULDR  (Read 9179 times)

dennis hk

  • Splashing around
  • ***
  • Posts: 8
    • View Profile
  • Linux Distribution: Mint Cinnamon 14 and Ubuntu 13.04
  • Printer: CLP680nd
SULDR
« on: June 25, 2013, 16:57:37 »
I cannot see anything to download on the repository page. Should I be downloading from the Samsung Installer page ?  A newb.

bchemnet

  • Administrator
  • *****
  • Posts: 524
    • View Profile
  • Linux Distribution: Debian Testing
  • Printer: none
Re: SULDR
« Reply #1 on: June 26, 2013, 10:52:00 »
You have to configure the repository and then use a package management program (anything that can install programs, such as apt-get or synaptic) to download.  See the following links for more details:
http://www.bchemnet.com/suldr/forum/index.php?topic=4.0
http://www.bchemnet.com/suldr/index.html

zcat7777

  • Soaking wet
  • ****
  • Posts: 10
    • View Profile
  • Linux Distribution: Ubuntu Precise
  • Printer: CLX-3185
Re: SULDR
« Reply #2 on: June 26, 2013, 20:18:38 »
I appreciate your work with the Samsung printers!

I am using Synaptic to install the packages from the repository, and most of the time things work correctly. However, the last couple days (I tried again a minute ago), I've been getting this message from Synaptic:

Failed to fetch http://www.bchemnet.com/suldr/dists/debian/extra/i18n/Index  No sections in Release file /var/lib/apt/lists/partial/www.bchemnet.com_suldr_dists_debian_extra_i18n_Index
Some index files failed to download. They have been ignored, or old ones used instead.

bchemnet

  • Administrator
  • *****
  • Posts: 524
    • View Profile
  • Linux Distribution: Debian Testing
  • Printer: none
Re: SULDR
« Reply #3 on: June 27, 2013, 15:51:54 »
The error is not actually a problem, and has to do with my solution to an entirely unrelated problem.  However, I think I have made a change that should eliminate the message; please let me know if you continue to get it.

zcat7777

  • Soaking wet
  • ****
  • Posts: 10
    • View Profile
  • Linux Distribution: Ubuntu Precise
  • Printer: CLX-3185
Re: SULDR
« Reply #4 on: June 27, 2013, 19:17:39 »
I just forced Synaptic to update now, and no errors appeared. Thanks for your answer and the fix!

Once again, I appreciate your work, which lets me use the scanner function & print with Linux!

dennis hk

  • Splashing around
  • ***
  • Posts: 8
    • View Profile
  • Linux Distribution: Mint Cinnamon 14 and Ubuntu 13.04
  • Printer: CLP680nd
Re: SULDR
« Reply #5 on: July 01, 2013, 20:02:42 »
Followed instructions for Ubuntu. Got message in terminal  cannot write to '_'  and other error reports. That's as far as I got. Dennis.

zcat7777

  • Soaking wet
  • ****
  • Posts: 10
    • View Profile
  • Linux Distribution: Ubuntu Precise
  • Printer: CLX-3185
Re: SULDR
« Reply #6 on: July 01, 2013, 20:32:59 »
I'm not the bchemnet, but this might help:  Did you copy & paste the line into the terminal & then hit enter? It looks like you might have used an underscore instead of a dash. When I copied & pasted the line into a terminal I got no errors.

dennis hk

  • Splashing around
  • ***
  • Posts: 8
    • View Profile
  • Linux Distribution: Mint Cinnamon 14 and Ubuntu 13.04
  • Printer: CLP680nd
Re: SULDR
« Reply #7 on: July 01, 2013, 20:35:58 »
No, I typed it in. Will try your suggestion.

dennis hk

  • Splashing around
  • ***
  • Posts: 8
    • View Profile
  • Linux Distribution: Mint Cinnamon 14 and Ubuntu 13.04
  • Printer: CLP680nd
Re: SULDR
« Reply #8 on: July 01, 2013, 20:58:07 »
I cannot copy to the terminal(it keeps closing) Also, Software Update won't open: error opening the cache; (E: Malformed line 58 in source list./etc/apt /sources.list)

zcat7777

  • Soaking wet
  • ****
  • Posts: 10
    • View Profile
  • Linux Distribution: Ubuntu Precise
  • Printer: CLX-3185
Re: SULDR
« Reply #9 on: July 01, 2013, 21:41:25 »
If you run gnome-terminal, you can use the Edit menu at the top of the terminal window, and then Paste to enter the line at the prompt. You need a clean, new terminal window so there is nothing before the line you pasted in. Then hit Enter. You will have to enter your password, since you are using sudo.

The easier way is to open Synaptic, click Settings, Repositories, click the Other Software tab, click the Add... button at the bottom, and copy & paste this line into the dialog box:

deb http://www.bchemnet.com/suldr/ debian extra

Click the Add Source button at the bottom, & Synaptic should take care of the key for you.

If you're new to Linux, it would be good to look over the bash documentation to make it easier to use the terminal, since every little thing matters when you use it. I've made my computer unusable with command errors before, so it's good to be familiar with how they work.

zcat7777

  • Soaking wet
  • ****
  • Posts: 10
    • View Profile
  • Linux Distribution: Ubuntu Precise
  • Printer: CLX-3185
Re: SULDR
« Reply #10 on: July 01, 2013, 22:04:21 »
QUOTE:  Also, Software Update won't open: error opening the cache; (E: Malformed line 58 in source list./etc/apt /sources.list

You should be able to see something unusual if you use a text editor to look at line 58 of the file located at /etc/apt/sources.list

It probably happened when the miscopy occurred with the terminal. It's a minor problem, but you might need to edit the file to fix it. I normally just delete the line when that type of thing occurs, but I would want to make sure it's not combined with another line you need, etc., before deleting it, so you don't mess up your system. Here is an example of just a couple correct lines in my /etc/apt/sources.list:

deb http://us.archive.ubuntu.com/ubuntu/ precise universe
deb http://us.archive.ubuntu.com/ubuntu/ precise-updates universe

If the lines have a different format (e.g. don't start with deb & a space, don't  have a valid web address, etc.) then the apt programs don't understand the file. Unfortunately both Synaptic & Update-manager crashed when I experimented with incorrect lines & I had to fix my test by editing the file.

Typing

sudo gedit /etc/apt/sources.list

at a terminal should let you edit the file, but you could make things worse, so be careful what you delete. Also, make sure you are working with the entire line. All lines except comments (starting with #) should start with deb or deb-src. When I'm not sure if I should delete a line, I often just put a # in front of it (hash mark, on the 3 key on the keyboard), save the file, and run the program again. That way the line is disabled, but it's still there if you need it (in corrected format, of course).

Example of badly malformed line with the hash mark in front of it to disable it so the program runs:

# db hp:us.archive.ubuntu.com/ubuntu/ precise

dennis hk

  • Splashing around
  • ***
  • Posts: 8
    • View Profile
  • Linux Distribution: Mint Cinnamon 14 and Ubuntu 13.04
  • Printer: CLP680nd
Re: SULDR
« Reply #11 on: July 02, 2013, 20:22:18 »
I opened this file via the terminal and put a # in front of line 58 which  read  deb-src http://us archive.ubuntu.com/ubuntu/  raring -backports main restricted universe multiverse. Saved changes & closed terminal.  Still cannot open  Software Update.

How about if I delete the complete file instead and retry?

zcat7777

  • Soaking wet
  • ****
  • Posts: 10
    • View Profile
  • Linux Distribution: Ubuntu Precise
  • Printer: CLX-3185
Re: SULDR
« Reply #12 on: July 02, 2013, 20:40:13 »
I wouldn't delete the file. The problems shouldn't be that hard to fix. The line that you disabled should look like the second one below, if you want to fix it:

deb http://us.archive.ubuntu.com/ubuntu/ raring-backports main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ raring-backports main restricted universe multiverse

Then if you get another error message when opening whichever apt program, it should tell you if there is another line that is malformed. I'll be online for a little while, so if you would like, you could post any other problems you see. The lines should be similar in format to the ones I included here. The deb line is for the programs, & the deb-src is for the source files.

zcat7777

  • Soaking wet
  • ****
  • Posts: 10
    • View Profile
  • Linux Distribution: Ubuntu Precise
  • Printer: CLX-3185
Re: SULDR
« Reply #13 on: July 02, 2013, 20:49:57 »
When you work on this file, I'd suggest making gedit (or whatever editor) wide enough so each line is entirely on one line. Then you can make sure a line isn't split up. Also, in these files everything matters, so spaces between words, etc., can make them not work.

Example:

deb http://us archive.ubuntu.com/ubuntu/ raring -backports main restricted universe multiverse

The space instead of the . between us & archive is a problem in the line above, and the space before the -backports, and if the line ends up on 2 lines when you widen gedit, then it won't work either.

dennis hk

  • Splashing around
  • ***
  • Posts: 8
    • View Profile
  • Linux Distribution: Mint Cinnamon 14 and Ubuntu 13.04
  • Printer: CLP680nd
Re: SULDR
« Reply #14 on: July 02, 2013, 21:30:23 »
I made those two typos myself when sending the 1st message. OK , I widened the text editor screen as instructed and went down 58 lines (counting the blank lines this time also) and line 58 was the third last line. It read ... bchemney.com  instead of bchemnet.com
I fixed this and returned the other line back to original. Still no Software Center. I will try a reboot now.

dennis hk

  • Splashing around
  • ***
  • Posts: 8
    • View Profile
  • Linux Distribution: Mint Cinnamon 14 and Ubuntu 13.04
  • Printer: CLP680nd
Re: SULDR
« Reply #15 on: July 02, 2013, 21:56:26 »
Line 58 now reads " deb http://www.bchemnet.com/suldr/debian extra" In fact lines 57,58,59 and 60 all read this. I still get an error message for line 58. I am using Ubuntu on a USB stick, kind of like a mosquito on my Windows machine, so if I have problems Windows is not affected.

zcat7777

  • Soaking wet
  • ****
  • Posts: 10
    • View Profile
  • Linux Distribution: Ubuntu Precise
  • Printer: CLX-3185
Re: SULDR
« Reply #16 on: July 02, 2013, 22:24:00 »
You only need the line once. It looks like there is no space before the word "debian" in the line in your post. The line should look like the one below, with the space between suldr/ and debian

deb http://www.bchemnet.com/suldr/ debian extra

dennis hk

  • Splashing around
  • ***
  • Posts: 8
    • View Profile
  • Linux Distribution: Mint Cinnamon 14 and Ubuntu 13.04
  • Printer: CLP680nd
Re: SULDR
« Reply #17 on: July 03, 2013, 09:56:49 »
Followed instructions-Successful in opening Software Center. Many thanks for the learning experience!

 

Repository Information Legal Contact Alternative Drivers