SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

How do I upgrade the unified drivers in Ubuntu 13.04?

Started by Whippy, July 08, 2013, 20:12:57

Previous topic - Next topic


I installed my CLP-620ND printer without issue on Ubuntu 13.04 following the prompts and it printed the self test page and prints simple text files from the command line.

When I try to print pdfs or images it fails.

The printer works fine from Ubuntu 10.04 and from Microsoft Windows 7.

Looking at some of the posts here, I thought I'd try the latest version of the driver here.

I have no idea how to uninstall the relevant driver first on Ubuntu 13.04. There is no /opt/Samsung folder and I could not find the top few files mentioned in the uninstallation instructions (deleting individual files is a bit scary in any event).

I tried

~/python/orb/dev $ dpkg -l | grep -i samsung
ii  printer-driver-splix                      2.0.0+svn308-0ubuntu1                  amd64        Driver for Samsung and Xerox SPL2 and SPLc laser printers

Is that what I should uninstall?


Based on what you have posted, you do not have the Unified driver installed at all.  It looks like your printer is configured using the splix driver, which is an open-source driver with good success for some people and not so good for others.

You do not need to uninstall the splix driver if you wish to install the unified driver.


Thank you very much for your prompt response.

I installed suld-driver-4.01.17 without a problem. Then I deleted and re-added the printer. It is behaving the same way as before and I'm assuming its still using the same splix driver. There was no option to select a driver.

How do I ensure that the printer uses the unified driver?


I'm not sure how you are configuring the printer.  If it is an auto-detection routine, it will always pick up the splix driver.  To ensure that you have an option to select the Samsung driver, you can install the suld-configurator-2-qt4 package and use that to set up the printer.


I've installed suld-configurator-2-qt4 as suggested, deleted the existing printer configuration and re-added it using the recommended foomatic driver at the top of the list.

When I ran the tests it said 'OK' for the driver and for the test page but the printer did not print anything. I noticed it was not 'started' so I started it. Still nothing.

On inspection of the printer properties under 'ink/toner levels' I see the following status messages:
Printer 'clp620': 'cups-ipp-conformance-failure-report'.
Printer 'clp620': 'cups-ipp-missing-send-document'
Printer 'clp620': 'paused'

No idea how to unpause it or get past these.

Google found which appears to describe the problem and suggests that everything should work if I use LPD rather than IPP.

So I delete the printer and try re-adding with the default 'add printer' option. This allows me to select 'LPD network printer via DNS-SD' for the CLP-620 so I try that: It prints a test page but still fails to print anything other than basic text files otherwise.

Deleted the printer again and tried with the configurator. This seems only willing to treat the 620 as an IPP printer but there is another non recommended driver for it listed as just 'Samsung CLP-620 Series' so I try that... It behaves exactly the same as the recommended foomatic driver.

Reading further down the bug report cited above, it states that Cups_1.5.2-9 fixes the issue. However, looking at my 13.04 version of cups, the installed version is 1.6.2-1ubuntu5 so one would assume that this should work on that basis.

Yet further down in the bug report it suggests using AppSocket/JetDirect protocol so I delete and re-add using the standard printer add utility and try that: Test page prints fine. Printer still wont print images or pdfs :( - although for a bit of variety, it now claims a 'media-jam' in the status panel rather than the above errors. There is no media jam and the printer itself reports 'ready'.

There is talk even further down in the bug report about ipp14 using the cups 1.4 ipp which apparently works. Unfortunately I could not see how I could try to make use of that in 13.04.

Reading between the lines I am guessing that the printer is not doing IPP as it should. This was worked around in CUPs version 1.4 but is no longer worked around in 1.6 (although there may have been a fix in 1.5) so I have a feeling this is not a problem with the driver itself - more an issue with CUPS (since we can't change the hardware) but I've no idea how to get this Samsung printer working and I'm fairly sure that all 12.04 upwards Ubuntu users will have the same issue if they use the same printer.


The "Samsung Series" driver is the one associated with the Unified Driver.

You may able to try the ipp14 solution as described here:

You may want to try it first with with the foomatic or splix drivers, as if it works with one of those then you can remove the unified driver.


I suspect that ipp14 will work for me but:
~ $ ls /usr/lib/cups/backend-available/
dnssd  lpd  snmp  socket  usb

However it is in /usr/lib/cups/backend already.

I linked it to the available folder and then manually configured the printer to use ipp14:/....

It still failed with the foomatic driver but now works fine with the unified driver.

Printing again - thanks! I hope ubuntu fix CUPS up (seems like the problem is there rather than with your driver) or they are going to be losing users.

Repository Information Legal Contact Alternative Drivers