SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

Author Topic: Scan on CLX-3160  (Read 4362 times)

George82

  • Splashing around
  • ***
  • Posts: 8
    • View Profile
  • Linux Distribution: Ubuntu
  • Printer: CLX-3170, CLX-3160, SCX-4600, ML-2250
Scan on CLX-3160
« on: January 15, 2014, 07:15:41 »
Hi everybody

I'm also having strange behaviour on my CLX-3160.
Simple-scan find the scanner on the network, but when i try to scan i'm getting: "failed to scan - Unable to connect to scanner"

Smftpnetdiscovery shows:
/usr/lib/cups/backend/smfpnetdiscovery
network ipp://192.168.178.101 "Samsung CLX-3160 Series" "Samsung CLX-3160 Series on 192.168.178.101" MFG:Samsung;CMD:GDI,FAX;MDL:CLX-3160 Series;CLS:PRINTER;MODE:FAX; ""

I try this with normal user and root
I also tried old drivers, but with these drivers my scanner is not found.
Any ideas?

Printer is working normally




Log of simple-scan

[+0,00s] DEBUG: simple-scan.vala:579: Starting Simple Scan 3.10.2, PID=15289
[+0,00s] DEBUG: Connecting to session manager
[+0,04s] WARNING: g_object_set_valist: invalid object type 'GtkAdjustment' for v
alue type 'GtkWidget'
[+0,04s] DEBUG: ui.vala:1524: Restoring window to 600x400 pixels
[+0,04s] DEBUG: autosave-manager.vala:64: Loading autosave information
[+0,04s] DEBUG: autosave-manager.vala:258: Waiting to autosave...
[+0,04s] WARNING: autosave-manager.vala:76: Could not load autosave infomation;
not restoring any autosaves
[+0,08s] DEBUG: scanner.vala:1443: sane_init () -> SANE_STATUS_GOOD
[+0,08s] DEBUG: scanner.vala:1449: SANE version 1.0.23
[+0,08s] DEBUG: scanner.vala:1510: Requesting redetection of scan devices
[+0,08s] DEBUG: scanner.vala:802: Processing request
[+0,15s] DEBUG: autosave-manager.vala:280: Autosaving book information
[+4,10s] DEBUG: scanner.vala:338: sane_get_devices () -> SANE_STATUS_GOOD
[+4,10s] DEBUG: scanner.vala:350: Device: name="smfp:net;192.168.178.101" vendor
="SAMSUNG" model="CLX-3160 Series on 192.168.178.101" type="Scanner"
[+5,83s] DEBUG: simple-scan.vala:307: Requesting scan at 150 dpi from device 'sm
fp:net;192.168.178.101'
[+5,83s] DEBUG: scanner.vala:1556: Scanner.scan ("smfp:net;192.168.178.101", dpi
=150, scan_mode=ScanMode.GRAY, depth=2, type=ScanType.SINGLE, paper_width=2100,
paper_height=2970, brightness=0, contrast=0)
[+5,83s] DEBUG: scanner.vala:802: Processing request
[+5,83s] DEBUG: scanner.vala:863: sane_open ("smfp:net;192.168.178.101") -> SANE
_STATUS_DEVICE_BUSY
[+5,83s] WARNING: scanner.vala:867: Unable to get open device: Device busy
[+24,40s] DEBUG: autosave-manager.vala:194: Deleting autosave records
[+24,40s] DEBUG: scanner.vala:1583: Stopping scan thread
[+24,40s] DEBUG: scanner.vala:802: Processing request
[+24,40s] DEBUG: scanner.vala:1594: sane_exit ()


« Last Edit: January 15, 2014, 07:52:47 by George82 »

bchemnet

  • Administrator
  • *****
  • Posts: 524
    • View Profile
  • Linux Distribution: Debian Testing
  • Printer: none
Re: Scan on CLX-3160
« Reply #1 on: January 16, 2014, 19:58:57 »
I try this with normal user and root
I also tried old drivers, but with these drivers my scanner is not found.
Any ideas?

It appears that some network signals for the scanner are going through but not others.  Are you running a firewall that could be interfering with something?  Alternatively, is there anything unusual about your network configuration?

George82

  • Splashing around
  • ***
  • Posts: 8
    • View Profile
  • Linux Distribution: Ubuntu
  • Printer: CLX-3170, CLX-3160, SCX-4600, ML-2250
Re: Scan on CLX-3160
« Reply #2 on: January 17, 2014, 03:41:13 »
Hi,

No i'm not running any firewall, except apparmor. I also tried to disable it without any changes.
I'll try to change the router and i will come back after that.
No there isn't any thing special about the network configuration.

George82

  • Splashing around
  • ***
  • Posts: 8
    • View Profile
  • Linux Distribution: Ubuntu
  • Printer: CLX-3170, CLX-3160, SCX-4600, ML-2250
Re: Scan on CLX-3160
« Reply #3 on: January 17, 2014, 05:23:52 »
Tried with another router. Same result. Simple Scan finds the scanner, but i'm unable to scan.

bchemnet

  • Administrator
  • *****
  • Posts: 524
    • View Profile
  • Linux Distribution: Debian Testing
  • Printer: none
Re: Scan on CLX-3160
« Reply #4 on: January 19, 2014, 08:32:09 »
Are you running Ubuntu 13.10 (Saucy)?  It appears that several other people are having similar problems, and the only common feature I can see so far is the Ubuntu version.

George82

  • Splashing around
  • ***
  • Posts: 8
    • View Profile
  • Linux Distribution: Ubuntu
  • Printer: CLX-3170, CLX-3160, SCX-4600, ML-2250
Re: Scan on CLX-3160
« Reply #5 on: January 19, 2014, 09:43:26 »
Yes i'm running 13.10 and also 14.04

bchemnet

  • Administrator
  • *****
  • Posts: 524
    • View Profile
  • Linux Distribution: Debian Testing
  • Printer: none
Re: Scan on CLX-3160
« Reply #6 on: January 26, 2014, 09:33:35 »
I don't know what is causing this problem.  My best guess is something in the current version of libsane (sane-backends) that is shipping with 13.10 and 14.04.  There are two other similar threads going in these forums right now about this, but I can't see much in common except a version of libsane that has a couple of extra patches not applied in previous releases or in the Debian series of packages.  My best suggestion now is to file a bug report with Ubuntu against the package, although honestly I wouldn't expect much of a response.

Sorry I can't be more help.

 

Repository Information Legal Contact Alternative Drivers