Sticky
SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

Author Topic: Another apt-get update problem  (Read 3709 times)

k8dbg

  • Testing the water
  • **
  • Posts: 3
    • View Profile
  • Linux Distribution: ubuntu 12.04 lts
  • Printer: SCX-4521F
Another apt-get update problem
« on: June 13, 2014, 19:48:16 »
Greetings. I've read the faq's and threads on this topic. If I missed the answer I apologize.

I'm trying to enable scanning with an SCX-4521F. I edited /etc/apt/sources.list and appended the line:

deb http://www.bchemnet.com/suldr/ debian extras

When I try apt-get update I get the following error:

W: Failed to fetch http://www.bchemnet.com/suldr/dists/debian/Release  Unable to find expected entry 'extras/binary-i386/Packages' in Release file (Wrong sources.list entry or malformed file)

I don't know enough about the update/repository process to get further. I appreciate any help.

Jeff

bchemnet

  • Administrator
  • *****
  • Posts: 526
    • View Profile
  • Linux Distribution: Debian Testing
  • Printer: none
Re: Another apt-get update problem
« Reply #1 on: June 13, 2014, 20:17:09 »
It looks like a typo.  You have "extras" where it should be "extra" (no "s").

k8dbg

  • Testing the water
  • **
  • Posts: 3
    • View Profile
  • Linux Distribution: ubuntu 12.04 lts
  • Printer: SCX-4521F
Re: Another apt-get update problem
« Reply #2 on: June 13, 2014, 20:31:52 »
Thanks for the quick answer. I cut & pasted that string from somewhere -- unfortunately not your web page, but one of the copy cats I found through DuckDuckGo.

Works as advertised. I appreciate the help.

Thanks,
Jeff

Deteklover

  • Testing the water
  • **
  • Posts: 2
    • View Profile
  • Linux Distribution: Debian
  • Printer: CLX-2160 & CLX-3170
Re: Another apt-get update problem
« Reply #3 on: December 12, 2014, 04:12:11 »
Hi,

I have same issue, impossible to connect to the repository.
The deb line was copy/paste from faq.

Here is the apt error :
W: Impossible de récupérer http://www.bchemnet.com/suldr/dists/debian/Release  Impossible de trouver l'entrée « extra/binary-armhf/Packages » attendue dans le fichier « Release » :  ligne non valable dans sources.list ou fichier corrompu

E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.

Any idear ?

bchemnet

  • Administrator
  • *****
  • Posts: 526
    • View Profile
  • Linux Distribution: Debian Testing
  • Printer: none
Re: Another apt-get update problem
« Reply #4 on: December 12, 2014, 21:55:15 »
Here is the apt error :
W: Impossible de récupérer http://www.bchemnet.com/suldr/dists/debian/Release  Impossible de trouver l'entrée « extra/binary-armhf/Packages » attendue dans le fichier « Release » :  ligne non valable dans sources.list ou fichier corrompu

ARM-HF architecture is not provided by Samsung.  So although there is an "arm" driver, it does not actually work with most modern arm systems.  Only "armel" works.

Deteklover

  • Testing the water
  • **
  • Posts: 2
    • View Profile
  • Linux Distribution: Debian
  • Printer: CLX-2160 & CLX-3170
Re: Another apt-get update problem
« Reply #5 on: December 14, 2014, 04:46:33 »
Thanks for your answer !

I use an Raspberry Pi B+, do you know if there is a drivers available for it ?
Thanks a lot

bchemnet

  • Administrator
  • *****
  • Posts: 526
    • View Profile
  • Linux Distribution: Debian Testing
  • Printer: none
Re: Another apt-get update problem
« Reply #6 on: December 14, 2014, 07:43:38 »
Not unless you change the distribution.  On most devices it is possible to run an armel distribution by wiping what is currently installed and starting over.  But I haven't tried with any Raspberry Pi.

 

Repository Information Legal Contact Alternative Drivers