SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

Author Topic: Printer spools but does not print  (Read 3429 times)

carlnielsen

  • Splashing around
  • ***
  • Posts: 7
    • View Profile
  • Linux Distribution: OMV 2.1
  • Printer: SCX-4623F
Printer spools but does not print
« on: August 05, 2015, 09:44:33 »
Open Media Vault 2.1 (based on Debian Wheezy) 64-bit
Samsung SCX-4623F
suld-driver-4.00.36

Scanner works from local and remote computers. No problems.

Printing via Network from Windows works fine. According to the OMV plugin for printing, SMB is switched off so Windows PC's are supposed to be connecting via IPP but I am not sure this is the case as all print jobs from windows show a prefix of smb.

Printing from the local host (eg test page from OMV printing screen or from CUPS admin panel) causes the printer to start whirring as if it will print. But no page spools. CUPS does not report any error.

Printing from a remote linux machine (Linux Mint XFCE 14.1) also generally causes the whir without the print, although recently a job (a print from Thunderbird) did work.

Any help would be greatly appreciated.

bchemnet

  • Administrator
  • *****
  • Posts: 524
    • View Profile
  • Linux Distribution: Debian Testing
  • Printer: none
Re: Printer spools but does not print
« Reply #1 on: August 05, 2015, 10:13:40 »
I'm assuming from your description that you have the printer set up using IPP.  If so, trying LPD instead might help.  Otherwise my best guess is to try a different driver version.

carlnielsen

  • Splashing around
  • ***
  • Posts: 7
    • View Profile
  • Linux Distribution: OMV 2.1
  • Printer: SCX-4623F
Re: Printer spools but does not print
« Reply #2 on: August 05, 2015, 10:18:22 »
Actually, I kind of assume it is set up with IPP but I could be wrong. Here is what CUPS says:

Connection:   usb://Samsung/SCX-4623%20Series?serial=Z2W3BAAZ201223F&interface=1

bchemnet

  • Administrator
  • *****
  • Posts: 524
    • View Profile
  • Linux Distribution: Debian Testing
  • Printer: none
Re: Printer spools but does not print
« Reply #3 on: August 05, 2015, 10:26:02 »
I don't know for certain either - it appears that OMV is treating it as a local device, and somehow handling the network aspect separately.  I've never used OMV so don't know what it is doing internally to share devices.  You might have a better time sorting it out by seeing how a remote computer views the printer.

carlnielsen

  • Splashing around
  • ***
  • Posts: 7
    • View Profile
  • Linux Distribution: OMV 2.1
  • Printer: SCX-4623F
Re: Printer spools but does not print
« Reply #4 on: August 05, 2015, 10:42:31 »
Okay. definite progress. I checked on the Linux Mint machine at it listed the Device URI as ipp://192.168.1.25:631/printers/Samsung

I changed that and selected the auto-detected printer and it changed that setting to dnssd://Samsung%20%40%20CatNAS._ipp._tcp.local/cups

And a test page printed.

Seeing as I don't ever need to print from the server, this now means that I have had some success with both machines that need it. So I think I am happy.

Thanks for the help

alexacarlton

  • Testing the water
  • **
  • Posts: 2
    • View Profile
    • http://www.digitekprinting.com/letterhead
  • Linux Distribution: Android
  • Printer: M2875DW
Re: Printer spools but does not print
« Reply #5 on: October 16, 2015, 22:54:42 »
Have they made comparison how this one works on 32bit instead?

 

Repository Information Legal Contact Alternative Drivers