Sticky
SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

Author Topic: CLP-315 all kind of installs fail in x64 bit system - it works fine in x32  (Read 3260 times)

legrega

  • Splashing around
  • ***
  • Posts: 6
    • View Profile
  • Linux Distribution: Kubuntu 15.10 x64
  • Printer: Samsung CLP-315
I've tried installation CD, download installer and smart panel from samsung drivers and finally here thoriugh debian apt-get for my Kubuntu S5000 SPL Intel XEON server.
Most reportive is CD so I will run it again and ctrl c the output ... The printer is turned on and connected. The printer does not respond. Same computer KUbuntu x32 14.04 worked perfectly. Please help me:


grega@lilaum:/media/grega/SAMSUNG_CLP/Linux$ sudo ./install.sh
[sudo] password for grega:
****  It seems Qt library is not installed, or X display is not accessible.
****  Custom Qt library will be configured for use with this package.
GUI mode installer execution failed, proceeding in text mode
****  Running text mode install
****  Press Enter to continue or q and then Enter to quit:

****  Print drivers for the following device models available:
CLP-300splc CLP-310splc CLP-350ps CLP-500splc CLP-510splc CLP-550ps CLP-600splc CLP-610splc CLP-650ps CLP-660ps CLP-770ps CLX-216xsplc CLX-3160splc CLX-3170splc CLX-6200ps CLX-6240ps CLX-8380ps CLX-9xx0ps mfp560 mfp750 ML-1450ps ML-1510spl2 ML-1520spl2 ML-1610spl2 ML-1630spl2 ML-1630wspl2 ML-1640spl2 ML-1710spl2 ML-1740spl2 ML-1750spl2 ML-1910spl2 ML-2010spl2 ML-2150ps ML-2150spl2 ML-2240spl2 ML-2245spl2 ML-2250spl2 ML-2510spl2 ML-2550ps ML-2550Sps ML-2550Sspl2 ML-2560ps ML-2570ps ML-2580spl2 ML-2850ps ML-2855ps ML-3050spl2 ML-3470ps ML-3560spl2 ML-4050DMVps ML-4050ps ML-4550ps ML-6060ps ML-7300ps ML-8x00ps scx4100 scx4200 scx4300 scx4400 scx4500 scx4500w scx4623 scx4725 scx4x16 scx4x20 scx4x21 scx4x24 scx4x26 scx4x28ps scx5312f scx5635ps scx5835ps scx5x30 scx6545ps scx6x20PCL scx6x20 scx6x20PS scx6x22ps scx6x45ps scx6x55ps sf531p
****  Please enter model to install and press Enter: CLP-310splc         
I/O warning : failed to load external entity "noarch/at_root/etc/sane.d/smfp.conf"
ERROR: xmlParseFile failed
INFO: Installing MFP port and SANE backend libraries ...
./install.sh: 1021: cd: can't cd to /usr/lib64/sane
ln: ni mogoče ustvariti simbolne povezave »libsane-smfp.so.1«: Datotečni sistem je zgolj za branje
ln: ni mogoče ustvariti simbolne povezave »libsane-smfp.so«: Datotečni sistem je zgolj za branje
INFO: Installing GUI lpr ...
INFO: Fixing file ownership and permissions ...
INFO: Registering SANE backend ...
INFO: Registering CUPS printer ...
[ ok ] Restarting cups (via systemctl): cups.service.
INFO: CUPS restart OK
INFO: Creating menu entries ...
mkdir: imenika »/proc/Desktop« ni mogoče ustvariti: Datoteka ali imenik s tem imenom ne obstaja
chmod: dostop do »/proc/Desktop« ni mogoč: Datoteka ali imenik s tem imenom ne obstaja
chown: dostop do »/proc/Desktop« ni mogoč: Datoteka ali imenik s tem imenom ne obstaja
mkdir: imenika »/proc/.gnome-desktop« ni mogoče ustvariti: Datoteka ali imenik s tem imenom ne obstaja
chmod: dostop do »/proc/.gnome-desktop« ni mogoč: Datoteka ali imenik s tem imenom ne obstaja
chown: dostop do »/proc/.gnome-desktop« ni mogoč: Datoteka ali imenik s tem imenom ne obstaja
INF0: psu (ver.2.00.12) has been installed successfully in /opt/Samsung/PSU/
INF0: phonebook (ver.2.00.12) has been installed successfully in /opt/Samsung/PhoneBook/
INF0: emailbook (ver.2.00.12) has been installed successfully in /opt/Samsung/EmailBook/
INF0: Shutting down smartpanel:
awk: cmd. line:2: { if ($3 == 0 || ($3 >= 1000
awk: cmd. line:2:                             ^ unexpected newline or end of string
INF0: smartpanel (ver.2.00.34) has been installed successfully in /opt/Samsung/SmartPanel
INFO: Starting smartpanel ...
INFO: Finishing installation ...
/opt/Samsung/SmartPanel/bin/smartpanel: error while loading shared libraries: libstdc++.so.5: wrong ELF class: ELFCLASS32
****  Text mode install finished
grega@lilaum:/media/grega/SAMSUNG_CLP/Linux$



As I understand there is a conflict I do not have some x32 libraries installed and already gooogled and installed some extra with no success. :-( Gregor Leskovšek from Slovenia





bchemnet

  • Administrator
  • *****
  • Posts: 524
    • View Profile
  • Linux Distribution: Debian Testing
  • Printer: none
Is it just the smartpanel that fails?  My first guess is that the 64-bit version is incorrectly compiled, which you won't be able to fix.  That type of error has happened before with the files Samsung distributes, and I have no experience working with the smartpanel.

legrega

  • Splashing around
  • ***
  • Posts: 6
    • View Profile
  • Linux Distribution: Kubuntu 15.10 x64
  • Printer: Samsung CLP-315
No, I can not print anything and fails both driver installer and smartpanel. Is there anything I can do? Thanks, Gregir

bchemnet

  • Administrator
  • *****
  • Posts: 524
    • View Profile
  • Linux Distribution: Debian Testing
  • Printer: none
You might be best off installing the x32 version in the x64 system if that seems to be working.  Using the repository, you can do this by entering the following in a terminal:
sudo dpkg --add-architecture i386
apt-get -a=i386 install suld-driver-4.01.17

Replace "suld-driver-4.01.17" with whatever version of the driver you actually want if you prefer a different one.  It is likely, but not definite, that installing the x32 version of the smartpanel from Samsung will also result in a working program after this.

legrega

  • Splashing around
  • ***
  • Posts: 6
    • View Profile
  • Linux Distribution: Kubuntu 15.10 x64
  • Printer: Samsung CLP-315
I don't know why it doesn't recognize the -a=i386 or --host-architecture=i386??
I tried also download instead of install, but the result was the same.

grega@lilaum:~/system$ sudo apt-get download -a=i386  suld-driver-4.01.17
E: Možnost ukazne vrstice 'a' [iz -a=i386] ni poznana.
grega@lilaum:~/system$ sudo apt-get --host-architecture=i386 install suld-driver-4.01.17
E: Možnosti ukazne vrstice --host-architecture=i386 ni mogoče razumeti

Please help me more. Thanks, Gregor

bchemnet

  • Administrator
  • *****
  • Posts: 524
    • View Profile
  • Linux Distribution: Debian Testing
  • Printer: none
Ubuntu seems to have removed that option from apt-get.  I have no idea why.

Try sudo apt-get install suld-driver-4.01.17:i386

If that also doesn't work, then perhaps Ubuntu has added some alternate way to force 32-bit installations.  But you would have to look at Ubuntu resources for that, I have not kept up with their changes to the underlying Debian system.

legrega

  • Splashing around
  • ***
  • Posts: 6
    • View Profile
  • Linux Distribution: Kubuntu 15.10 x64
  • Printer: Samsung CLP-315
Are those drivers - suld-driver-4.01.17 - x64 bit? Perhaps I need x64 bit drivers and not x32 bit? AFAIU there is a confict between the x64bit system and x32bit drivers? Do You agree?
Because the install cd from samsung worked in 32bit environment and in x64bit nothing works ;-(

It didn't work:
grega@lilaum:~/system$ sudo apt-get install suld-driver-4.01.17:i386
Branje seznama paketov ... Narejeno
Gradnja drevesa odvisnosti         
Branje podatkov o stanju ... Narejeno
Nekaterih paketov ni mogoče namestiti. To lahko pomeni, da ste zahtevali
nemogoč položaj, če uporabljate nestabilno izdajo pa
, da nekateri zahtevani paketi še niso ustvarjeni ali premaknjeni
 iz Prihajajočega.
Naslednji podatki vam bodo morda pomagali rešiti težavo:

Naslednji paketi imajo nerešene odvisnosti:
 suld-driver-4.01.17:i386 : Odvisen od: suld-driver-common-1:i386 vendar se ga ne da namestiti
                            Odvisen od: suld-ppd-2:i386 vendar se ga ne da namestiti
E: Ni mogoče popraviti težav. Imate pokvarjene pakete.
grega@lilaum:~/system$
... Can not install dependencies in short ...

bchemnet

  • Administrator
  • *****
  • Posts: 524
    • View Profile
  • Linux Distribution: Debian Testing
  • Printer: none
The drivers are both 32 and 64 bit.  The packages that it reports as failing don't exist, though - the "common" and "ppd" packages do not have architecture-specific binary files, and so it should be trying to pull those as architecture "all".

I think there is a problem with the way your system is handling multiarch.  However, Ubuntu doesn't seem to configure it the same way as the base Debian system, so I can't offer you an immediate suggestion.  I am sure that it has to do the way dpkg and apt are configured, and if you look for resources about installing multiarch packages under 64 bit for Ubuntu you can probably find a solution.  The errors you are getting are not specific to these packages.

 

Repository Information Legal Contact Alternative Drivers