SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

Samsung Xpress M2026 on Lubuntu 14.04

Started by Gizork, May 04, 2016, 05:37:59

Previous topic - Next topic



I need help with a problem, I Cannot get the printer to print. (Printer is shown as M2020 in the printer menu).

I've tried this with suld-driver2-1.00.06, suld-driver2-1.00.36 (With this it will send the data to the machine,you can hear a little "click" on it also. Tho the printer on lubuntu will just stay at "Processing page 1...".

I've also tried the suld-driver-4.01.17.

Printer has been tested on Windows and it was working.

Anyone got any ideas what to test next ? Any help is welcome.


Which driver are you choosing?  I'm assuming that this printer is part of the M2020 series, which 4.01.17 doesn't support.


Yeah that's what i'm assuming also that it should work with the same drivers as M2020 and M2022 ?. Just can't get it further than the "Processin page1...".
I got also the printer to print "SPL-ERROR - Incomplete Session by time out" System : h6fwsim/os_hook and
"SPL ERROR - Please use the proper driver" System : h6fwsim/xl_image.


It appears that the 2026 is identical to the 2020, and the same as the 2022 except with a slower processor and less RAM.  So I continue to assume the 2020 driver is correct.

That leads me to think that one of the following is true:
1. The printer RAM is too low.  I've seen this with other Samsung models from Linux, where a small amount of printer RAM made it impossible to print anything other than very simple documents.
2. Despite all appearances, the printer isn't really the same as the 2020, and there isn't a driver for it in Linux.
3. Something is wrong with your printer.  The way to test this would be try to print from a Windows or Mac machine using those drivers.  A virtual machine would probably work if you have one handy.
4. There is some minor issue in the way the driver is packaged, and you should install the driver using the direct Samsung installer instead of the packages.

If you can't do #3 and/or it doesn't help, and #4 doesn't help, then you probably will have to contact Samsung or consider an alternate printer.


Okay so I got A M2022 tested also on the same computer and even that didn't work... Got the same result "you can hear the click" but nothing else, after a long while "timeout". Is there anyway to see if i got multiple Samsung drivers installed ? Before I installed the suld drivers.


If you are configuring the printer manually and selecting the M2020 series driver, you only have 1 driver installed if you only see one option for that printer.

You can be even more certain by uninstalling all SULDR components and then trying to set up the printer again, and seeing if it finds an appropriate driver.


Got to test the M2020 printer with a fresh install of Lubuntu and it worked with generic PLC laser and with the samsung drivers installed directly .... What is going on here. Tho Ubuntu was also updated so maybe the reason might be in that, need to check the patch notes and try with the other computer.


It's possible there was an issue with CUPS (my best guess), if the issue is resolved because of the update.

If not and it relates to installing using the Samsung installer instead of the packages, let me know and I will investigate to see if something critical is getting lost during package generation.

Repository Information Legal Contact Alternative Drivers