SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

Author Topic: apt-get update issue  (Read 2748 times)

djfil007

  • Splashing around
  • ***
  • Posts: 5
    • View Profile
  • Linux Distribution: Raspberian
  • Printer: ML-1915
apt-get update issue
« on: January 13, 2016, 01:45:25 »
Really appreciate finding this repository to try and help install my Samsung ML-1915.

Raspbian Jessie Lite on Raspberry Pi 2B.

Followed instructions as per repository setup guide on first page.  Following error/log when I try to do 'sudo apt-get update'...

-----

Hit http://www.bchemnet.com debian InRelease
Hit http://archive.raspberrypi.org jessie InRelease
Hit http://mirrordirector.raspbian.org jessie InRelease
Hit http://archive.raspberrypi.org jessie/main armhf Packages
Hit http://archive.raspberrypi.org jessie/ui armhf Packages
Hit http://mirrordirector.raspbian.org jessie/main armhf Packages
Hit http://mirrordirector.raspbian.org jessie/contrib armhf Packages
Hit http://mirrordirector.raspbian.org jessie/non-free armhf Packages
Hit http://mirrordirector.raspbian.org jessie/rpi armhf Packages
Ign http://archive.raspberrypi.org jessie/main Translation-en_GB
Ign http://archive.raspberrypi.org jessie/main Translation-en
Ign http://archive.raspberrypi.org jessie/ui Translation-en_GB
Ign http://archive.raspberrypi.org jessie/ui Translation-en
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en
Ign http://mirrordirector.raspbian.org jessie/main Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/main Translation-en
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en
W: Failed to fetch http://www.bchemnet.com/suldr/dists/debian/InRelease  Unable to find expected entry 'extra/binary-armhf/Packages' in Release file (Wrong sources.list entry or malformed file)

E: Some index files failed to download. They have been ignored, or old ones used instead.

-----

Help please.  Not sure why it's failing.

Also am I barking up the wrong tree?  I've read mixed messages regarding the ML-1915 drivers and Raspbian.  Is armel supported or not?  Should I switch to fedora or another distro?

Thank you!

bchemnet

  • Administrator
  • *****
  • Posts: 524
    • View Profile
  • Linux Distribution: Debian Testing
  • Printer: none
Re: apt-get update issue
« Reply #1 on: January 13, 2016, 05:55:36 »
The answer is that yes, it is supported, but only if you configure the system correctly from the very beginning.

The issue has to do with "soft float" (armel) vs. "hard float" (armhf).  The difference is whether floating-point calculations are done by the processor (hard float) or software (soft float).  The original ARM processors, including the one that the first Raspberry Pi was built on, did not have a hardware floating point processor, and so were all "armel".  This is what Samsung released a driver for.  All current Raspberry Pi devices (I believe) can in fact run as armhf, and that is the version that is provided if you download an installation image from the Raspberry Pi foundation.  You cannot use the Samsung driver this version, and based on the "armhf" in your output, that is the version you are using.

It should (I think, not tested by me) be possible to download and install an older armel Raspbian installation from Raspbian.org, and that will work with the printer driver - at least for the versions that Samsung released an ARM-compiled version.  The downside to using armel when armhf works is that some processes will be slower and more energy-intensive, because software calculations are not as efficient as hardware ones.

So if you want to use the Samsung driver, you would need to download and install a fresh image of Raspbian that is armel instead of armhf.  There may also be a loss of access to some packages in other respositories as a consequence, I don't know how many other things are currently offered as both armel and armhf.

djfil007

  • Splashing around
  • ***
  • Posts: 5
    • View Profile
  • Linux Distribution: Raspberian
  • Printer: ML-1915
Re: apt-get update issue
« Reply #2 on: January 13, 2016, 10:40:43 »
Thank you very much for your detailed response.

Trying to search for an armel version of Raspbian has been tough so far, appears Raspberry Pi themselves (or via raspbian.org) no longer host armel versions of their distro.

Hopefully I'll be able to find one (that works on Raspberry Pi 2 hardware), as this is the primary use for my RPi.

Will follow up later if any further issues.  Thank you again.

djfil007

  • Splashing around
  • ***
  • Posts: 5
    • View Profile
  • Linux Distribution: Raspberian
  • Printer: ML-1915
Re: apt-get update issue
« Reply #3 on: January 13, 2016, 12:53:41 »
Bah.  Appears it's not possible for the Raspberry Pi 2 hardware.  Guess I'll need to see if I can find another method to get my printer working (foomatic maybe).

Saulius2006

  • Splashing around
  • ***
  • Posts: 6
    • View Profile
  • Linux Distribution: Linux raspberrypi 4.4.11-v7+ 2016 armv7l GNU/Linux
  • Printer: Samsung C410W
Re: apt-get update issue
« Reply #4 on: August 31, 2016, 04:28:23 »
Hi,

Did you get your printer working with Raspberry Pi 2 armhf.
Could you be so kind to provide alternative solution.

I run Raspberrypi 4.4.13-v7 armv7l  GNU/Linux - the error that I receive is armhf.

djfil007

  • Splashing around
  • ***
  • Posts: 5
    • View Profile
  • Linux Distribution: Raspberian
  • Printer: ML-1915
Re: apt-get update issue
« Reply #5 on: August 31, 2016, 08:10:03 »
I did.

http://splix.ap2c.org/

appears to be already in the latest raspbian repositories.  sudo apt-get splix

Saulius2006

  • Splashing around
  • ***
  • Posts: 6
    • View Profile
  • Linux Distribution: Linux raspberrypi 4.4.11-v7+ 2016 armv7l GNU/Linux
  • Printer: Samsung C410W
Re: apt-get update issue
« Reply #6 on: August 31, 2016, 10:06:24 »
Would you be so kind to provide me with a full instruction
I'm beginner and not sure the way its installed and used.

Is it replacement of Cups or is just a Samsung drivers (replacing the original Samsung drivers)

djfil007

  • Splashing around
  • ***
  • Posts: 5
    • View Profile
  • Linux Distribution: Raspberian
  • Printer: ML-1915
Re: apt-get update issue
« Reply #7 on: August 31, 2016, 11:20:31 »
This is only drivers.  Use with CUPS.  Once installed, you should see a large section of Samsung drivers/printers to choose from when configuring CUPS.

Saulius2006

  • Splashing around
  • ***
  • Posts: 6
    • View Profile
  • Linux Distribution: Linux raspberrypi 4.4.11-v7+ 2016 armv7l GNU/Linux
  • Printer: Samsung C410W
Re: apt-get update issue
« Reply #8 on: September 01, 2016, 07:07:30 »
I tried to install the Splix but unfortunately my Samsung model is not included in prints list.
Tried different model but can't get working.

 

Repository Information Legal Contact Alternative Drivers