SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

[SOLVED] M2078W scans, prints a test page, but doesn't print anything else...

Started by tulak, January 17, 2017, 03:26:23

Previous topic - Next topic


Hi all,
I'm not very new in Linux but so far friends could help me; this time nobody has a clue how to solve this problem:
I've a printer/scanner Samsung M2078W, it used to work with my Linux Mint. It stopped working after an update last fall, and this week I put a new Linux Mint on my laptop.
I've installed the Samsung Unified Linux Driver, presently 1.00.37, but any version of it leads to the same result (I tried 1.00.06; 1.00.35; 1.00.36)

    - Scanner works properly (Simple Scan 3.20.0)
    - system-config-printer 1.5.7 (CUPS) recognizes my printer. The Trouble-shooting tool of system-config-printer prints the Test Page. But when I want to print directly a Test Page from the properties of the printer in system-config-printer, I cannot click the button.
    - And when I want to print with any other software, it does not work:

    - Openoffice (Libreoffice) says (translated from French): "Impossible to start the printer! Check its settings" and I have a Linux Mint notification at the same time saying "Printing has been canceled"
    - All the other softwares don't say anything and don't print either.
    - When I tell any software to print something, nothing appears in the cue of system-config-printer.

Here is some indication about what I have, and what I've tried already:
- Either I have a driver SULD installed or not, the situation is the same, always as above.
- I've tried many different versions of Samsung ULD, it is always the same. Each time, I was careful to uninstall the previous one and install the next one, in order to avoid having 2 different drivers at the same time. However, I don't know how to check which drivers are installed, to be sure. Each time I used the command "sudo ./uld/" and "sudo ./uld/" in a Terminal.
- I've cheked on the page "" the Uninstallation Instructions, and I don't have any file left from the previous drivers I have installed.
- I don't know how to print a test page directly from the printer.
- My printer is connected to my laptop with a USB wire. If you think a wireless connection could solve this problem, I'm opened to that but have no clue how to do it, knowing that the printer does not have an ethernet plug.
- I've tried to print with different USB plugs, id does not change anything.
- On the page I have tried the Question 2: I installed the package libpng12-dev, and it installed it together with libc-dev-bin ; libc6-dev ; zlib1g-dev. Then I tried sudo ln -s /lib/ /usr/lib/ so I tried on a Terminal ln -s /lib/x86_64-linux-gnu/ /usr/lib/ and it returned "ln: impossible to create the symbolic link ... the file exists" (translated from French). This did not make any change in the situation.
- Also the troubleshooting of system-config-printer, after printing me the Test page, when I continue, says at the end that there is a problem that there is nothing in the cue of the printer, and that I should try this: su -c 'journalctl -u cups.service --since="None" --until="2017-01-17 09:53:35"' > troubleshoot-logs.txt But when I type this on a Terminal, it returns an error, saying that "None" does not mean anything. And I don't know what with I can replace it.
- As an attachment I put the conclusions of the troubleshooting of system-config-printer, maybe it can help or there is something useful in there?
- Kernel is 4.4.0-59-generic x86_64 (64 bit)
- Desktop is Cinnamon 3.2.7
- Distro is Linux Mint 18.1 Serena
- Laptop is Lenovo, 2011

And also, I posted a first call here where they told me I could find tips overhere, and actually there is a lot... thanks!

Thanks for helping if you have any advice, it would be great!


Hi, I've been visiting the page:
Hummmm... It didn't work. And actually, I have no idea why, it's a bit worse than before. I think the new problem has to do with "Section: Problems installing the CUPS package" (see at the end of the post!).
Here are details about what I managed to do, and what I didn't manage:

Section : CUPS error_logh
The /var/log/cups/error_log is error_log-2017-01-18 (document is attached)

Section : Troubleshooting Wizard
The file is troubleshoot-2017-01-18.txt . Impossible for me to create the file troubleshoot-logs.txt because « I tried again this command (su -c 'journalctl -u cups.service --since="None" --until="2017-01-17 09:53:35"' > troubleshoot-logs.txt) and it's different from earlier. Now, it simply gives this sign ">", flashing, on a next line. I've made a Screen Impress, it's as an attachment. But still, I can save a troubleshoot.txt document, on the next panel of the debug tool of system-config-printer. In fact, I never have such a troubleshoot-logs.txt document.
It's the same, either I write sudo or su, and either there is a SULD driver installed for the printer or not. »

Section : Print Error pop-up window
I don't have such a window, and cannot click a diagnose button.

Section : AppArmor Protection of the printing system
I don't have apparmor-utils installed. I've only libapparmor1, version 2.10.95-ubuntu2.5

Section : Capturing print job data
Until step 4 « Display the content of CUPS' spool directory using the command
$ sudo ls -1 /var/spool/cups
(Enter your password when asked). » it's ok.
But step 5, « There should be exactly one file beginning with a "d". Copy this file to your home directory: »
I don't have any file beginning with a « d ».

Section : Getting the data which would go the the printer
Step 1 : « Activate printing into a file by adding a line containing "FileDevice yes" to /etc/cups/cups-files.conf and restarting CUPS by the command
$ sudo restart cups »
I cannot modify the file cups-files.conf. It's a read-only file.

Section : Sending a file to the printer unfiltered
Impossible to try, because before that I tried Section : « Problems installing the CUPS package » and now everything is broken (see below).

Section : « PostScript (PDF) printer chokes on the PostScript (PDF) coming from Ubuntu »
I don't understand what it is about, but I'm not more concerned about PDF documents than about ODT, TXT and others. So I don't seem to be concerned by this section.

Section : USB printer does not print or prints garbage
I follow the steps of part 2., till and when I make the change « lpadmin -p M2070-Series -o usb-unidir-default=true » it still does not print, nothing changes.
I follow the steps of part 3, till and when I mak the change « lpadmin -p <queue> -o usb-no-reattach-default=true » it still does not print, nothing changes.
I use commands « lpadmin -p <queue> -R usb-unidir-default » and « lpadmin -p <queue> -R usb-no-reattach-default » to come back to the default settings.
I don't have ubuntu-bug cups, I don't have software apport, because I have Mint, and not Ubuntu.
Lsusb gives Bus 001 Device 003 : ID 04e8:3469 Samsung Electronics CO., Ltd

Section : Problems installing the CUPS package
When I run the command wget
it returns Connecting to people.... Connected.
HTTP request transmitted, waiting for an answer... 404 Not Found.
Then I cannot do the next steps.

Then I run
« $ sudo mv /etc/cups/cupsd.conf ~
$ apt-get download cups
$ sudo dpkg -i --force-confmiss cups_*.deb »
to restore the default settings. Now, when I want to print a document from libreoffice, it does not say anything anylonger. It simply makes a small window of the middle of the screen, appearing and disappearing so quickly that I cannot read anything. It's the same size as the previous window « "Impossible to start the printer! Check its settings" » I had so far.
And now, when I start system-config-printer, it says that « the printing service is unavailable. » It says « Start the service on this computer or connect yourself to an other serveur. »
So I tried to remove cups and system-config-printer-gnome, -common and -udev, and to install it again, with Synaptic.
It is still the same, when I start system-config-printer it says as above « the printing service is unavailable. » etc.
So I don't know what is worse than before, but... it's worse... I think this appeared only during the Section : Problems installing the CUPS package.

Section : Turboprint
Does not seem to be relevant in my case...

Has anyone a clue how to come back to the previous step, at least with system-config-printer working, with no connexion problem? And maybe, how to print a page with this printer...?


It works wouhou!!!!!!
I tried to follow advice given there but it went wrong: When I tried to install splix, I could not install it with command lines, did not feel able to; so in Synaptic I added a repository to have the right packages; I did it wrongly because Synaptic could not open anylonger (that was the last time I do such a thing by myself, I'm clearly not able to!). I could not repare it by myself, so I started back from a total new LinuxMint installation.
Now, how it comes that the printer works:
- Basically, it was the same situation than at first: The machine scans, and when I launch system-config-printer it does not print a Test Page directly, but the troubleshooting wizard prints a test page. And no software is able to print anything.
- So I came back to the properties of the printer, in system-config-printer. On the line "Maker and Model" I clicked "Modify". There I followed the wizard and selected "give a PPD file" by myself. I went to and downloaded a driver (version 1.00.29). Inside this driver there was a PPD file matching with my printer. I selected this file in the wizard of system-config-printer. Next step of the wizard, I selected to replace everything.
- Then I could click the button "Print a Test Page" in the properties of my printer, in system-config-printer. But there was an error, saying that a printing filter was missing. When I went to the troobleshooting wizard of system-config-printer, it said that the program /usr/lib/cups/filter/rastertospl was required, and that it was missing. So far I could not print anything more than previously.
- So I went to this page: And I used the command "sudo ln -s /opt/smfp-common/printer/bin/rastertospl rastertosplc" I don't know if it was useful at the end, but it didn't change anything at this moment.
- Then I installed the driver of the printer, (Samsung Unified Linux Driver) SULD, 1.00.29, only the driver with sudo install /WAY/ WAY is replaced by the way to the file.
- And now it works! wouhou!!
I don't know why, for me it's quite magical, and I only hope it won't crash at a coming Mint update, like it did last fall!
Special thanks to pdc_2 for wandering around the Mint Forum and helping lost users!
Good luck to everyone with a Samsung printer, hope these few lines will help some people!

Repository Information Legal Contact Alternative Drivers