SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

apt-get update issue

Started by djfil007, January 13, 2016, 01:45:25

Previous topic - Next topic


Really appreciate finding this repository to try and help install my Samsung ML-1915.

Raspbian Jessie Lite on Raspberry Pi 2B.

Followed instructions as per repository setup guide on first page.  Following error/log when I try to do 'sudo apt-get update'...


Hit debian InRelease
Hit jessie InRelease
Hit jessie InRelease
Hit jessie/main armhf Packages
Hit jessie/ui armhf Packages
Hit jessie/main armhf Packages
Hit jessie/contrib armhf Packages
Hit jessie/non-free armhf Packages
Hit jessie/rpi armhf Packages
Ign jessie/main Translation-en_GB
Ign jessie/main Translation-en
Ign jessie/ui Translation-en_GB
Ign jessie/ui Translation-en
Ign jessie/contrib Translation-en_GB
Ign jessie/contrib Translation-en
Ign jessie/main Translation-en_GB
Ign jessie/main Translation-en
Ign jessie/non-free Translation-en_GB
Ign jessie/non-free Translation-en
Ign jessie/rpi Translation-en_GB
Ign jessie/rpi Translation-en
W: Failed to fetch  Unable to find expected entry 'extra/binary-armhf/Packages' in Release file (Wrong sources.list entry or malformed file)

E: Some index files failed to download. They have been ignored, or old ones used instead.


Help please.  Not sure why it's failing.

Also am I barking up the wrong tree?  I've read mixed messages regarding the ML-1915 drivers and Raspbian.  Is armel supported or not?  Should I switch to fedora or another distro?

Thank you!


The answer is that yes, it is supported, but only if you configure the system correctly from the very beginning.

The issue has to do with "soft float" (armel) vs. "hard float" (armhf).  The difference is whether floating-point calculations are done by the processor (hard float) or software (soft float).  The original ARM processors, including the one that the first Raspberry Pi was built on, did not have a hardware floating point processor, and so were all "armel".  This is what Samsung released a driver for.  All current Raspberry Pi devices (I believe) can in fact run as armhf, and that is the version that is provided if you download an installation image from the Raspberry Pi foundation.  You cannot use the Samsung driver this version, and based on the "armhf" in your output, that is the version you are using.

It should (I think, not tested by me) be possible to download and install an older armel Raspbian installation from, and that will work with the printer driver - at least for the versions that Samsung released an ARM-compiled version.  The downside to using armel when armhf works is that some processes will be slower and more energy-intensive, because software calculations are not as efficient as hardware ones.

So if you want to use the Samsung driver, you would need to download and install a fresh image of Raspbian that is armel instead of armhf.  There may also be a loss of access to some packages in other respositories as a consequence, I don't know how many other things are currently offered as both armel and armhf.


Thank you very much for your detailed response.

Trying to search for an armel version of Raspbian has been tough so far, appears Raspberry Pi themselves (or via no longer host armel versions of their distro.

Hopefully I'll be able to find one (that works on Raspberry Pi 2 hardware), as this is the primary use for my RPi.

Will follow up later if any further issues.  Thank you again.


Bah.  Appears it's not possible for the Raspberry Pi 2 hardware.  Guess I'll need to see if I can find another method to get my printer working (foomatic maybe).



Did you get your printer working with Raspberry Pi 2 armhf.
Could you be so kind to provide alternative solution.

I run Raspberrypi 4.4.13-v7 armv7l  GNU/Linux - the error that I receive is armhf.


I did.

appears to be already in the latest raspbian repositories.  sudo apt-get splix


Would you be so kind to provide me with a full instruction
I'm beginner and not sure the way its installed and used.

Is it replacement of Cups or is just a Samsung drivers (replacing the original Samsung drivers)


This is only drivers.  Use with CUPS.  Once installed, you should see a large section of Samsung drivers/printers to choose from when configuring CUPS.


I tried to install the Splix but unfortunately my Samsung model is not included in prints list.
Tried different model but can't get working.

Repository Information Legal Contact Alternative Drivers