SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

Xpress c460W Color multifunction

Started by alesand, June 05, 2016, 17:08:26

Previous topic - Next topic


hello, I have a Xpress c460W Color multifunction samsung  printer.
I installed it on windows xp, vista, 7, android, all they  work fine, furthermore I have a virtual machine(virtualbox)
with ubuntu 12.04 inside windows 7
I downloaded  uld_v1.00.36_00.91.tar from When I executed ./install_sh. script(samsung installer) on ubuntu 12.04 virtual machine , the logs are ok, cups and sane too, no message error according the display. Both printer and scanner  work ok with usb port using simple scan and xsane, furthermore the printer works ok on wireless network protocol through my router, but the scanner does not work on wireless network protocol through my router. Xsane and simple scan display "No device available" .

Note: I repeat I am working on the virtual machine ubuntu  12.04

I run these testings:

a) from windows ipconfig:
   printer ip:
   virtualbox ip:
   subnet mask:

b) from ubuntu
my virtual machine ip

c) Tell SANE to run as a server (saned)

#sudo nano /etc/default/saned
# Set to yes to start saned

d) Tell saned who to share with sudo nano /etc/sane.d/saned.conf
## Access list

#sudo service saned restart

#sudo service saned status
saned is working

however no detect the scanner

Other testings:

1)add the saned user to the lp group

sudo usermod -a -G lp saned

2)Export the scanner to localhost

sudo nano /etc/sane.d/saned.conf

## Access list

3) Tell SANE to use localhost

## saned hosts

From the command line, run

Nothing it works, ¿ why does printer work and the scanner not works? they are in the same machine

What other testings can I do?

thanks for advance


My guess is that you are encountering a variation of the issue of crossing network address space, because Ubuntu thinks it has an IP address in space but you are asking it to find the scanner in space.  See, even though it applies to the older drivers it is possible that the network work-arounds may provide some clues.

It may also be an issue with the network setup in Virtualbox.  Even though the printer works, the scanner mode has always been more sensitive to network quirks.  You could try setting up port forwarding (if you are configured as NAT) or using bridged networking.  I don't know if either would help.

Ubuntu 12.04 also has a history of network problems with the Samsung drivers that are solved by using any other release.  You could try setting up a new virtual machine with a different release and checking to see if it works.


bchemnet, thank you for your quick replay. I will follow attempting it


I've successfully detected WiFi on two debian distros - Point Linux & Linux Mint LMDE.

cd /etc/sane.d/
nano xerox_mfp.conf

Edit #Samsung C460 Series
# usb 0x04e8 0x3468
tcp # IP address of Samsung Printer at the moment  - obtained either from your router or a printout of the SL-C460W information from the printer itself.

Don't know if the usb needs commenting out but I'm not using it so decided to play safe.

Didn't need to make any other changes.

Repository Information Legal Contact Alternative Drivers