SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

SL-M2875DW/XAC requires reboot

Started by gbierner, March 03, 2017, 13:14:54

Previous topic - Next topic


Hi, thanks for the great work here.  I just got a SL-M2875DW/XAC and installed it on the network (no usb).  Setting up the printer was a snap.  Then I installed the suld-driver-4.00.39 package to get the scanner to work, and instant success.  Running scanimage -L found the scanner and I could scan using simple scan and also gscan2pdf and things worked beautifully.  A few days later, I tried to scan again and the scanner couldn't be found.  I tried editing the /etc/sane.d/xerox_mfp.conf file to specify the ip address, and this allowed the scanner to be found, but gscan2pdf no longer worked-- the scanner seemed to be trying but nothing really happened.  I rebooted my machine and now scanimage -L detected 2 versions of the scanner, and I was able to scan fine again with one of them.  Next day, back to square one.

It seems as though something different is happening with xerox_mfp.conf that's not the same as the auto-discovered version.  I'd love to figure out how to either 1) have that work correctly or 2) not have to reboot to get back the auto-discover.  Is there some service that needs to be restarted or something?

Thank you!


*Face Palm*

I was on a VPN, so the network scan wasn't working.   Obviously the reboot "fixed" it.

So let me change this from a request for help to a hearty thank you to the maintainer of this project for making it so easy to get network scanning working.  Thank you!

Repository Information Legal Contact Alternative Drivers