SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

Samsung M2835DW

Started by harry mole, March 31, 2017, 20:25:03

Previous topic - Next topic

harry mole

Hello all,  My printer a Samsung M2835DW, seems to print fine until I try to print out something from Libre Office Writter (v5.1.6.2).  The red light comes on and I have to disconnect the power then plug it back in to clear it.   If I print something that was saved to the desktop, it prints with no problem.  I am using the Ubuntu drivers that Ubuntu installed when it found the printer.  I am running the printer as USB wired, and have not tried to use the wireless feature.  I can print to the printer using my tablet with Bluetooth.

I get a message printed out (once in awhile) that I am using the wrong driver.  This is a relatively new printer and a fresh install of Ubuntu Mate 16.04 (2nd time), and I don't want to screw it up again.

Could someone please give me step by step instructions, as I'm older and a bit forgetful.  I'm a wanna be geek, but it's a bit to late. 




You can try 2 things.  The easier one is to try to have Libreoffice change the way it outputs print jobs.  Open Libreoffice to a new file (any type), then go to the Tools Menu, Options, and select Print under "Libreoffice".  Uncheck (or check) the box next to "PDF as standard print job".  Click OK and try to print again.  If it still doesn't work, it is probably best to leave that option turned on (checked), so adjust it if necessary and try the next option.

The more involved option is to install the Samsung driver and use that.  You can set up the repository as described on the main page, through the SULDR link above.  Once you have the repository set up, choose driver2-1.00.36 to install.  You will then need to add your printer again as a new printer.  During the process, you may have to choose the correct driver (Samsung....M283x) or it may automatically pick it up.  The default Ubuntu driver might be the default, though, even with the new driver installed, so you should check to make sure you are using the M283x driver.

harry mole

Thank You bchemnet, for the quick reply.  I tried the 1st option, and it worked!   Prints as it should. 

How do I mark this post as Solved?

Thanks again


Repository Information Legal Contact Alternative Drivers