SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

Scanning over WLAN with Xpress C460FW sometimes works

Started by s-light, August 05, 2017, 04:02:30

Previous topic - Next topic


Hey @all,

yesterday i tried to configure my Kubuntu 17.04 to be able to scan with my Samsung Xpress C460FW over WLAN.
The WLAN is managed by an (technicolor) router.
the printer/scanner has the ip my computer has
so they are in the same net / ip-area.

i first tried with the hack to include the ip in the /etc/sane.d/xerox_mfp.conf config file:

#Samsung C460 Series
#usb 0x04e8 0x3468

this seemd to work partly - if i remember correctly i had success one time to scan just one page.
after this i got io-errors. (i used Skanlite)

i also tried to use usb - with the xerox_mfp.conf config changed back.
but this also didn't work. (here it could be that i have missed to restart my system?! )

then i tried and installed "sudo apt install suld-driver2-1.00.36" from the repository.
restarted and tried again. nothing changed.
i also got only one or two time a single scan and on a second try to scan  i got again an io error.

iam a bit lost how to debug this.

before i started to experiment with the scanner yesterday the printer part was installed as printer in my system - i don't remember how i have done this - i think with the normal system tools...

could this mean that i had the original samsung driver installed before i started yesterday? could this mean that i know have installed two versions?
how can i check this?

hopefully someone of you can help me to understand this all better ;-)

sunny greetings


today i tried to print something via network. no look.
the document was an one page pdf - the printer started to print pages over pages with some on or two lines of abstract symbols.. i canceled...

then i printed via the usb connection (second printer also installed.) this worked fine!

then out of curiosity i just tried to scan with gscan2pdf:
YEAH!!! it worked i had a list to select a scanner from :-)
i first tried with the usb connection.
the scan worked. multiple times.
only thing that did not work: automatically scan multiple pages with the mutli-page tray (ADF Simplex) -
no difference if i selected 'all' or '# 2' - he only scanned one page but the feeder transported all pages one after each other. Seems here is going something wrong in the communication...

then i tried and switched to the network scanner and disconnected the usb:
same :-) it scanned a page - and then another page (on my request - automatic was broken as before.)

in the attachment you can see the scan dialog from gscan2pdf and the list with the available scanners.

after this i also tried a second time to print something over network. this time it also just worked fine :-)

so it seems i now have a sometimes working setup - i will report back if this is reproducible.

sunny greetings

Repository Information Legal Contact Alternative Drivers