SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

Testing Ubuntu Artful (beta)

Started by nachokb, September 19, 2017, 11:06:49

Previous topic - Next topic


Hey, I decided to jump a little early into testing Ubuntu Artful. It has not disappointed and it's very stable.

The thing is that it brings updates to both GNOME (and its Simple Scan app) and systemd.

1. netdiscovery finds the scanner (of course, it's on the same network segment, nothing fancy):

    ⚡ /opt/Samsung/mfp/bin/netdiscovery --all --scanner
    # DEBUG: Network printers discovery utility
    ip:    slp: 0,0,0,0 snmp: 1,1,0 vendor: Samsung dsc: "CLX-3300 Series"

    ⚡ scanimage
    scanimage: no SANE devices found

2. Simple Scan says "No Scanners Available"; sadly I didn't test sane's scanimage before;
3. samsungScannerServer times out

    sep 19 12:38:23 valinor systemd[1]: Starting LSB: Server for Samsung MFP network scanners...
    -- Subject: Unit samsungScannerServer.service has begun start-up
    -- Defined-By: systemd
    -- Support:
    -- Unit samsungScannerServer.service has begun starting up.
    sep 19 12:43:23 valinor systemd[1]: samsungScannerServer.service: Start operation timed out. Terminating.
    sep 19 12:43:23 valinor systemd[1]: Failed to start LSB: Server for Samsung MFP network scanners.
    -- Subject: Unit samsungScannerServer.service has failed
    -- Defined-By: systemd
    -- Support:
    -- Unit samsungScannerServer.service has failed.
    -- The result is failed.

Any idea what can I test next

-- nachokb


Quote from: nachokb on September 19, 2017, 11:06:49
3. samsungScannerServer times out

Not much in logs either:

    09-15-17 05:01:14 stdout       INFO     Init SANE ...
    09-15-17 05:01:14 stderr       INFO     No Scanner found. Trying again in 30s.


BTW, I tested multiple suldr versions. Now I'm on suld-driver-4.01-17, suld-driver-common-1 1-9, suld-network-2.


I have got the same problem. Since I updated to Ubuntu 17.10 beta Xsane does not find my network-scanner.

Is there already an idea how to solve the problem? Or a workaround?

My workaround is right now to change  /etc/sane.d/xerox_mfp.conf

Instead of

#Samsung CLX-3170fn & CLX-3175FW
usb 0x04e8 0x342a

I changed it to

#Samsung CLX-3170fn & CLX-3175FW
#usb 0x04e8 0x342a
tcp has to be changed to the IP of your own Printer/Scanner-Device
( ->right at the bottom of the page)

But that driver is much slower than the one from Samsung.

Any better idea?



Quote from: sveicken on October 02, 2017, 10:11:02
Or a workaround?

Hey Sven,

  FWIW, now I'm using a USB drive

  I plan on creating a Docker image based on an older version of Ubuntu's userland (say, 14.04 or 16.04) with the hope that I will be able to use _Scan to PC_ at least.

  If that does work, then the next step might be editing the Python script to add some sort of notification mechanism (email, Slack, or whatever).



Thanks for the reply,

for me it worked perfect with 17.04. No problems. I am using xsane very often and there were no problems finding the network- scanner. Only since I updated to 17.10beta the scanner wont be found.

Hopefully there will be a solution soon, as others might get the same problem.



I posted a topic about it. The shared library is in the wrong place, just put on the right one:
sudo mv /usr/lib/sane/* /usr/lib/x86_64-linux-gnu/sane/
Scan nice things and have an awesome life. (:


Hi mhalano,

Wau, pefect!!! Thats it! Now it works perfect! Thank you soooo much for your message!

My problem is solved!

Kind Regards, Sven


If you update your packages to the lastest, this problem should be resolved for everyone.

Repository Information Legal Contact Alternative Drivers