Sticky
SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

Author Topic: Ubuntu 18 Needs new drivers  (Read 180 times)

GottaGetmedat

  • Testing the water
  • **
  • Posts: 2
    • View Profile
  • Linux Distribution: Ubuntu 18
  • Printer: Samsung M2885 MF
Ubuntu 18 Needs new drivers
« on: May 25, 2018, 07:56:23 »
I've spent about 10 Hours now I know for sure. This is not working with Ubuntu 18 and someone needs to rebuild a new driver version.
I have a machine with Ubuntu 16 and after a drive failure a new machine with latest Ubuntu 18
I can install any version with a Samsung M2885 MF so driver 2 latest is version 1.00.39 (driver2) 37 and the only one that says is supported 36 all work Easily and simple with SimpleScan or XSane on the Ubuntu 16.04 box.
Nothing will work to get it working on Ubuntu 18.
I hope someone can confirm this as easily in minutes and repair and release a new updated driver for Ubuntu 18, thanks.

Honestly I tried to find something I'm missing over many days and there really is nothing that can go wrong I've double checked and aligned everything with the Ubuntu 16 that works, so the only possible thing left is the driver simply will not work with Ubuntu 18.

Any suggestions are welcome and I can try within a week or so but it's been fully exhausted.
Not sure how one would proceed with source code on Github maybe?

This is going to hit everybody hard soon as the upgrade. Maybe it's something with Ubuntu 18 that missing or broken but I can't for the life of me figure out what that could possibly be that isn't there.

I can Print fine. It's just the scanner it will not find any devices. This is a network scanner of course. There is no way to connect it USB etc. has to be over the network in another room.

I can also telnet to it etc. so it's not the firewall either. Said yes to that on all installs.

Note: Version 39 installer has permission issues extracting as well hacked around that and again tried them all which all work with the printer from previous version of Ubuntu 16. Tried Root account, sudo etc.






bchemnet

  • Administrator
  • *****
  • Posts: 513
    • View Profile
  • Linux Distribution: Debian Testing
  • Printer: none
Re: Ubuntu 18 Needs new drivers
« Reply #1 on: May 25, 2018, 20:01:50 »
The source code is not available.  Samsung developed it as a closed source driver, and HP has not taken any public action to change that or update the driver since Samsung sold the printer division.  The driver has not significantly changed in several years, so it is entirely possible something no longer works.  And unless the other change causing the problem can be identified and itself changed in some way, nothing can be done.  The driver cannot be changed.  Perhaps the open source drivers work, or will work in the future.  But that conversation would need to happen with those developers - see the alternatives driver link on this site (bottom).

GottaGetmedat

  • Testing the water
  • **
  • Posts: 2
    • View Profile
  • Linux Distribution: Ubuntu 18
  • Printer: Samsung M2885 MF
Re: Ubuntu 18 Needs new drivers
« Reply #2 on: May 27, 2018, 02:16:23 »
Thanks for the feedback.
It's the scanner so half of the alternatives are not able to do that.
I'll exhaust the other options with wishful thinking thanks again.

 

Repository Information Legal Contact Alternative Drivers