SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

SCX 3400 on ubuntu 18.04.1

Started by pi4630, September 03, 2018, 02:09:36

Previous topic - Next topic


Printer Model = SCX-3400
Linux distro = ubuntu 18.04.1
USB connected
suldr-driver 3.00.65 version 4
suld-network 2
suld ppd 1

I have upated my distro from 16.04 to 18.04 (the above driver version worked flawlessy with the old distro), and now have problems making the scanner work. SimpleScan does not have any scanner entry, VueScan doesn't work neither.

sane-find-scanner yields
found USB scanner (vendor=0x04e8 [Samsung Electronics Co., Ltd.], product=0x344f [SCX-3400 Series]) at libusb:003:004
could not open USB device 0x1d6b/0x0002 at 003:001: Access denied (insufficient permissions)

I don't know about the permission problem above. My user is part of lp.

Edited /lib/udev/rules.d/60-libsane1.rules by adding
# Samsung SCX-3400
ATTRS{idVendor}=="04e8", ATTRS{idProduct}=="344f", ENV{libsane_matched}="yes"

Still to no avail. Any hint?



try this in a terminal:
ls -l /dev/bus/usb/003/

And see who owns 001.  If it is not root/lp, you may need to add your user to another group, and/or chown that device to match a group that you are in.

If it is owned by root/lp and you are sure that you are in lp, try logging out & back in, then seeing if you can access it.


pasqualino@Asus:~$ ls -l /dev/bus/usb/003/
insgesamt 0
crw-rw-r-- 1 root root 189, 256 Sep  3 19:16 001
crw-rw-r-- 1 root root 189, 257 Sep  3 19:16 002
crw-rw-r-- 1 root root 189, 258 Sep  3 19:16 003

001 is owned by root.

I installed 'members'. From terminal

pasqualino@Asus:~$ members lp
lp hplip pasqualino barbara

pasqualino is me. This is odd. I tried now and it worked! I didn't change anything, I restart quite often this morning, and now it just works?!?


JJ Henry

After my latest upgrade, my scanner quit to scan.
Printing is as good as always.
But the weird thing is that if the multi-function is in power-save mode and I try to scan something (using simple scan), it gets awake, almost ready to scan, but... the scanning head doesn't move at all.

Thanx folks


Check if lib/udev/rules.d/60-libsane1.rules got overwritten (see above) and report back.

JJ Henry

I think so.
The file 60-libsane1.desktop reports Sept 13th, that could be my last upgrading date.

It contains at the end:

# Samsung SCX-3400 aka JJ-Scanner
ATTRS{type}=="3", ATTRS{vendor}=="Samsung", ATTRS{model}=="SCX-3400", ENV{libsane_matched}="yes"


That line seems not correct. Check the one I've posted earlier. It should read exactly as there (except for the # comments).

JJ Henry

Hi, as you told me I've just pasted the lines:

# Samsung SCX-3400
ATTRS{idVendor}=="04e8", ATTRS{idProduct}=="344f", ENV{libsane_matched}="yes"

into 60-libsane1.desktop file.

Rebooted, but still doesn't work.
QuoteIt should read exactly as there (except for the # comments).

Does it mean I'm supposed to uncomment it?


To avoid misunderstandings:

1) You should edit the 60-libsane1.rules file, which is located in /lib/udev/rules.d/ (You're mentioning a .desktop file, that doesn't sound correct to me). You need to be a superuser to do so (sudo).
2) Have the appropriate packages from suldr installed. These are: suldr-driver 3.00.65 version 4, suld-network 2, and suld ppd 1. Make sure you follow setting up Suldr's repository as explained here

@Suldr: it's a damn pity you're shutting this down. Is there anything we/I can do to prevent this?


JJ Henry

Seems now it's working

I've installed the suld-driver2-1.00.39 package

Thanx for now.
I'll let you know


Quote from: pi4630 on October 26, 2018, 00:48:15
@Suldr: it's a damn pity you're shutting this down. Is there anything we/I can do to prevent this?

I am exploring some options.  It is clear that many people do not want this to go away.

JJ Henry

Nothing to do... it scanned really bad, back and white and with a low resolution.
I tried to change some settings, but nothing moves anymore


Try again replacing the driver packages (see the above).

Let me know about your timezone; maybe we can do a videocall and I can help you doing things while you share your screen with me.


JJ Henry

Pasquale, I'm Italian from Italy.
Where are you?
I tried to contact you by private message, but it seems you're not allowed to.



I'm italian, too :D

Drop me a mail here: p.imbemba (at) so we can take further appointment!


p.s.: I don't know why I'm not allowed to PM


So, we had our remote session and everthing is fine now.

Basically, it boils down to this:

- Have the correct SULDR package version installed;
- Have /lib/udev/rules.d/60-libsane1.rules edited as explained;
- Make sure user accounts are part of lp group;



Hi all, firstly, sorry about my english. I will try to explain how finally can operate my scanner SCX-3400

Maybe, some step was unnecessary, who knows...

All starts in

Add repository:
    :~$ sudo vi /etc/apt/sources.list
    #Samsung Unified Driver Repo
    deb debian extra
    # deb-src debian extra

Try to search samsung drivers...bad luck
    :~$ aptitude search samsung
         "" nothing ""

Search, download and install appropiate driver
    *run as root (also add $user to lp group)

Patch sane config files

Made some links
    sudo ln -sfr /usr/lib/sane/libsane-smfp* /usr/lib/x86_64-linux-gnu/sane

Here, still not working... :-/

Install Suld-scanner-usblp-fix

BINGO!! simple-scan, xsane,...can scan now!!

Un saludo y gracias!!!!

Repository Information Legal Contact Alternative Drivers