SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

SCX 4500 on ubuntu 18.04.01 on USB

Started by yanndan, November 17, 2018, 04:50:56

Previous topic - Next topic


Hello all,

I have updated my ubuntu version from 16.04 to 18.04. It appears that the scanning function does not work anymore. I have a I/O device issue (see the end of the message for the log from simple scan).
My printer/scanner is plugged in USB.
I installed the drivers v1.00.39 from this webpage:

I added the lines to libsane.rules files (I added old and new version since I was not sure):
# Samsung SCX-4500
ATTRS{idVendor}=="04e8", ATTRS{idProduct}=="3426", ENV{libsane_matched}="yes"
ATTRS{type}=="3", ATTRS{vendor}=="04e8", ATTRS{model}=="3426", ENV{libsane_matched}="yes"
#ATTRS{type}=="3", ATTRS{vendor}=="Samsung", ATTRS{model}=="SCX-4500", ENV{libsane_matched}="yes"

I added a symbolic link to make it detected by simple scan:
sudo ln -sfr /usr/lib/sane/libsane-smfp* /usr/lib/x86_64-linux-gnu/sane

I launched simple-scan as a root because I wanted to be sure that was not a permission issue. Below are the lines of the log
sudo simple-scan -d
[+0,00s] DEBUG: simple-scan.vala:637: Starting Simple Scan 3.28.0, PID=3289
[+0,03s] CRITICAL: g_action_print_detailed_name: assertion 'g_action_name_is_valid (action_name)' failed
[+0,03s] CRITICAL: gtk_application_set_accels_for_action: assertion 'detailed_action_name != NULL' failed
[+0,06s] DEBUG: app-window.vala:1714: Loading state from /home/XXXXXXXXXX/.cache/simple-scan/state
[+0,06s] DEBUG: app-window.vala:1671: Restoring window to 668x396 pixels
[+0,06s] DEBUG: app-window.vala:1675: Restoring window to maximized
[+0,06s] DEBUG: autosave-manager.vala:64: Loading autosave information
[+0,06s] DEBUG: autosave-manager.vala:259: Waiting to autosave...
[+0,12s] DEBUG: scanner.vala:1454: sane_init () -> SANE_STATUS_GOOD
[+0,12s] DEBUG: scanner.vala:1460: SANE version 1.0.27
[+0,12s] DEBUG: scanner.vala:1521: Requesting redetection of scan devices
[+0,12s] DEBUG: scanner.vala:806: Processing request
[+0,16s] DEBUG: autosave-manager.vala:281: Autosaving book information
[+0,22s] DEBUG: app-window.vala:1775: Saving state to /home/XXXXXXXX/.cache/simple-scan/state
[+9,09s] DEBUG: scanner.vala:341: sane_get_devices () -> SANE_STATUS_GOOD
[+9,09s] DEBUG: scanner.vala:353: Device: name="smfp:usb;04e8;3426;9721BFFQA02170D." vendor="Samsung" model="SCX-4500 Series sur USB" type="Scanner"
[+12,83s] DEBUG: simple-scan.vala:454: Requesting scan at 300 dpi from device 'smfp:usb;04e8;3426;9721BFFQA02170D.'
[+12,83s] DEBUG: scanner.vala:1569: Scanner.scan ("smfp:usb;04e8;3426;9721BFFQA02170D.", dpi=300, scan_mode=ScanMode.COLOR, depth=8, type=ScanType.SINGLE, paper_width=0, paper_height=0, brightness=0, contrast=0, delay=10000ms)
[+12,83s] DEBUG: scanner.vala:806: Processing request
[+47,09s] DEBUG: scanner.vala:867: sane_open ("smfp:usb;04e8;3426;9721BFFQA02170D.") -> SANE_STATUS_IO_ERROR
[+47,09s] WARNING: scanner.vala:871: Unable to get open device: Error during device I/O


Do you have any idea how to solve this issue?

Kind Regards,


Hello all,

I have a weird issue.
The scanner worked in command line with scanimage but not with simple scan or xsane. After a reboot, it did not work anymore with any programs.

Kind Regards,


Hi pat,

Thanks for your answer but I still cannot scan with linux. I also tried with linux mint and I have the same issue. There is something that bother me: it worked yesterday but it does not work today. I did not change anything in the configuration.

Thanks for everything.


It's not the same scanner (SCX 4500 <> SCX 4705).
In my case I also had to install "suld-scanner-usblp-fix". You can try to change usb socket, if possible directly on the motherboard. Check this page

Repository Information Legal Contact Alternative Drivers