SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

SCX 3400 networked

Started by pi4630, December 14, 2019, 05:06:19

Previous topic - Next topic


Hi everybody,

so far I had my SCX-3400 connected via USB to my ubuntu 18.04.3. Everything was fine via USB: scanning as well as printing.

Kids and wife asked to use the MFP via network, so I bought a TP-Link PS310U, connected it to the MFP and the router. Printing works. Simple Scan however, doesn't find any device. The MFP has the following address: dnssd://samsung%20electronics%20co.,%20ltd.%20scx-3400%20series-20dfdf._printer._tcp.local/

I run netdiscovery, but couldn't find it:

pasqualino@Asus:~$ /opt/Samsung/mfp/bin/netdiscovery -all --scanner
# DEBUG: Network printers discovery utility

My installed suld  packages are:
suld-driver-3.00.65 (version 3.00.65-4)
suld-network-2 (version 4.00.39-2)
suld-ppd-1 (version 4.00.39-2)

What can I do? Should I try the network-1 package?



Have you tried the suggestions in issue 11 for scanners?

The network-1 package is only for much older driver versions.

You could also try the latest driver2 package, which theoretically should work with that printer.

Repository Information Legal Contact Alternative Drivers