SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

Success with Samsung ML-1670 under Manjaro

Started by inksi, July 18, 2019, 15:07:09

Previous topic - Next topic



I inherited a Samsung ML-1670 which was lucky because the old hp has long been a source of trouble. But I could not get the little Samsung to work except under Windows - which I never really use

The printer did not appear in the cups list despite having added in most available extra driver packages (all the foomatic ones, the splix one, and maybe more)
The ML-1660 driver did not work
no generic 5e selections worked
no foomatic selections worked
I never found a linux driver on the Samsung site

The most I could get was a test page telling me 'Internal Error - Please use the proper driver'.

I tried no end of hints and workarounds then for some reason, perhaps a simpler search, the SULDR site popped up. I downloaded the 1.00.27 driver and unzipped the gzipped tar 'UnifiedLinuxDriver-1.00.27.tar.gz' in my Download directory. Then I did a cd to the uld directory created and issued the command
$ sudo ./

This did the trick, I modified the printer under CUPS and saw the new driver there read;y for selection ....
So easy ...


Very grateful because I needed a new printer but could not afford a new one. I hope we have solved this for posterity. I wish there was such a workable solution for the hp :)

many many thanks.

Repository Information Legal Contact Alternative Drivers