Sticky
SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

Author Topic: Minor update and note re: Configurator  (Read 194 times)

bchemnet

  • Administrator
  • *****
  • Posts: 547
    • View Profile
  • Linux Distribution: Debian Testing
  • Printer: none
Minor update and note re: Configurator
« on: May 30, 2020, 17:53:48 »
All driver packages have been updated to include a dependency on libcupsimage2, to reflect a change in CUPS package structure start with CUPS 2.3.1.  This should prevent (or fix) issues with the printers that rely on the raster component of CUPS.

For those still using the Configurator, note that Debian has removed qt4 libraries entirely, so the Configurator is not installable with Debian testing, the next Debian Stable, or the latest Ubuntu (or other distributions) that pull from Debian testing/unstable.  Because of a major security issue a couple of years ago in openssl, after qt4 development was discontinued, one of the essential qt4 libraries for the Configurator is no longer functional.  Therefore, there is no secure way to keep the Configurator installed with a new distribution, and I am officially declaring my support for the Configurator ended.  I am leaving the packages in place for a while longer, but they will eventually disappear, likely along with many packages that are being utilized less than once a month on average (some driver versions, most i386 packages, and all armel packages).  I expect more compatibility issues to arise as CUPS evolves and these drivers continue to age, so I will need to prune the packages down to only those receiving significant use to match the effort I can invest in keeping any packages working.

 

Repository Information Legal Contact Alternative Drivers