SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

No Colorprinting

Started by Blümchen Blau, April 03, 2014, 12:50:03

Previous topic - Next topic

Blümchen Blau


a new problem has been detected (didn't know, because it was not needed ;-))

I am not able to print in colour! :-(
System(s): Ubuntu (Unity) 14.04 32bit-flavor on a Lenovo X220 (same problem on other hardware like a Dell Latitude E4200 & E4300) and a CLX-6220FX over LAN with the bchemnet-Repositories installed.

Tried various drivers for my 6220 (4.01.17 and 3.00.65) with and without "configurator". All kinds of available setting. (Enough toner on board :-))

Any ideas what I can try to have coloured printouts.


I am about to post a new driver version, you could try that (driver2-1.00.21).

Blümchen Blau

New driver but no colour, only "fifty shades of Gray". Painful!
Any other ideas?

Thanks for your work and help!


I'm assuming that you don't have any setting that says "print grayscale" or the equivalent selected anywhere.

You could try a different driver that doesn't match the printer model - sometimes this works.  Perhaps one of the other CLX-6xxx models?

Blümchen Blau

Hi bchemnet,

Many thanks for your time an help! Settings were correct. I know that from the fact, that colour printing is now working! (Haven't tried my other machines on Ubuntu 14.04 (and derivatives) but think, that the problem was caused by the OS - maybe the kernel.) I found out, when printing the scan of a thermopaper-bill. That looked, compared to the written characters (LibreOffice), very much like a composite of colours.

Anyway - problem is solved, although I can't give a solution how. (Sorry for all you searchers in the net. ;-))



I have the same problem with my CLX-6260nd printer, this is driving me crazy!

When I first installed it a couple of weeks ago, everything worked just fine. A few weeks later when I now have to print something in colour, colour printing doesn't work anymore from within Linux.

Printing from Windows, my Android phone, iPad and my MacBook Air works perfect in colour. So does copying.

Distro: Manjaro x64 rolling release with Cinnamon desktop
Connection: 1 gbit Ethernet through router
Driver: Tried all the driver2 versions from 1.00.06 up to 1.00.35

Solutions I tried:
* Different distro's on different computers (!) (Ubuntu, Fedora, both x86 and x64)
* Different versions of different distro's, before updating and after updating
* Different kernel versions
* Changing/deleting ICC/colord profiles
* Eco mode on/off
* Setting every possible setting on the printer from grayscale to color
* Different print quality settings
* Universal PostScript driver
* Different network protocols (IPP/DirectJet/mDNS/LPD)

Only way to reproduce the problem outside of Linux is to print a colour PDF using Direct Print within the printers http interface, which also only prints in gray. This makes me suspect there's nothing wrong with the Linux drivers or settings, but a bug in the printer firmware and/or settings.

Unfortunately I don't recall what I changed for this problem to start. It still printed in colour after I updated the firmware to the most recent version. I searched the manual to find some way to reset everything to default factory settings but couldn't find how.

I also tried printing in colour from a Windows XP guest installation in VMware installed with Linux as host OS - works fine.

Please help!

Blümchen Blau

Hi ewige,

let me tell you that, two weeks after my last posting in this thread, colour-printing dissapeared again. :-/
BUT: I think since Kernel 3.16.x you (for printing) do not need drivers out of bchmnet's repo (at least for 6220). With drivers given by Ubuntu colour-printing works fine for me! (Only reason I added the repo again, is for scanning purposes.)

Maybe it is worth a try with kernel-versions from 3.16 on.



Thank you for returning to this old thread. :-)

I've tried a variety of Kernels ranging from 3.17 to 4.01 with no luck.

What's weird is that I have this same problem in Ubuntu 12.04 and 15.04, Linux Mint 17 and 17.1, Fedora 21 and 22 and my rolling-release Manjaro distro. Regardless if I update the OS after installation or don't. It's as if the printer somehow locked itself into a "I am only going to print in grayscale if you use Linux, no matter what you do!"-mode.

I'm starting to suspect it's a bug or wrong setting in CUPS or GhostScript that somehow "infected" the printer. Though I barely got started on reading up how the Linux printing system and colour profiling works. Still, that doesn't explain why printing pdf's using Direct Print in the SyncThru Web Service doesn't print in colour, as that function is unrelated to the OS or drivers used (?).



After spending yet another afternoon trying to fix this, I now have two theories:

1) Bug in CUPS/Foomatic-rip/GhostScript/ICM/ICC/whatever that replicates itself when Linux Distros autoupdate their printer drivers from the net. Thus it doesn't matter if you use an old version or not as it updates itself if the computer is connected to the Internet. I'm too tired right now to give it another try without an internet connection.

I don't think this is a bug in any Samsung printer driver, as I found posts on various forums about the same problem with Canon and HP printers when I googled. It seems related to CUPS and I'm still trying to wrap my head around how CUPS, CUPS filters, Foomatic, colord and GhostScript are all related to one another and where their config files are stored so I can take a look.

2) I took a look at the /var/spool/cups files to see if perhaps colour information wasn't passed on to the printer in the PostScript file. To my surprise, it seems to just pass on image files (jpeg, gif etc) and pdf/ps to the printer directly. Contrary to Windows where the printout is "translated" before being sent to the printer. This leads me to believe that somehow the printer is stuck in monochrome mode and everything being sent directly to it won't print in colour. This doesn't explain though why the demo page printed directly from the printer prints in colour.

Once again, I checked all settings to make sure they are set to "color" wherever possible.

On the plus side, I found the service manual for the printer and there is indeed an option to do a full reset to default settings, I'm saving it as a last resort.

Update 2:

I had an idea and put a .ps file on a USB memory stick, put it in the USB port on the printer and tried printing the file directly, surpassing any existing driver or setting problem. It came out in grayscale.

I'm starting to feel like Jim Carrey's character in the movie Liar Liar when he can't lie but tries in vain to say out loud "this pen is red!". In the end, he's mentally shattered and gives up, crying out "It's blue! The g-d d-mn pen is bluuuuueeee!"

Update 3:

I printed a colour photo I took with my mobile phone, using the Samsung Print Plugin Android app. It came out in colour.

Then I scanned the very same colour photo I just printed and stored it on the memory stick, still in the printer, then printed the picture. It came out in grayscale.

After that, I put the memory stick in the computer just to make sure the image was scanned in colour mode. It was, as a pdf.

I changed the scanner settings to save scanned images as jpeg and scanned the image again to the memory stick and printed it directly from the printer. Once again, grayscale.

Just for the hell of it, I tried the same thing with a Windows Phone and an iPad. Same result: Printing from any of the mobile devices produces a colour print. Scanning the very same image and printing it results in a monochrome print.

Right or wrong, I conclude for now that it's a bug in the printer or firmware and that the Linux driver lacks any kind of workaround that exists in the other drivers or mobile printing apps.

Update 4:

Umm, there is no option anywhere on the printer to change colour/monochrome settings when it comes to printing!?! I checked every menu both from the control panel and from the SyncThru Web Service. You can change Colour on/off/auto when copying or scanning, but not printing? Could it be that it somehow defaulted to monochrome and that there's no way to change it back?


Problem solved!!

Wow! Finally!!! Now I can print again in colour from Linux computers, Print Direct interface and by connecting USB memory sticks to the printer!

Here's what I did (pardon any mistakes as I am typing this from memory):

1) (Menu) > System Setup > Machine Setup -> Maintenance -> Image Management
2) Run an Auto Color Registration
3) Run an Auto Tone Adjustment
4) Run an ID Sensor Calibration

Either one of them did the trick for me - I didn't do a test print inbetween so I don't know which one it was specifically.

I've not been able to reproduce the bug, nor can I guess what caused it or might cause it in the feature again. The printer manual lists neither the problem itself or any of the maintenance functions as a possible fix for this, so I'm pretty sure it's a bug.

I hope this will help you as well, BB, and other users who find their way to this forum having the same problem.


@ewige: need more details...

Currently I've problems with all my linux machines. As far as I remember... last time I printed in color was on 31.12.2016... However...

Current status:
Printing via linux does only work in grayscale (debian 9/ ubuntu 16.04) and even if I use a newly created debian 8 machine.
Printing from windows 7 works partly in color:
* testpage (windows logo looks fine)
* printing from browser is fine
* printing test patterns from the color manager gets grayscale
Direct printing a color ps file gets grayscale.
Printing the same ps file via google cloud gets colored.
Google Cloud print from android device (pdf) is colored.

I checked xml exported printer prefs with prefs of another printer... They look fine.

Is this problem related to color profiles of the system (colord)?


I don't know why... but color printing is working again. Looks like the printer was the problem. I have not restarted the printer between last unsuccess and the latest successful printing...

(The only thing I remeber is... that I set "print errors" for PCL and PS - but IMHO this could'nt have fixed it :-)


I had this problem with my CPL-680DW on Linux Mint 18.2. Suddenly no colour printing. From my phone no problem.

I tried the solution of ewige, only slightly different menu layout on the printer:
1) (Menu) > Image Management
2) Run an Auto Color Registration
3) Run an Auto Tone Adjustment

Without step 4) are the colours back.


My C480FW seems to have the same issue.  Although I can't seem to find Color registration settings in the menus anywhere.  If anyone figures it out I'd appreciate the info.


I have the same printer as @ewige (CLX-6260ND), and the same problem as all of you guys. The fix that ewige proposed is not working for me. What appears to have worked, however, is a factory reset of the printer. As per some other web page:

Press "Menu > # > 1 > 9 > 3 > 4 " on the printer panel.
Press Menu.
Select "Tech Mode".
Select Data Setup.
Select Clear All Mem.

After this I got at least one color printout, from CentOS 8 using the latest (but now somewhat dated) Samsung drivers and firmware.


Quote from: europ on November 25, 2020, 13:37:28
I have the same printer as @ewige (CLX-6260ND), and the same problem as all of you guys. The fix that ewige proposed is not working for me. What appears to have worked, however, is a factory reset of the printer. As per some other web page:

Press "Menu > # > 1 > 9 > 3 > 4 " on the printer panel.
Press Menu.
Select "Tech Mode".
Select Data Setup.
Select Clear All Mem.

After this I got at least one color printout, from CentOS 8 using the latest (but now somewhat dated) Samsung drivers and firmware.

@europ THANK YOU SO MUCH FOR POSTING THIS.  You just saved me $200-400 on a new printer.  I just tried this and can confirm that this solved my issue as well, but on my C480FW.

Repository Information Legal Contact Alternative Drivers