SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer


Started by adzika, September 25, 2021, 05:13:36

Previous topic - Next topic


Hello, I recently had to reinstall Ubuntu 20.04 LTS.
I have set up Samsung M2022 printer in CUPS but no matter
what I try I get this message - please help?
Idle - "File "/usr/lib/cups/filter/rastertospl" not available: No such file or directory"


Please post the output of the following two terminal commands:

apt list suld*


ls -l /usr/lib/cups/filter/raster*


Here they are:
oem@Kevin:~$ sudo apt list suld*
[sudo] password for oem:
Listing... Done
oem@Kevin:~$ ls -l /usr/lib/cups/filter/raster*
-rwxr-xr-x 1 root root 43248 mar 21  2020 /usr/lib/cups/filter/rastertobrlaser
-rwxr-xr-x 1 root root 22832 kwi 24  2020 /usr/lib/cups/filter/rastertoepson
-rwxr-xr-x 1 root root 35128 kwi 10  2020 /usr/lib/cups/filter/rastertoescpx
-rwxr-xr-x 1 root root 18736 kwi 24  2020 /usr/lib/cups/filter/rastertohp
-rwxr-xr-x 1 root root 22832 kwi 24  2020 /usr/lib/cups/filter/rastertolabel
-rwxr-xr-x 1 root root   563 kwi 10  2020 /usr/lib/cups/filter/rastertopclm
-rwxr-xr-x 1 root root 39240 kwi 10  2020 /usr/lib/cups/filter/rastertopclx
-rwxr-xr-x 1 root root 96680 kwi 10  2020 /usr/lib/cups/filter/rastertopdf
-rwxr-xr-x 1 root root 18760 kwi 10  2020 /usr/lib/cups/filter/rastertops
-rwxr-xr-x 1 root root 34816 lut 10  2018 /usr/lib/cups/filter/rastertoptch
-rwxr-xr-x 1 root root 18736 kwi 24  2020 /usr/lib/cups/filter/rastertopwg
-rwxr-xr-x 1 root root 15964 paź 31  2018 /usr/lib/cups/filter/rastertosag-gdi


It appears you do not have any of the packages from this repository installed, nor the driver using the Samsung installer.  You probably need to configure this repository and then install suld-driver2-1.00.39.

I am not sure why setting up the printer worked to select a driver that is not installed on your system, but that seems to be your situation.


Regarding the driver - I installed suld-driver2-1.00.39, pulled out the driver I needed and deleted the rest (I did the same a few years ago)
Regarding the repository I get this:
sudo apt update
Hit:1 focal InRelease
Hit:2 stable InRelease         
Hit:3 focal InRelease     
Get:4 ./ InRelease [2 441 B]     
Get:5 debian InRelease [17,0 kB]           
Err:5 debian InRelease
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY FB510D557CC3E840
Reading package lists... Done
W: GPG error: debian InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY FB510D557CC3E840
E: The repository ' debian InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.


You need to install the suldr-keyring package first to set up the secure package system.  If you are unable to do so from the repository by explicitly specifying it, then download it from and then

sudo dpkg -i suldr-keyring_2_all.deb

I have not worked with this particular printer, but I think the ppd explicitly depends on some of the Samsung binaries such as rastertospl.  So perhaps when you did this before, you also extracted those or had them installed from a previous attempt at setting up the driver.


Understood, I did this a few years ago and it took a bit but it was not so messy.

Anyway,  i did
download it from

But now I get
oem@Kevin:~$ sudo dpkg -i suldr-keyring_2_all.deb
[sudo] password for oem:
dpkg: error: cannot access archive 'suldr-keyring_2_all.deb': No such file or directory

I appreciate the help. This thing is driving me crazy


Make sure your current terminal directory is the same as where you downloaded.  You might need to

cd ~/Downloads

or similar to depending on where your downloads are saved, before trying the dpkg command.


You are right:o
em@Kevin:~/Downloads$ sudo dpkg -i suldr-keyring_2_all.deb
[sudo] password for oem:
(Reading database ... 201375 files and directories currently installed.)
Preparing to unpack suldr-keyring_2_all.deb ...
Unpacking suldr-keyring (2) over (2) ...
Setting up suldr-keyring (2) ...

But still I get:
Idle - File "/usr/lib/cups/filter/rastertospl" not available: No such file or directory


Now you should be able to do:

sudo apt update
sudo apt install suld-driver2-1.00.39

Probably you will be all set at this point.  But if not, delete & reinstall the printer.


oem@Kevin:~$ sudo apt install suld-driver2-1.00.39
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
suld-driver2-1.00.39 : Depends: libusb-0.1-4 but it is not installable
E: Unable to correct problems, you have held broken packages.


Perhaps you do not have the Ubuntu "universe" repository active.  The last time I used Ubuntu (many years ago) that repository was active by default, but it seems that changed at some point.


sudo add-apt-repository universe
sudo apt update

or see if you have the "community" (universe) repository active under your Software & Updates settings.

Then try installing the driver package again.


Success! Thanks so much for the help, really appreciate it.

Repository Information Legal Contact Alternative Drivers