SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

CLP-510 on raspberry pi 3

Started by behnam263, December 05, 2021, 05:11:38

Previous topic - Next topic


Hello, I tried to install drivers for a Samsung CLP-510 printer, but because I'm using a Raspberry Pi 3 with an arm7 processor,
I can't install anything except unified driver 4.01, which is outside the printer's minimum and maximum support range.

Is there anything that can be done to fix it and make it function, or is there a solution?


I think you have two options.  One is to follow this thread, but use one of the version 3.xx drivers that support that printer instead of the latest package:

The other option is to set the printer to be a "generic postscript" as the printer type.  I seem to recall that works okay with that model, although not quite as well as the dedicated driver.


Thank you for the answer, I watched the link and realized that also other people get the same error that i get
when they try to install the qemu-user emulation of amd64 package :

The following packages have unmet dependencies:
suld-driver2-1.00.39:amd64 : Depends: libxml2:amd64 but it is not installable
                              Depends: libstdc++6:amd64 but it is not installable
                              Depends: libusb-0.1-4:amd64 but it is not installable
                              Depends: libcupsimage2:amd64 but it is not installable
E: Unable to correct problems, you have held broken packages.

So I am going for the second option to test.

Repository Information Legal Contact Alternative Drivers