SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

Author Topic: Clp620nd stops working with cups 1.5.3 <solved>  (Read 7177 times)

iainrs

  • Splashing around
  • ***
  • Posts: 6
  • retired programmer - still learning Linux
    • View Profile
  • Linux Distribution: Linux Mint Debian Edition
  • Printer: clp620nd
Clp620nd stops working with cups 1.5.3 <solved>
« on: September 21, 2012, 13:50:11 »
Hi

Just found your website (wished I'd seen it 7 years ago !!)
I've just upgraded my LMDE system to UP5 and my clp620nd has stopped
I think the cups upgrade from 1.5.2 to 1.5.3 did it.
I've reported it to Samsung who were sympathetic but not very positive (they seemed to recognise the problem!)

In order to continue printing I have now restored the previous system, but would obviously like to use new software.

I got error messages :
    Printer 'clp620-mono':'cups-ipp-conformance-report'
   Printer 'clp620-mono':'cups-ipp-missing-job-history'
(but I am not sure whether I got these before)

The printer has worked OK since purchase in March 2012
Previously I had a CLP550N for 6 years until it became too expensive to maintain.
The clp620 has worked fine with the Unified driver until now.
(it works fine on virtualbox XP)

Is there anything else I can tell you ?

printer   : Clp620nd
Linux     : LMDE (Upgrade 4)
conn'ted :  Networked printer - ipp://192.xxx.x.xxx (used by XP system)
driver      : Samsung CLP-620 Series (SPL-C) - downloaded (March 2012) Unified driver (1.04) - not sure which actual version
nb this driver is still on Samsung website.

Iain
« Last Edit: September 26, 2012, 13:55:52 by iainrs »

bchemnet

  • Administrator
  • *****
  • Posts: 547
    • View Profile
  • Linux Distribution: Debian Testing
  • Printer: none
Re: Clp620nd stops working with cups 1.5.3 (New member )
« Reply #1 on: September 22, 2012, 18:24:02 »
The driver supplied for that printer is 3.00.65.  You might have better luck with a newer version; I've been using CUPS 1.5.3 with more recent versions of the driver without any trouble, albiet with a different printer.  If you don't want to pull from the repository, you can download newer versions from the SULDR website or by looking on Samsung's site for a newer printer (e.g., SCX-3405, CLP-365).

iainrs

  • Splashing around
  • ***
  • Posts: 6
  • retired programmer - still learning Linux
    • View Profile
  • Linux Distribution: Linux Mint Debian Edition
  • Printer: clp620nd
Re: Clp620nd stops working with cups 1.5.3 (New member )
« Reply #2 on: September 23, 2012, 02:16:11 »
Thanks for response.
How do I find out which driver I am actually using ?
The download file was 'UnifiedLinuxDriver_1.04.tar.gz'.

bchemnet

  • Administrator
  • *****
  • Posts: 547
    • View Profile
  • Linux Distribution: Debian Testing
  • Printer: none
Re: Clp620nd stops working with cups 1.5.3 (New member )
« Reply #3 on: September 23, 2012, 22:46:12 »
Sometimes the about dialog in the Configurator gives the correct version.  There is a file in the download from Samsung that lists the various versions as well (there are several).  And it usually says on the Samsung website where you find the file, although the download itself is invariably named differently.

All told, it's non-trivial.  Even my repository versioning is a bit arbitrary, because I version everything after the core driver, but there are actually several version numbers in use.  And to make it even more interesting, the 4.00.xx series of drivers restarted the numbering they use on the download file names, so for example the new 4.00.36 is give as 0.86, but it is actually newer than the 1.04 you have.

iainrs

  • Splashing around
  • ***
  • Posts: 6
  • retired programmer - still learning Linux
    • View Profile
  • Linux Distribution: Linux Mint Debian Edition
  • Printer: clp620nd
Re: Clp620nd stops working with cups 1.5.3 (New member )
« Reply #4 on: September 24, 2012, 07:08:17 »
Thanks again

Configurator - About gives
Common : 3.00.65
Printer : 3.00.38
Build : 253

I am intending to
a. Update LMDE to UP5 (again)
b. Add you repository to lists**
c. Update program lists**
d. Uninstall Samsung software**
e. Install your drivers**

** as per instructions on the website

Are there any other things that I should consider ?

bchemnet

  • Administrator
  • *****
  • Posts: 547
    • View Profile
  • Linux Distribution: Debian Testing
  • Printer: none
Re: Clp620nd stops working with cups 1.5.3 (New member )
« Reply #5 on: September 24, 2012, 16:13:58 »
The "common" is what I consider the version number.

Your plan is reasonable; if for some reason you wanted to test the repository first, you could do step a last.

iainrs

  • Splashing around
  • ***
  • Posts: 6
  • retired programmer - still learning Linux
    • View Profile
  • Linux Distribution: Linux Mint Debian Edition
  • Printer: clp620nd
Re: Clp620nd stops working with cups 1.5.3 (New member )
« Reply #6 on: September 24, 2012, 16:56:36 »
" ... you could do step a last."
The problem with that is I have 1409 current updates outstanding and I'm not sure how to put off doing those while I  add another repository.

It it feasible/wise to exclude the 6 cups 1.5.3 updates in the major update. (i.e. upgrade but stay with 1.5.2) ?
« Last Edit: September 26, 2012, 03:37:19 by iainrs »

iainrs

  • Splashing around
  • ***
  • Posts: 6
  • retired programmer - still learning Linux
    • View Profile
  • Linux Distribution: Linux Mint Debian Edition
  • Printer: clp620nd
Re: Clp620nd stops working with cups 1.5.3 (New member )
« Reply #7 on: September 26, 2012, 11:07:46 »
Success - Thanks
I reinstalled LMDE UP5 (excluding cups 1.5.3) and it worked OK.
I changed to using the Repository  4.00.35
 - installed CLP620
 - Originally I used Foomatic driver - monochrome only
 - used SPL/C - worked fine

Upgraded cups to 1.5.3 - still worked - good

A question ?
in the past I used 'ipp' connection
this time 'lpd (PASSTHRU)' was default & I used that.

Other options were 'socket' & 'smb'

what are the pros/cons of the connection types ?
(sorry if this is very elementary)

Thanks for your help
Iain



bchemnet

  • Administrator
  • *****
  • Posts: 547
    • View Profile
  • Linux Distribution: Debian Testing
  • Printer: none
Re: Clp620nd stops working with cups 1.5.3 <solved>
« Reply #8 on: September 28, 2012, 20:04:24 »
IPP is the most sophisticated protocol; this is a quick summary of sum advantages:
http://www.cups.org/articles.php?L193+TFAQ+Q

That said, most home (or even small office) users have no need for the advantages of IPP, and LPD or JetDirect/Raw work just fine.  I believe some of the Samsung printers do provide a little more information about ink levels & the like over IPP than LPD, but by no means all of them.  And if the printer does not properly support IPP, IPP can be a headache.

SMB is the Windows sharing support, for printers shared over a Windows network.

Personally I use LPD for all the many printers my laptop interacts with at home, work, and when traveling, because it is so reliable and I don't really care about the extras that IPP provides.  But none of those printers are highly managed, either.

 

Repository Information Legal Contact Alternative Drivers