SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

Cant print with my M2620 ( M262x-282x )

Started by gersh94, December 05, 2023, 04:16:32

Previous topic - Next topic


Hi everyone,
Tried installing the latest driver for the laser printer (USB connection) but after the installation was finished I sent a job to test print, it was processing and then the job stopped.

tried 1.00.39 and 37 drivers

any input would be helpful
Using Debian 12 with the latest updates, am4 x64.

adding a YouTube video


There have been previous reports that this behavior sometimes happens with the automatically installed/detected printer.  You can try deleting the installed printer and then adding it again manually.

If that does not help, apparently certain models also benefit from the following to address what might be a name coding error for certain printers:
cd /usr/lib/cups/filter/
sudo ln -s rastertospl rastertosplc

The 1.00.39hp driver might also work.

The three approaches can tried in combination as well.

Repository Information Legal Contact Alternative Drivers