SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

CLP-365 - no page gets printed

Started by ugo, October 28, 2012, 08:10:06

Previous topic - Next topic


Hi all,

1. printer model: CLP-365
2. Linux distribution and version: Debian Testing
3. printer connection: USB
4. driver version (packages) installed: installed the latest driver packages using the repository
5. specific problem including any error messages:
though the printer appears to be properly configured, no page gets printed when the "Print Test Page" is requested (either through the CUPS web interface of through gnome printer UI). Printer Job appears to be sent and completed with no visible error shown, yet nothing gets printed. Printer's green led blinks shortly.

Printing a text file through lp works ($ lp -d Samsung_CLP-360_Series a-text-file)

6. Other relevant information:

I'm attaching the troubleshoot.txt created by the "Troubleshoot" wizard of gnome's system-config-printer.

In addition to the test made with the repository's package installed, I also tried to manually install and configure the printer by manually copying the .ppd file and rastertosamsungsplc files (as suggested in Made no difference. With the packages installed, I do get in cups/error_log many "Bad driver information file" lines such as

[cups-driverd] Bad driver information file "/usr/share/cups/model/samsung/cms/CLX-3160-600x600cms2"!

With the manual install, those disappear but that's about the only difference --still nothing gets printed.

If there's any additional detail needed, please let me know.

Thanks in advance for any help or hints in troubleshooting this.



Hi all,

just an additional test done right now.

I installed the Samsung driver available at

by running the script.

Though printing did not work with the printer the installer configured (I believe it used /dev/mfpx, though I did not take a note of that), removing that printer and than adding a new one through the CUPS web GUI did work.
The CUPS page for the printer reports:

Description:   Samsung CLP-360 Series
Driver:   Samsung CLP-360 Series (SPL-C) (color, 2-sided printing)
Connection:   usb://samsung/CLP-360%20Series?serial=...

and the test page now gets printed.

Perhaps this may be useful to understand how the driver package in the repository could be fixed in order to work with this printer.


Cheers, Ugo


I'm not sure what the difference is, because the driver package you downloaded is the same one available on the SULDR website and the basis for the 4.00.39 packages.  But I'll make a note for when I have time to look into it.


Just seting up a CLP 365w

Prints from Samsung mobile app so I know it can work ;)
XUbuntu 12.04
Latest software from repository
Printer deleted and recreated
Tried Appdirect ad well as LPR

Network cable
No error messages

AppDirect - test page, 50%page width, no further print outs as above
LPR - test page and images print out but at 50% width


Reconfigured multiple times

Test page works from IPP, LPR & Direct
Choose Quality option and change "best" to "normal" and page prints full width

ONLY LPR is working for me to print anything else.
Ensure Quality set at "normal" on driver and also in advanced options of any print dialogue (eg GIMP)

CLP 360 driver with CLP365W printer.
xubuntu 12.04. latest SULDR. CUPS 1.5.3-0ubuntu4


I am in the same situation. lp works, print jobs appear in Completed Jobs, but nothing is printed. However... LibreOffice 3.5 Writer can also print. This means my money was not completely wasted.

clp-365 connected by USB
Mint 13 Maya Mate
driver downloaded from Samsung: UnifiedLinuxDriver_CLP-360_0.87.tar.gz ( dated Tue 20 Mar 2012)
Quality option changed to "normal"
Computer CPU is an old AMD dual core  Athlon 5200+ @ 2.7 GHz

Update: Well, Writer can print text. If the document has pictures, then it does the usual completed job but nothing printed.


Try removing the files you installed and installing a version from the repository.



I have similar problem with this model.

1. Printing plain text with /opt/Samsung/mfp/bin/slpr works

2. Printing any images/pdf doesn't work
Green LED blinks for about 1-5 mins
and then it prints page with following text:

SPL-C ERROR - Including Corrupted Data

     POSITION : 0xd1c0 (53696)

     SYSTEM   : src_5.59/xl_image

     LINE     : 759

     VERSION  : SPL-c 5.59 05-04-2012


SPL-C ERROR - Illegal Resolution

     POSITION : 0x0 (0)

     SYSTEM   : src_5.59/xl_tbl

     LINE     : 836

     VERSION  : SPL-c 5.59 05-04-2012

3. I tried these drivers:

md5, file name
94ee35696ddad334a53f76c9606607a5  ULD_Linux_V1.00.06.tar.gz
f245d9c85d212813f19710ed33fd8429  UnifiedLinuxDriver-4.00.39.tar.gz

Tried adding printer from "Samsung Unified Driver Configurator"
URI: mfp:/dev/mfp4

Tried from CUPS Web Interface:
Driver: Samsung CLP-360 Series (SPL-C)
Connection: usb://samsung/CLP-360%20Series?serial=Z6Y7B8GD4E005RE

4. Tried Quality: Normal

5. In Windows it does print images, but only small ones.

6. Tried in Ubuntu and ArchLinux

extra/cups 1.6.3-1 [Installiert]
extra/cups-filters 1.0.38-1 [Installiert]
extra/cups-pdf 2.6.1-1 [Installiert]
extra/foomatic-db 1:4.0.17_20130518-1 [Installiert]
extra/foomatic-db-engine 1:4.0.17_20130518-1 [Installiert]
extra/foomatic-filters 1:4.0.17_20130518-1 [Installiert]

Linux jerboa 3.11.2-1-ARCH #1 SMP PREEMPT Fri Sep 27 07:35:36 CEST 2013 x86_64 GNU/Linux


I can't find any logs, messages on PC. Maybe try manually with "rastertosamsungsplc", "pstospjlps" and other programs and look for messages? But I don't know how.


As before, my first suggestion is to install the drivers via the repository.  Although given that the 1.00.06 driver didn't work and the installer for that one is okay, I'm not optimistic it will matter.  This sounds like an issue with the actual printer, not the driver, especially given that even the Windows driver doesn't work perfectly.  I suggest contacting Samsung support.

Repository Information Legal Contact Alternative Drivers