SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

Samsung CLX 3185 won't print with Quantal 12.10

Started by Sinai, November 24, 2012, 15:42:01

Previous topic - Next topic



I use since a few days Kubuntu Quantal Quetzal 12.10. But printing with my Samsung CLX 3185 doesn't work at all. Scanning works fine. The printer ist connected by network usin protocol ipp. Driver ist installed from your repository (packages below). There are no messages in /var/log/syslog. Any other place i should search for?

With Natty and Oneiric everything worked fine. At the moment i feel like just before changing fro Opensuse to Kubuntu, because my old printer didn't work any more.

I found one Issue about this problem and one hint, that it doesn't work any more - but no solutions. I am using linux for several years. compiling patching and testing is nor problem for me.

But i don't want to downgrade to natty or oneiric causing a complete new installtion.




andreas@andreas-ThinkPad-T60:~$ dpkg -l samsungmfp*
Gewünscht=Unbekannt/Installieren/R=Entfernen/P=Vollständig Löschen/Halten
| Status=Nicht/Installiert/Config/U=Entpackt/halb konFiguriert/
         Halb installiert/Trigger erWartet/Trigger anhängig
|/ Fehler?=(kein)/R=Neuinstallation notwendig (Status, Fehler: GROSS=schlecht)
||/ Name                          Version             Architektur         Beschreibung
ii  samsungmfp-common             4.00.39-1           all                 Samsung Unified Linux Driver (common files)
ii  samsungmfp-configurator-data  4.00.39-1           all                 Samsung Unified Driver Configurator (data)
un  samsungmfp-configurator-qt3   <keine>                                 (keine Beschreibung vorhanden)
ii  samsungmfp-configurator-qt4   4.00.39-1           i386                Samsung Unified Driver Configurator (Qt4 interface)
ii  samsungmfp-data               4.00.39-1           all                 Samsung Unified Linux Driver (data)
un  samsungmfp-data-legacy        <keine>                                 (keine Beschreibung vorhanden)
un  samsungmfp-driver             <keine>                                 (keine Beschreibung vorhanden)
un  samsungmfp-driver-3.00.65     <keine>                                 (keine Beschreibung vorhanden)
un  samsungmfp-driver-3.00.90     <keine>                                 (keine Beschreibung vorhanden)
un  samsungmfp-driver-4.00.35     <keine>                                 (keine Beschreibung vorhanden)
ii  samsungmfp-driver-4.00.39     4.00.39-1           i386                Samsung Unified Linux Driver (drivers)
un  samsungmfp-driver-install     <keine>                                 (keine Beschreibung vorhanden)
un  samsungmfp-driver-legacy      <keine>                                 (keine Beschreibung vorhanden)
un  samsungmfp-legacy-configurato <keine>                                 (keine Beschreibung vorhanden)
un  samsungmfp-legacy-configurato <keine>                                 (keine Beschreibung vorhanden)
ii  samsungmfp-legacy-configurato 3.00.37-11          all                 transitional package for samsungmfp-configurator-qt4
un  samsungmfp-legacy-netdiscover <keine>                                 (keine Beschreibung vorhanden)
un  samsungmfp-legacy-netdiscover <keine>                                 (keine Beschreibung vorhanden)
un  samsungmfp-legacy-scanner     <keine>                                 (keine Beschreibung vorhanden)
ii  samsungmfp-libmfp             4.00.39-1           i386                Samsung Unified Linux Driver (core library)
un  samsungmfp-netdiscovery       <keine>                                 (keine Beschreibung vorhanden)
un  samsungmfp-netdiscovery-oldli <keine>                                 (keine Beschreibung vorhanden)
ii  samsungmfp-network            4.00.39-1           i386                Samsung Unified Driver Configurator (network connectivity)
un  samsungmfp-network-legacy     <keine>                                 (keine Beschreibung vorhanden)
ii  samsungmfp-scanner            4.00.39-1           i386                Samsung Unified Linux Driver (enable scanning)
un  samsungmfp-scanner-sane-fix-m <keine>   


I found some outup in Printer-Queue:


Any hints how to fix this?


Several people have recently reported that trying to print using lp seems to release whatever the blockade is for some printers, such as the method described in this post:

IPP errors are almost worthless, in that there is no good reference for what they mean, and the majority of them seem to have no impact anyway.  (I'm sure some are serious and useful, I just don't know how one is supposed to tell the difference.)  However, you may have better luck using a different protocol (lpd or raw).

Christian S.


Distribution: Kubuntu 12.10
Printing system: cups

I have a similar problem with my Samsung CLX 3185FW printer. I can print over socket connection (ipp does not work at all) but it prints most of the time garbage. A lot of sheets with same printed lines on it are spilt out. I tried different driver samsungmfp-driver-4.00.35, samsungmfp-driver-4.00.36 and samsungmfp-driver-4.00.39 without any success.

In the previous Kubuntu version (12.04) it worked.

Is there any solution to fix it?


I found a solution:

Deinstalling all drivers from your PPA and/or the UnifiedPrinterDriver from Samsung, then just using the printerdialog in systemsettings, new printer, searching for network-printer using the ipp-protocoll and installing it.

The printer works out of the box with Quantal, when every version of the unified printer driver ist removed.


Christian S.


I tried your solution with following result. ipp search did not wrok for CLX 3185FW but it was listed as dnssd://samsung%20clx-3180%20series%20(sec001599912d85)._printer._tcp.local/ printer so I choose this one. As printer driver was suggested Samsung CLX-3175 Foomatic/foo2qpdl [en] (empfohlen). Test pages were printed with success.

Are the features of CLX 3185FW supported from this driver (CLX-3175)?
How can I use the scan function?



If it is working with foomatic, you should be able to install the Samsung driver in parallel, and then just use the Samsung part for scanning support (i.e., install the samsungmfp-scanner package, but don't change anything about the printer setup).

Repository Information Legal Contact Alternative Drivers